Page 1 of 1

Kyocera FS-1220MFP on Mint 18

Posted: Tue Oct 23, 2018 5:20 pm
by RuudWH
I am volunteer for all kinds of computer, tablet and phone problems at Gilde and Seniorweb NL.
I use mainly Win 10 myself and on one laptop I run Linux Mint 18.

Now I am trying to help somebody who had problems with her laptop : Win 10 1803 would not install, so I installed Mint 18 without a problem.
All running fine. I Connected the Kyocera FS-1220MFP wich was recognised by Mint. I tried to print a test page wich went well too.

The lady is not a frequent computer user. Recently she reported that it was not possible to print anything.
Went over there and found the printer in Mint but could not get anything to print.
Maybe drivers ? So I searched for software at the Kyocera site : nothing found.
Tried to find if the printer was supported by Mint and I am not sure if i found the correct list. I saw an FS1200 only.

I will try a new USB cable altough I do not believe that it will solve the problem.

Can anybody tell me if this printer will ever work well please.
If it should, please where will I find the proper software.
Many thanks.