Driver for Epson 4180 photo?

Forum rules
Before you post please read this
Post Reply
Biggvs Richardvs
Level 1
Level 1
Posts: 2
Joined: Fri Oct 26, 2018 6:13 am

Driver for Epson 4180 photo?

Post by Biggvs Richardvs » Fri Oct 26, 2018 7:11 pm

Hello,

Trying to get an Epson Perfection 4180 Photo scanner working in Mint 18. Ya - "Perfection" - my pinky toe.

Running pretty generic HP hardware. Kernel sees it thusly:
[32877.049309] usb 3-4: new high-speed USB device number 5 using xhci_hcd
[32877.200524] usb 3-4: New USB device found, idVendor=04b8, idProduct=0118
[32877.200534] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[32877.200539] usb 3-4: Product: EPSON Scanner
[32877.200543] usb 3-4: Manufacturer: EPSON

sane-find-scanner says this:

found USB scanner (vendor=0x138a, product=0x003d) at libusb:001:003
found USB scanner (vendor=0x04b8 [EPSON], product=0x0118 [EPSON Scanner]) at libusb:003:005
# Your USB scanner was (probably) detected. It may or may not be supported by
# SANE. Try scanimage -L and read the backend's manpage.
(I think the first one is my built in laptop camera)

Yet scanimage fails:

scanimage -L -vv

No scanners were identified. If you were expecting something different,

SimpleScan, Scanlite, and Xsane all fail to find a scanner.


So I tried to build the driver from the source the epson hands out, but it bombs saying I need "gtk+" -- not gtk2 or gtk3, but (I assume) 1.0+ or whatever. Old stuff which means lots more will break in the compile.

I tried

I am just hopelessly fooked, or is there some other way to get my otherwise wonderful Mint Laptop talking to this scanner?

I even did a kvm install of windows 7 (gack!) and hoped that spice would pass the usb through so I could use it that way, but windblows doesn't even detect it.

Native solution would be awesome, but I'm fine with kvm win7 too if that gets me running.

Any help would engender my undying gratitude plus free beer or coffee if you can meet up in the Seattle area!

Many thanks,
Rich

Biggvs Richardvs
Level 1
Level 1
Posts: 2
Joined: Fri Oct 26, 2018 6:13 am

Re: Driver for Epson 4180 photo?

Post by Biggvs Richardvs » Sat Oct 27, 2018 4:09 am

Ok guys,

I'm not sure if we should mark this one solved, but I did find a viable workaround.

So I ended up getting it to work on the KVM vm of windows 7. The key was to plug the scanner in, then exit the VM and go into its configuration (vm still running), right click on the list of stuff on the left and choose "add new hardware." Then I added a new "USB Host Device" and I chose the scanner from there. Once I did that it made the little two tone windows sound in the vm of a new device being plugged in, and the driver install ran pretty normally.

I did have to go into device manager in windows and do a manual update of the driver and navigate to the directory with the driver and tell it to look for it there. Then Epson's scanner software worked like a charm.

Hope that helps someone save banging their head against the wall like I did.

Post Reply

Return to “Printers & Scanners”