Page 1 of 1

SOLVED (sort of :) Outdated HPLIP driver package for my HP 410 Printer

Posted: Tue Jan 08, 2019 1:21 pm
by magar
My Mint 19 distro includes HPLIP version 3.17.10 and I need version 3.18.7 or better.
I downloaded version 3.18.12 from
https://developers.hp.com/hp-linux-imag ... g/gethplip
and executed the following command:
sh hplip-3.18.12.run
All well until I encountered this warning:
QUOTE
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information. Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.
UNQUOTE
Since i'm new to linux, i aborted the installation.
How should i proceed?

Re: Outdated HPLIP driver package for my HP 410 Printer

Posted: Tue Jan 08, 2019 1:39 pm
by yertchuk
I did this HPLIP installation yesterday, and encountered the same warning. Since I know I can always use Timeshift to get back to my previous state, I went ahead with the installation, followed all the prompts, and everything worked correctly.

Re: Outdated HPLIP driver package for my HP 410 Printer

Posted: Wed Jan 09, 2019 7:01 am
by lsemmens
magar wrote:
Tue Jan 08, 2019 1:21 pm
My Mint 19 distro includes HPLIP version 3.17.10 and I need version 3.18.7 or better.?
Begs the question. Who, or what, told you you need 3.18.7 or better? Did you try ver 3.17.10? I've had no real issues with the version in the official repositories.

Re: Outdated HPLIP driver package for my HP 410 Printer

Posted: Wed Jan 09, 2019 7:16 am
by srq2625
I did a quick look and found that there is one "410" printer that requires 3.18.7, called "HP Ink Tank Wireless 410". Everything else with "410" in the name requires HPLIP 3.10.9 or older.

Take a look at the post linked in my signature for a couple of ways to get the HP drivers installed.

Re: Outdated HPLIP driver package for my HP 410 Printer

Posted: Thu Jan 10, 2019 7:46 pm
by jimallyn
Just a general note to all asking questions about printers here: Just giving the brand and number of your computer often isn't enough. It could be an OfficeJet 410, or a DeskJet 410, a PhotoSmart 410, an Envy 100 d410, a PSC 410, and god-only-knows how many other possibilities. More information is needed for anyone to be able to help you.

Re: Outdated HPLIP driver package for my HP 410 Printer

Posted: Fri Jan 18, 2019 11:21 am
by magar
srq2625 wrote:
Wed Jan 09, 2019 7:16 am
I did a quick look and found that there is one "410" printer that requires 3.18.7, called "HP Ink Tank Wireless 410".
Yeah, that's mine.
Thank you all for your help!
Will follow the suggestion of yertchuck trusting Timeshift as a fallback.

Re: Outdated HPLIP driver package for my HP 410 Printer

Posted: Fri Jan 18, 2019 3:10 pm
by brian_p
Why is HPLIP needed for printing with this device?

https://wiki.debian.org/DriverlessPrinting

Re: Outdated HPLIP driver package for my HP 410 Printer

Posted: Tue Jan 22, 2019 12:43 pm
by magar
magar wrote:
Fri Jan 18, 2019 11:21 am
srq2625 wrote:
Wed Jan 09, 2019 7:16 am
I did a quick look and found that there is one "410" printer that requires 3.18.7, called "HP Ink Tank Wireless 410".
Will follow the suggestion of yertchuck trusting Timeshift as a fallback.
So I did and it worked fine, at least for the printing capability of my HP ITW 410.
Still missing the scanner part, but for now I'll use the Simple Scan app.
Thanks again!

Re: SOLVED (sort of :) Outdated HPLIP driver package for my HP 410 Printer

Posted: Tue Jan 22, 2019 2:29 pm
by brian_p
Still missing the scanner part, but for now I'll use the Simple Scan app.
If simple-scan works, you are not missing scanning functionality.