Missing print filter Canon IP2200 and Driver help

Forum rules
Before you post please read this
User avatar
ClixTrix
Level 6
Level 6
Posts: 1068
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Missing print filter Canon IP2200 and Driver help

Post by ClixTrix » Wed Feb 06, 2019 8:03 pm

Yeah.....seems to be a conflict with openprinting saying the guten does work and guten saying no way. Confusing.....but maybe it unofficially works. I just remember that lsb was needed for an old Canon (like many old USB printers). Not saying you're wrong Brian.....just worth a try. :wink:

http://www.openprinting.org/printer/Can ... XMA-iP2200
Linux Mint 19.1 x64 Cinnamon 4.15.0-47-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 EVO 250GB + Toshiba OCZ VX500 512GB

Kit
Level 1
Level 1
Posts: 26
Joined: Tue Jan 23, 2018 8:06 pm

Re: Missing print filter Canon IP2200 and Driver help

Post by Kit » Fri Feb 08, 2019 10:55 am

brian_p wrote:
Wed Feb 06, 2019 7:53 pm
https://sourceforge.net/projects/gimp-p ... /NEWS/view
* The following Canon printer models were either not added, or removed, as they cannot currently be supported, even experimentally, owing to an as-yet unknown command format or other issues:
The Canon PIXMA iP2200 is listed.
From list of drivers
"Canon PIXMA iP2200 - CUPS+Gutenprint (OpenPrinting LSB 3.2) v5.2.7 Simplified"

This doesn't work, filter is missing. Guess its new printer time :(

User avatar
ClixTrix
Level 6
Level 6
Posts: 1068
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Missing print filter Canon IP2200 and Driver help

Post by ClixTrix » Fri Feb 08, 2019 12:52 pm

Well, this is interesting. I downloaded the 5.2.7 (Deb for LSB 3.2) package linked at openprinting and extracted to see what it has.

Guess what? It does indeed have support for the Canon PIXMA-iP2200. In fact here is the first lines in the PPD for the printer.

Code: Select all

*PPD-Adobe: "4.3"
*% PPD file for CUPS/Gutenprint.
*% Copyright 1993-2008 by Mike Sweet and Robert Krawitz.
*% This program is free software; you can redistribute it and/or
*% modify it under the terms of the GNU General Public License,
*% version 2, as published by the Free Software Foundation.
*%
*% This program is distributed in the hope that it will be useful, but
*% WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
*% or FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
*% for more details.
*%
*% You should have received a copy of the GNU General Public License
*% along with this program; if not, write to the Free Software
*% Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
*%
*FormatVersion:	"4.3"
*FileVersion:	"5.2.7"
*LanguageVersion: English
*LanguageEncoding: UTF-8
*PCFileName:	"STP00045.PPD"
*Manufacturer:	"Canon"
*Product:	"(Canon PIXMA iP2200)"
*ModelName:     "Canon PIXMA iP2200"
*ShortNickName: "Canon PIXMA iP2200"
*NickName:      "Canon PIXMA iP2200 - CUPS+Gutenprint (OpenPrinting LSB 3.2) v5.2.7"
*PSVersion:	"(3010.000) 0"
*LanguageLevel:	"3"
*ColorDevice:	True
*DefaultColorSpace:	RGB
*FileSystem:	False
*LandscapeOrientation: Plus90
*TTRasterizer:	Type42
*cupsVersion:	1.2
*cupsManualCopies: True
*cupsFilter:	"application/vnd.cups-raster 100 /opt/OpenPrinting-Gutenprint/cups/lib/filter/rastertogutenprint.5.2"
*cupsICCProfile Gray../Grayscale:	"/System/Library/ColorSync/Profiles/sRGB Profile.icc"
*cupsICCProfile RGB../Color:	"/System/Library/ColorSync/Profiles/sRGB Profile.icc"
*cupsICCProfile CMYK../Color:	"/System/Library/ColorSync/Profiles/Generic CMYK Profile.icc"
*APSupportsCustomColorMatching: true
*APDefaultCustomColorMatchingProfile: sRGB
*APCustomColorMatchingProfile: sRGB
Obviously, guten decide to withdraw support at some point. Not saying that package will install and work (or even correctly install). That would take some testing.
Linux Mint 19.1 x64 Cinnamon 4.15.0-47-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 EVO 250GB + Toshiba OCZ VX500 512GB

brian_p
Level 4
Level 4
Posts: 365
Joined: Thu Jan 17, 2019 9:20 am

Re: Missing print filter Canon IP2200 and Driver help

Post by brian_p » Fri Feb 08, 2019 1:31 pm

Not saying that package will install and work (or even correctly install). That would take some testing.
Not a bad idea if you have an hour or two; you never know. I tried it yesterday using packages from

snapshot.debian.org

cups-driver-gutenprint will eventually install but it needs dependencies from snapshot. libtasn1, libgcrypt1 and libgnutls26 are amongst them. I never got round to getting everything to work because, IIRC, I ran out of puff. I also thought the Gutenprint developers were probably right in their judgement and I could use the time for better things.
--
Brian.

Kit
Level 1
Level 1
Posts: 26
Joined: Tue Jan 23, 2018 8:06 pm

Re: Missing print filter Canon IP2200 and Driver help

Post by Kit » Fri Feb 08, 2019 2:42 pm

ClixTrix wrote:
Fri Feb 08, 2019 12:52 pm
Well, this is interesting. I downloaded the 5.2.7 (Deb for LSB 3.2) package linked at openprinting and extracted to see what it has.

Guess what? It does indeed have support for the Canon PIXMA-iP2200. In fact here is the first lines in the PPD for the printer.

(snip)

Obviously, guten decide to withdraw support at some point. Not saying that package will install and work (or even correctly install). That would take some testing.
If you get this working, in a way that's not overly complicated, I would be very interested.

User avatar
ClixTrix
Level 6
Level 6
Posts: 1068
Joined: Wed Dec 09, 2015 11:40 am
Location: Columbus, Ohio, USA

Re: Missing print filter Canon IP2200 and Driver help

Post by ClixTrix » Fri Feb 08, 2019 3:37 pm

I agree with Brian. This is a very old package from back around 2008 and guten took it off their support list for a reason(s) unknown.

As I said earlier, I did download the x64 package. I just tried simple double-click on the downloaded .deb file and brought up the debian installer. The install on my test system seems to go OK with all dependencies installed. I then went to Printers and tried an Add+. Using the Generic CUPS-BFR method I looked to see if it is now listed under Canon printers. Yep, it's there, listed as PIXMA ip2200 with these two Drivers:

Canon PIXMA iP2200 - CUPS+Gutenprint(Openprinting LSB 3.2)v5.2.7 Simplified [en](recommended)
Canon PIXMA iP2200 - CUPS+Gutenprint(Openprinting LSB 3.2)v5.2.7 [en]

Now this is a pretty much pure Mint 19.1 Cinnamon x64 test system, where I do crazy things....when necessary. :lol: I do use Timeshift to restore back, so I have a safe out if any problems were to have happened.

I obviously can't go any further, as I don't have the real printer to compete an install, much less test. It's a do-at-your-own-risk. I would follow my lead and set a restore point with Timeshift before you try, that is, if you decide to try.
Linux Mint 19.1 x64 Cinnamon 4.15.0-47-generic
Gigabyte GA-AB350M-D3H (F20) / Ryzen 5 1600 / Micron Ballistix Sport DDR4 2400 2x8GB / Sapphire Radeon HD6450
NVMe-SSD: Samsung 960 EVO 250GB / SATA-SSD: Samsung 850 EVO 250GB + Toshiba OCZ VX500 512GB

brian_p
Level 4
Level 4
Posts: 365
Joined: Thu Jan 17, 2019 9:20 am

Re: Missing print filter Canon IP2200 and Driver help

Post by brian_p » Fri Feb 08, 2019 4:11 pm

If you get this working, in a way that's not overly complicated, I would be very interested.
Not a chance of my pursuing this further. The iP2200 started life as a Linux unfriendly printer. It ends its life in the same way. Inexpensive printers which fit a modern Mint distribution are available. Try HP. You will be happier.

I am all for keeping old hardware going. We are on your side; Canon isn't.
--
Brian.

Kit
Level 1
Level 1
Posts: 26
Joined: Tue Jan 23, 2018 8:06 pm

Re: Missing print filter Canon IP2200 and Driver help

Post by Kit » Tue Feb 12, 2019 3:09 pm

brian_p wrote:
Fri Feb 08, 2019 4:11 pm
If you get this working, in a way that's not overly complicated, I would be very interested.
Not a chance of my pursuing this further. The iP2200 started life as a Linux unfriendly printer. It ends its life in the same way. Inexpensive printers which fit a modern Mint distribution are available. Try HP. You will be happier.

I am all for keeping old hardware going. We are on your side; Canon isn't.
Sent an email to PC world on what they would recommend. Bye bye IP2200, it was a very good printer

Wompoo
Level 5
Level 5
Posts: 908
Joined: Sat Dec 28, 2013 2:42 am

Canon Pixma IP1600

Post by Wompoo » Fri Mar 01, 2019 6:53 pm

I also have the same problem trying to install my Pixma iP1600 printer into Linux Mint 19.
I strike this every time I upgrade the operating system. Each time, it gets harder. This time I am stumped.

I will start looking for a printer that will be supported for some time onwards. Also, would like one that I can refill the cartridges, as I now have a full refill kit.
Any suggestions?
Desktop PC #2
Linux Mint 19 KDE desktop (64-bit), Asus
CPU E7500, 8 Gb RAM


Desktop #1
Dell Vostro 220 64 bit.
Linux Mint 17.3 Rosa KDE

Dell Inspiron 6000 laptop

Post Reply

Return to “Printers & Scanners”