SOLVED-partially-EPSON WF-3540 no print after 19.1 upgrade

Forum rules
Before you post please read this
Post Reply
krustybaguette
Level 3
Level 3
Posts: 151
Joined: Thu Mar 31, 2011 8:24 am

SOLVED-partially-EPSON WF-3540 no print after 19.1 upgrade

Post by krustybaguette »

system details include Netgear router WNDR 3400.

Printer is connected via ethernet and worked via my wife's Win10 laptop using wifi and my laptop using an ethernet connection. Now neither works. I've tried all I can to get it to "print test page" with no success. I found thread re: failure to "print test page" and tried printing a pdf document. Still no results.
For various reasons I suspect my router may be nearing EOL (end of life) but wonder if it might work if I used the usb connection on my router, which is currently connected to a 1TB backup drive. If I do this will I need to reinstall the printer from scratch, or just edit the current non-working configuration?

Reason this post is marked "SOLVED-partially" is that I've got it printing with decent results but because some color are "off" I decided to run the head cleaning utility. It is nowhere to be found. When I installed the printer I didn't have to browse to the previous driver, but didn't realize that the driver that the OS (or CUPS) found lacks the printer utilities that I had under 18.3.
I have downloaded and installed the driver for this printer from the Epson web site with no change in utilities availability.

The SOLUTION was to install a new router which had no trouble finding the printer. Under 18.3 the printer was doing a disappearing act from both of the computers on our home network. Now it even works from my Android phone under Epson iPrint.
Last edited by krustybaguette on Sat Apr 27, 2019 4:16 pm, edited 2 times in total.
brian_p
Level 6
Level 6
Posts: 1236
Joined: Thu Jan 17, 2019 9:20 am

Re: EPSON WF-3540 no print after 19.1 upgrade

Post by brian_p »

The command

Code: Select all

driverless
gives you a URI.

The command

Code: Select all

lpadmin -p 3540 -v URI -E -m everywhere
surely gives you a working print queue?
--
Brian.
krustybaguette
Level 3
Level 3
Posts: 151
Joined: Thu Mar 31, 2011 8:24 am

Re: EPSON WF-3540 no print after 19.1 upgrade

Post by krustybaguette »

I'm not familiar with the term/acronym URI but the command gave me no results. Since URI is part of the second command I haven't tried that yet.
krusty
brian_p
Level 6
Level 6
Posts: 1236
Joined: Thu Jan 17, 2019 9:20 am

Re: EPSON WF-3540 no print after 19.1 upgrade

Post by brian_p »

I'm not familiar with the term/acronym URI but the command gave me no results.
What is the output of

Code: Select all

lpinfo -v
--
Brian.
Post Reply

Return to “Printers & Scanners”