Page 1 of 1

Canon Printers can't install

Posted: Sat Sep 28, 2019 3:00 am
by Billy60
Good morning
I have 2 canon printers which have their Linux drivers, both in 32 and 64 bits downloaded and running ok on a previous version of Mint (17.3).
I tested 19.2 and they would not be found or the drivers would not install. Those drivers are supposed to be valid for mint 19.2
Those printers are somewhat old but run perfectly.
How could it be explained and what to do ?

Thanks !

Re: Canon Printers can't install

Posted: Sat Sep 28, 2019 3:12 am
by Pierre
what is the Model Number of your Cannon Printers ?

Re: Canon Printers can't install

Posted: Sat Sep 28, 2019 3:38 am
by Billy60
They are:
MF4380DN
MF8350CDN
(both from Isensys series)


Thanks

Canon lasers need UFR driver

Posted: Mon Oct 14, 2019 9:20 pm
by pdc_2
so that needs the UFR driver

https://www.canon-europe.com/support/co ... anguage=en

it comes down as linux-UFRII-drv-v500-uken-04.tar.gz

if you open a terminal; and we assume it lands in Downloads

Code: Select all

cd Downloads

Code: Select all

tar -zxvf linux-UFRII-drv-v500-uken-04.tar.gz

Code: Select all

cd linux-UFRII-drv-v500-uken-04

Code: Select all

sudo ./install.sh
that should

1) install the printer drivers and

2) register the printers; if usb connection? I can only assume one becomes lp0 and other becomes lp1

Re: Canon Printers can't install

Posted: Tue Oct 15, 2019 3:43 am
by Billy60
Good morning and thanks a lot.
I will try this. It seems there is a possibility since I could install one finally but it is deemed connected but does not print.
I'll have to investigate further.

Re: Canon Printers can't install

Posted: Tue Oct 15, 2019 7:25 pm
by pdc_2
thanks Billy;

if usb connected, one will be called lp0 and the next will be lp1

but be aware that whichever is lp0 will always be seen as that; so if you turn on what is lp1 as the first to turn on, the system will not print; lp0 must always be turned on first;

Re: Canon Printers can't install

Posted: Wed Oct 16, 2019 1:42 am
by Billy60
Good morning pdc
Thanks again. I write this message via my Win7 session, because I also have a dual boot issue to solve before using my Mint again.
I will then try and install mint 19.2, hoping my printers will work !

Could you confirm to me one thing: the printer driver you mention and which I have, will work on Mint 17 (32bits) as well as on Mint 19.2 (64 bits) ?
I suppose the CUPS features apply to both 32 and 64 bits or am I wrong ?

Thanks again !

32bit Canon support

Posted: Mon Oct 21, 2019 3:49 pm
by pdc_2
if you download the driver, you can actually check for yourself; Canon were providing 32bit and 64bit; open the package