[SOLVED] epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Forum rules
Before you post please read this
Post Reply
but-it-does-move
Level 1
Level 1
Posts: 30
Joined: Mon Apr 18, 2016 12:42 pm

[SOLVED] epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by but-it-does-move »

My epson-printer-utility debian package which worked fine up through Mint 19.3 doesn't work in Mint 20. I get this error message:

Code: Select all

epson-printer-utility: error while loading shared libraries: libQtCore.so.4: cannot open shared object file: No such file or directory]
I don't know a lot about this stuff, but I suspect it's a qt4/qt5 problem.

I think I need the epson-printer-utility_1.1.1-1lsb3.2_amd64.deb package. After upgrading Mint from 19.3 to 20, my previously installed epson-printer-utility_1.0.2-1lsb3.2_amd64.deb package downloaded from Epson stopped working.

When I go to this web site http://download.ebz.epson.net/dsc/sear ... FromResult and click the "Download" button for "Epson Printer Utility" version 1.1.1 dated 06-24-2020, I get the message "The page you requested is unavailable" As far as I can see, there is no way to contact Epson and tell them about it. The "Printer Driver" and "Scanner Driver" downloads seem to work fine.

I've been searching for the version 1.1.1 package with no success. Maybe I just have poor search skills. Anyone know where I can get it? Thanks.
Last edited by but-it-does-move on Wed Sep 16, 2020 1:55 pm, edited 1 time in total.
but-it-does-move
Level 1
Level 1
Posts: 30
Joined: Mon Apr 18, 2016 12:42 pm

Re: epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by but-it-does-move »

Well, Epson has made some progress on their web site. The download button for the deb package epson-printer-utility_1.1.1-1lsb3.2_amd64.deb now works and the date for the package is 07-13-2020. However, the file size for the new downloaded deb package is only 1.3MB compared to my previously working package which has a file size of 3.4MB. I'm suspicious.

While the package installs OK, running the epson-printer-utility command generates the same error I got previously:

Code: Select all

$ epson-printer-utility
epson-printer-utility: error while loading shared libraries: libQtCore.so.4: cannot open shared object file: No such file or directory
Does anyone know if the 4 in libQtCore.so.4 refers to qt4 and if so, is there a way to install libQtCore.so.4? Thanks.
milasx
Level 2
Level 2
Posts: 67
Joined: Mon Jul 02, 2018 5:24 am

Re: epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by milasx »

I have the same issue - did you manage to solve it?
but-it-does-move
Level 1
Level 1
Posts: 30
Joined: Mon Apr 18, 2016 12:42 pm

Re: epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by but-it-does-move »

Sorry to say I haven't solved it.

I have a machine with Trisquel 8 on it that uses the Linux 4.4 kernel and I think it has QT4 rather than QT5 on it as well. That machine will run the epson printer utility successfully. I continue to suspect that it's a QT4/QT5 issue. I don't know if it's possible to run both QT4 and QT5 on Linux Mint 20, but my guess is if that were possible, it would fix the problem.

I don't know how anyone can use an Epson printer without the software to clean the heads and perform a nozzle check. If there's a way to contact Epson and discuss this problem with them, I don't know what it is.

Good luck!
User avatar
kelebek333
Level 4
Level 4
Posts: 270
Joined: Sat Jun 25, 2011 11:57 am
Location: Türkiye
Contact:

Re: epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by kelebek333 »

Hi,

You can install QT4 dependencies with following commands for Linux Mint 20.x.

Code: Select all

sudo add-apt-repository ppa:gezakovacs/ppa
sudo apt update
sudo apt install libqtcore4 libqtgui4
but-it-does-move
Level 1
Level 1
Posts: 30
Joined: Mon Apr 18, 2016 12:42 pm

Re: [SOLVED]epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by but-it-does-move »

Thank you @kelebek333! Teşekkür ederim!' I can now see my epson printer ink levels and clean my heads again!

@milasx: I'm running epson-printer-utility_1.1.1-1lsb3.2_amd64.deb downloaded from the epson web site http://download.ebz.epson.net/dsc/du/02 ... 4530efcef8 This is the latest version of the utility. Just follow @kelebek333's instructions. 3 lines entered into a terminal. Oddly, when adding the PPA, mention is made of the USB pen drive writing utility UNETBOOTIN, but that doesn't get installed. Ah, computers.

As I suspected from the start, it was a missing QT4 problem.
User avatar
kelebek333
Level 4
Level 4
Posts: 270
Joined: Sat Jun 25, 2011 11:57 am
Location: Türkiye
Contact:

Re: [SOLVED]epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by kelebek333 »

You are welcome.

There are several PPA repositories available for installing QT4 packages to Linux Mint 20.x series. I thought a PPA repository owned by the Unetbootin developer could be more reliable.

Note: If Unetbootin PPA repository is added, you can install the application with the command below.

Code: Select all

sudo apt install unetbootin unetbootin-translations
but-it-does-move
Level 1
Level 1
Posts: 30
Joined: Mon Apr 18, 2016 12:42 pm

Re: [SOLVED] epson-printer-utility doesn't work after Mint 19.3 to 20 upgrade

Post by but-it-does-move »

@kelebek: Thanks again. I don't need unetbootin but I'll leave its PPA in place. I don't know if removing that PPA would also uninstall qt4 and I'm happy to have epson-printer-utility working again.
Post Reply

Return to “Printers & Scanners”