XSANE crash after scan

Forum rules
Before you post please read this
Post Reply
nimi
Level 1
Level 1
Posts: 1
Joined: Fri Oct 16, 2020 4:18 pm

XSANE crash after scan

Post by nimi »

Hello and nice to meet you! :)

Linux Mint Ulyana here with XSANE 0.999.
Please let me know what other information is required!

Code: Select all

water@water:~$ coredumpctl info 3297
           PID: 3297 (xsane)
           UID: 1000 (water)
           GID: 1000 (water)
        Signal: 6 (ABRT)
     Timestamp: Fri 2020-10-16 22:02:58 CET (3min 42s ago)
  Command Line: xsane
    Executable: /usr/bin/xsane
 Control Group: /user.slice/user-1000.slice/user@1000.service/dbus.service
          Unit: user@1000.service
     User Unit: dbus.service
         Slice: user-1000.slice
     Owner UID: 1000 (water)
       Boot ID: a7999cb556124b54bf01d699916b44c2
    Machine ID: 2e6db7b3feeb408ba59f7482257bc249
      Hostname: water
       Storage: /var/lib/systemd/coredump/core.xsane.1000.a7999cb556124b54bf01d699916b44c2.3297.1>
       Message: Process 3297 (xsane) of user 1000 dumped core.

                Stack trace of thread 3297:
                #0  0x00007fcf2a9ad18b __GI_raise (libc.so.6 + 0x4618b)
                #1  0x00007fcf2a98c859 __GI_abort (libc.so.6 + 0x25859)
                #2  0x00007fcf2a9f73ee __libc_message (libc.so.6 + 0x903ee)
                #3  0x00007fcf2a9ff47c malloc_printerr (libc.so.6 + 0x9847c)
                #4  0x00007fcf2aa0112c _int_free (libc.so.6 + 0x9a12c)
                #5  0x00007fcf24a369cd sane_escl_read (libsane-escl.so.1 + 0x79cd)
                #6  0x0000556db3cf57d0 n/a (xsane + 0x827d0)
                #7  0x0000556db3cf4b31 n/a (xsane + 0x81b31)
                #8  0x0000556db3cf6b66 xsane_scan_dialog (xsane + 0x83b66)
                #9  0x00007fcf2afc1802 g_closure_invoke (libgobject-2.0.so.0 + 0x14802)
                #10 0x00007fcf2afd5814 n/a (libgobject-2.0.so.0 + 0x28814)
                #11 0x00007fcf2afe0b9e g_signal_emit_valist (libgobject-2.0.so.0 + 0x33b9e)
                #12 0x00007fcf2afe10d3 g_signal_emit (libgobject-2.0.so.0 + 0x340d3)
                #13 0x00007fcf2b15d22e n/a (libgtk-x11-2.0.so.0 + 0x9522e)
                #14 0x00007fcf2afc1802 g_closure_invoke (libgobject-2.0.so.0 + 0x14802)
                #15 0x00007fcf2afd5962 n/a (libgobject-2.0.so.0 + 0x28962)
                #16 0x00007fcf2afe0b9e g_signal_emit_valist (libgobject-2.0.so.0 + 0x33b9e)
                #17 0x00007fcf2afe10d3 g_signal_emit (libgobject-2.0.so.0 + 0x340d3)
                #18 0x00007fcf2b15c0a9 n/a (libgtk-x11-2.0.so.0 + 0x940a9)
                #19 0x00007fcf2b205b9b n/a (libgtk-x11-2.0.so.0 + 0x13db9b)
                #20 0x00007fcf2afc1802 g_closure_invoke (libgobject-2.0.so.0 + 0x14802)
                #21 0x00007fcf2afd4f96 n/a (libgobject-2.0.so.0 + 0x27f96)
                #22 0x00007fcf2afe045d g_signal_emit_valist (libgobject-2.0.so.0 + 0x3345d)
                #23 0x00007fcf2afe10d3 g_signal_emit (libgobject-2.0.so.0 + 0x340d3)
                #24 0x00007fcf2b32122d n/a (libgtk-x11-2.0.so.0 + 0x25922d)
                #25 0x00007fcf2b203ccc gtk_propagate_event (libgtk-x11-2.0.so.0 + 0x13bccc)
                #26 0x00007fcf2b2040c3 gtk_main_do_event (libgtk-x11-2.0.so.0 + 0x13c0c3)
                #27 0x00007fcf2b06c6d0 n/a (libgdk-x11-2.0.so.0 + 0x5f6d0)
                #28 0x00007fcf2aed3fbd g_main_context_dispatch (libglib-2.0.so.0 + 0x51fbd)
                #29 0x00007fcf2aed4240 n/a (libglib-2.0.so.0 + 0x52240)
                #30 0x00007fcf2aed4533 g_main_loop_run (libglib-2.0.so.0 + 0x52533)
                #31 0x00007fcf2b203092 gtk_main (libgtk-x11-2.0.so.0 + 0x13b092)
                #32 0x0000556db3d06e13 n/a (xsane + 0x93e13)
                #33 0x0000556db3c96a76 main (xsane + 0x23a76)
                #34 0x00007fcf2a98e0b3 __libc_start_main (libc.so.6 + 0x270b3)
                #35 0x0000556db3c96b4e _start (xsane + 0x23b4e)
Background:
New Printer/Scanner - Canon TS5300 Series, WiFi connection, no issues connecting.
Scanning with SimpleScan does work without issues, but the Scanner is not good. The lamp is really lame and scanned pages have blue taint.
Thus, I tried XSANE where contrast correction is possible and removing the blue taint, but then after the first page XSANE dumps.

Thanks for any help.
Post Reply

Return to “Printers & Scanners”