Can't install hplip 3.10.6

Forum rules
Before you post please read this
Post Reply
fedefun34
Level 1
Level 1
Posts: 4
Joined: Tue Sep 21, 2010 6:02 pm

Can't install hplip 3.10.6

Post by fedefun34 »

Just bought a new HP Laserjet M1212nf MFP. it shows as being supported under HPLIP 3.10.6
I'm running Linux Mint 9

I downloaded the package (hplip 3.10.6) but when I try to run the install package I get an installation error: see below


INTRODUCTION
------------
This installer will install HPLIP version 3.10.6 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).


DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Linux Mint 9.

Is "Linux Mint 9" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y


ENTER USER PASSWORD
-------------------
Please enter password:
Password accepted


RUNNING PRE-INSTALL COMMANDS
----------------------------
OK


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
warning: There are 7 missing REQUIRED dependencies.
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: This installer cannot install 'gcc' for your distro/OS and/or version.
error: Installation cannot continue without this dependency. Please manually install this dependency and re-run this installer.


I go to package manager and it show that gcc is installed and hplip 3.10.2 is installed. However that version of hplip does not seem to have a driver for my printer, I was hoping to upgrade it to 3.10.6 so that I can use it. Does Mint 9 run with a later hplip version?
is there any work around?

thanks

User avatar
beefstu
Level 5
Level 5
Posts: 652
Joined: Tue Dec 29, 2009 10:22 am
Location: Southampton, UK

Re: Can't install hplip 3.10.6

Post by beefstu »

go to a terminal and type

Code: Select all

apt install build-essential
then your password if its asked for then try installing the HPLIP again
Please go through the steps here when posting a question. Once your question has been resolved, edit the original question post and add [Solved] to the subject. Both of these will help others use the forum effectively.

pdc_2
Level 8
Level 8
Posts: 2416
Joined: Mon May 11, 2009 1:21 am

Re: Can't install hplip 3.10.6

Post by pdc_2 »


focalguy
Level 1
Level 1
Posts: 23
Joined: Wed Dec 12, 2007 2:54 pm
Contact:

Re: Can't install hplip 3.10.6

Post by focalguy »

Did you ever figure this out? I have the same printer and I got hplip installed doing it the manual way but there is no PPD file for my printer. I tried some others and it didn't work.

User avatar
Gramps50
Level 4
Level 4
Posts: 238
Joined: Sun Dec 13, 2009 1:36 am

Re: Can't install hplip 3.10.6

Post by Gramps50 »

I have a HP OJ 6500e Plus which I need the same hplip as mentioned above. I also could not get it to install with either Mint 9 or Mint 10 so I told it I was using the Ubuntu 10.04 (I think this is right) anyway pick the version of Ubuntu equal to your version of Mint and then it should work. It did for me.

My main problem was not getting the printer to print that worked fine with the old version of hplip didn't have all the function but it would print. I couldn't get it to see the scanner with 3.10.6 the scanner works but not reliblebly. I tried everything and finally gave up as I can scan to a SD card from the control panel and that works rather well. I tried LM9, LM10, LMDE and had the same problem with all even though hplip says that it's supported but not recommended. Didn't know that when I bought it but I got such a good deal I just couldn't take it back.

Googd luck
LMDE ROCKS!!!

focalguy
Level 1
Level 1
Posts: 23
Joined: Wed Dec 12, 2007 2:54 pm
Contact:

Re: Can't install hplip 3.10.6

Post by focalguy »

Thanks Gramps. I think I'm actually on 3.10.9 or whatever the latest is but I couldn't find my printer in the list of PPD files. I did finally find it last night after trying the CUPS install on the web interface. It was still difficult because of the order they are in. I was looking in the "HP Laserjet mxxxxx" printers but it was further down the list as "HP Laserjet Professional mxxxx". Found it in there and then when I went to add it through the hp-setup utility, the PPD was listed. Funny thing was when I browsed I couldn't find it but since it was already there I just left the selection and got it working. Finally I just went to bed after it printed a test page. I hope I can get it scanning and all. Haha.

Post Reply

Return to “Printers & Scanners”