Cannot share files to win98 on network

Questions about Wi-Fi and other network devices, file sharing, firewalls, connection sharing etc
Forum rules
Before you post please read how to get help
Post Reply
KT-GB-12
Level 1
Level 1
Posts: 47
Joined: Thu Jan 28, 2021 11:18 am

Cannot share files to win98 on network

Post by KT-GB-12 »

Mint+MATE 21
Hi, I have an old machine that runs bespoke control-software in win98se/DOS. Remmina connects to the IP address and allows me to control it all just fine. A Ping to the IP also works fine.

I need to transfer files to the win98 but it does not have USB sockets, only a 3-1/2" floppy. Huh? What's that!! :D

I tried installing a USB card but win98se refuses to boot, probably no drivers pre-installed for it.

I found this viewtopic.php?t=363989
I installed Samba as directed by the included links, but the "client min protocol = NT1" etc made no difference.

How can I transfer files to win98se?

Thanks
Ryzen 5 4500, 16GB, 500GB, ext4, LM-20.1, Cinnamon -- all stock-LM and updated daily.
User avatar
hglee
Level 6
Level 6
Posts: 1423
Joined: Fri Jun 22, 2018 4:31 pm

Re: Cannot share files to win98 on network

Post by hglee »

KT-GB-12 wrote:
Sat Oct 01, 2022 3:14 pm
How can I transfer files to win98se?


Every PC once had a couple of RS-232 serial ports -- for a mouse, modem, etc. There was software and a cable to transfer RS-232 to RS-232, Now there are USB to RS-232 adapters.

There was something similar to copy across prarallel printer ports.

Or, depending on the size of the file, an email attachment.

Linux Mint 21 Vanessa, MATE 1.26.0, kernel 5.15.0*, Dell 2-in-1
AMD Ryzen 7 5825U / Barcelo iGPU - 14" WUXGA Touchscreen
MediaTek MT7921 WiFi-6 BT-5.2; 32GB DDR4@3200MHz; XPG 2TB-NVMe
RowlandP
Level 3
Level 3
Posts: 129
Joined: Tue Jan 26, 2021 7:30 am

Re: Cannot share files to win98 on network

Post by RowlandP »

I suggest you open a terminal, type 'man smb.conf' and read the part about 'lanman auth', then add;

Code: Select all

ntlm auth = yes
lanman auth = yes
To your smb.conf
KT-GB-12
Level 1
Level 1
Posts: 47
Joined: Thu Jan 28, 2021 11:18 am

Re: Cannot share files to win98 on network

Post by KT-GB-12 »

RowlandP wrote:
Sun Oct 02, 2022 10:02 am
I suggest you open a terminal, type 'man smb.conf' and read the part about 'lanman auth', then add;
I appreciate the help, but not the tone regarding "man". It is easy if one knows what they are looking for, I did not. I had looked through the "man" before posting, but unable to guess what might help or hinder, nothing jumped out to me hence the request here.

I added the 2-lines you suggested but it made no difference. Same error message.

I remembered I have an old PC with win2000 (w2K) on it that used to connect with the win98 machine so I dusted off the cobwebs and fired it up. Sure enough, it connects fine as a "Drive" to win98 all on the same Network Gateway.

I went back to the office PC and and tried to connect to it and I get a Password box, a good start. But, it does not accept the password for the w2K box and yes, the local user (Office) has an SMB User and Password. defined that is the same as the w2K box login.

So here I be, tantalizing close. :)
Ryzen 5 4500, 16GB, 500GB, ext4, LM-20.1, Cinnamon -- all stock-LM and updated daily.
RowlandP
Level 3
Level 3
Posts: 129
Joined: Tue Jan 26, 2021 7:30 am

Re: Cannot share files to win98 on network

Post by RowlandP »

KT-GB-12 wrote:
Mon Oct 03, 2022 2:17 pm
[
I appreciate the help, but not the tone regarding "man". It is easy if one knows what they are looking for, I did not. I had looked through the "man" before posting, but unable to guess what might help or hinder, nothing jumped out to me hence the request here.
There was no tone intended, it was a simple suggestion to run a series of commands to get to the information about lanman auth, which is the only thing that a Win95/98 computer will understand. A Win2k computer comes from the same era and as such will also understand lanman auth, something that we turned off in Samba, it is even more insecure than SMBv1, something else that is now turned off by default.

When you added the lines to your smb.conf, did you restart Samba and change the users password, if you didn't, then your user will still not have the lanman password.
Post Reply

Return to “Networking”