WiFi not found after installation

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

WiFi not found after installation

Postby pinckston » Mon Sep 11, 2017 2:55 pm

Hi all, only just joined but have been using Linux for a few years and this has got me stumped. I've Googled for days for a solution avoiding ndiswrapper and the like.

My WiFi will not work at all from a hdd install, with any of 30+ distros I've tried! Yet with Mint it works but only from a live session!? As soon as I install I get device not ready on network manager. I've tried every driver trick Google has to offer (broadcom 4965agn), no dice.

So, I wondered, could the booted contents of the live USB be transferred to an ex4 partition and then booted from hdd in the same configuration as if it was running live? In this way preserving the working WiFi.

Any other possible solutions would also be welcome, I'll gladly post any shell command results required.

Many thanks to all that can help.
Last edited by WharfRat on Tue Sep 12, 2017 8:58 am, edited 1 time in total.
Reason: Changed subject line

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Mon Sep 11, 2017 3:21 pm

Hello pinckston Image

Welcome to Linux Mint and the Linux Mint forum :)

That is strange indeed :?

Start with running inxi -Fzxxx from your installed version then boot the live media and do the same.

Compare the kernel version and network information from both.

You can paste them back here too so others can take a look :wink:
Last edited by WharfRat on Tue Sep 12, 2017 8:59 am, edited 1 time in total.
Reason: Changed subject line
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Mon Sep 11, 2017 3:33 pm

Forgot to mention, I am booting live in compatibility mode to get it working, just about to run requested command on live, will post shortly.
Last edited by WharfRat on Tue Sep 12, 2017 9:00 am, edited 1 time in total.
Reason: Changed subject line

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Mon Sep 11, 2017 3:46 pm

Ok, ran in both environments. Kernel is identical ; 3.13.0-24-generic i686 gcc= 4.8.2.. I have installed mint 17 in the hope that older is may work!

From hdd, no network information at all, not even a heading. In live;

Card-1:intel pro/wireless 4965, driver iwl4965 version in tree, bus id 02:00.0
Last edited by WharfRat on Tue Sep 12, 2017 9:00 am, edited 1 time in total.
Reason: Changed subject line

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Mon Sep 11, 2017 4:13 pm

What does rfkill list show :?:
Last edited by WharfRat on Tue Sep 12, 2017 9:00 am, edited 1 time in total.
Reason: Changed subject line
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Mon Sep 11, 2017 4:46 pm

No blocks, live or hdd.
Last edited by WharfRat on Tue Sep 12, 2017 9:11 am, edited 1 time in total.
Reason: Changed subject line

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Mon Sep 11, 2017 5:01 pm

Just from your installed version what about awk '/Network/,/Kernel/' <(lspci -k)
Last edited by WharfRat on Tue Sep 12, 2017 9:01 am, edited 1 time in total.
Reason: Changed subject line
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Mon Sep 11, 2017 5:14 pm

Pro wireless 4965agn

Subsystem : intel corporation pro/wireless 4965 ag or agn

Kernel driver iwl4965
Last edited by WharfRat on Tue Sep 12, 2017 9:01 am, edited 1 time in total.
Reason: Changed subject line

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Mon Sep 11, 2017 5:17 pm

It looks like your typing this info here, are you logged in to a desktop session or is there other problems beyond the wireless that you are experiencing :?:
Last edited by WharfRat on Tue Sep 12, 2017 9:02 am, edited 1 time in total.
Reason: Changed subject line
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Mon Sep 11, 2017 5:20 pm

Having to type it on my phone, no wired connection and tethering is very flaky also. Trying to give the pertinent details where possible, but literal details when necessary.
Last edited by WharfRat on Tue Sep 12, 2017 9:02 am, edited 1 time in total.
Reason: Changed subject line

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Mon Sep 11, 2017 5:31 pm

pinckston wrote:Having to type it on my phone, no wired connection and tethering is very flaky also. Trying to give the pertinent details where possible, but literal details when necessary.

OK, I got it.

Unfortunately the next step would be to run a wireless script located here and that's not possible.

What you might want to do is follow that thread as the poster seems to be experiencing a similar situation.

I might change the subject and move this topic to the wireless section if no one else comes along, It will get better visibility in the wireless section.

I'm not an expert with networks so I'm hoping someone more knowledgeable will jump in here.
Last edited by WharfRat on Tue Sep 12, 2017 9:02 am, edited 1 time in total.
Reason: Changed subject line
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Mon Sep 11, 2017 5:34 pm

That sounds good, it's getting late here and I can pick it up again tomorrow, hopefully a few more ideas will be floating around. Thanks for your time and help.
Last edited by WharfRat on Tue Sep 12, 2017 9:03 am, edited 1 time in total.
Reason: Changed subject line

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Mon Sep 11, 2017 5:38 pm

pinckston wrote:That sounds good, it's getting late here and I can pick it up again tomorrow, hopefully a few more ideas will be floating around. Thanks for your time and help.

No problem. I'll notify you with a PM if I do move it :wink:
Last edited by WharfRat on Tue Sep 12, 2017 9:03 am, edited 1 time in total.
Reason: Changed subject line
Image ImageImage

zaqcroyd
Level 1
Level 1
Posts: 38
Joined: Sun Aug 20, 2017 5:11 pm

Re: WiFi not found after installation

Postby zaqcroyd » Mon Sep 11, 2017 8:38 pm

This is a long shot, but could you have a situation similar to the one described in https://www.ghacks.net/2015/03/27/how-to-get-wifi-working-in-linux-mint-after-installation/

If so, the Driver Manager from the HDD install might be able to just pick the necessary driver up from the Live USB?
Last edited by WharfRat on Tue Sep 12, 2017 9:03 am, edited 1 time in total.
Reason: Changed subject line

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Tue Sep 12, 2017 3:31 pm

I've tried that on most distros that I installed, at least the debian/Ubuntu variants. I'll give it a go when I get time though but not at all optimistic. Has anyone got any ideas regarding transferring the working live environment directly to the hdd and making it bootable (install grub, etc.)? Even if extremely difficult, it might be a good case study, so to speak.

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Tue Sep 12, 2017 3:55 pm

pinckston wrote:I've tried that on most distros that I installed, at least the debian/Ubuntu variants. I'll give it a go when I get time though but not at all optimistic. Has anyone got any ideas regarding transferring the working live environment directly to the hdd and making it bootable (install grub, etc.)? Even if extremely difficult, it might be a good case study, so to speak.

That might be possible, but I would like to try one thing and that's is chrooting from the live media to the installed version and upgrading to the latest applications and kernel.

Doing this might just fix the problem. A lot had been updated since the iso's were spun.

It's up to you whether or not to reinstall 18.2, but it might make things easier.
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 8:41 am

I can reinstall 18.2, no problem, will attend to it this evening after the toddlers have been put to bed(can't do anything with a 2 and 4 year old running around!).

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 2:16 pm

Just checked driver manager, it seems that it's "sl-modem daemon" that's not working, if that has any bearing on the situation.

User avatar
WharfRat
Level 19
Level 19
Posts: 9505
Joined: Thu Apr 07, 2011 8:15 pm

Re: WiFi not found after installation

Postby WharfRat » Wed Sep 13, 2017 2:31 pm

pinckston wrote:Just checked driver manager, it seems that it's "sl-modem daemon" that's not working, if that has any bearing on the situation.

I don't believe that would have any relevance with the WIFI situation.

If/when you're running from the live media, paste back blkid so I can determine the mint partition for the chroot.
Image ImageImage

pinckston
Level 1
Level 1
Posts: 21
Joined: Mon Sep 11, 2017 2:30 pm

Re: WiFi not found after installation

Postby pinckston » Wed Sep 13, 2017 2:35 pm

Will do, just redownloading 18.2, be back in 20-30 min.


Return to “Wireless”

Who is online

Users browsing this forum: No registered users and 2 guests