"Not authorized to control networking"

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

"Not authorized to control networking"

Post by johnywhy » Mon Aug 20, 2018 8:01 pm

Mint 19 xfce

I login as non-root user. I updated my Mint yesterday.
Now, when i click on a connection in the network manager panel-applet, i get "Not authorized to control networking"

I'm guessing i need to do one of the following:
- add user to netdev group https://askubuntu.com/a/304181
- change configuration of DBus policy file https://superuser.com/a/219140
- do something with polkit https://askubuntu.com/a/752168/412839

Or...?

What do folks recommend?

THX
Last edited by johnywhy on Tue Aug 21, 2018 3:28 pm, edited 2 times in total.
Mint 19 xfce. Semi-noob

User avatar
trytip
Level 8
Level 8
Posts: 2058
Joined: Tue Jul 05, 2016 1:20 pm

Re: "Not authorized to control networking"

Post by trytip » Mon Aug 20, 2018 8:38 pm

find $HOME ! -user $USER -type f
more likely you have some permission issues again. after updating crucial components did you reboot?
Image

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: "Not authorized to control networking"

Post by johnywhy » Thu Aug 23, 2018 7:31 pm

Yep, rebooted after update.
When logged in as Admin user, i can connect/disconnect using nm-applet.
But when logged in as Desktop user, i can see the nm-applet in panel, but "disconnect" is grayed out. If i click anything, i get "Not authorized to control networking".

i applied this config in

Code: Select all

/etc/polkit-1/localauthority/10-vendor.d/org.freedesktop.NetworkManager.pkla

Code: Select all

[nm-applet]
Identity=unix-group:netdev
Action=org.freedesktop.NetworkManager.*
ResultActive=yes
ResultAny=yes
ResultInactive=no
and i ensured the user is a member of netdev.
https://askubuntu.com/a/708262

But still cannot connect/disconnect with nm-applet. Also tried

Code: Select all

Action=NetworkManager
, but no luck.

i confirmed polkit agent is running

Code: Select all

$ ps -ef | grep polkit-gnome
johny     1292  1150  0 16:39 ?        00:00:00 /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
johny     2065  2054  0 16:45 pts/0    00:00:00 grep --color=auto polkit-gnome
But maybe i don't need the agent? "if you use gnome-shell, you do not need /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 because gnome-shell has its own agent incorporated" https://bbs.archlinux.org/viewtopic.php ... 2#p1099562

i noticed "NetworkManager" is not listed when i do pkaction. Should it be?

Not sure if this is related, but I'm getting

Code: Select all

$ pkaction -v -a org.freedesktop.NetworkManager.settings.modify.system
No action with action id org.freedesktop.NetworkManager.settings.modify.system
https://mail.gnome.org/archives/network ... 00039.html

NetworkManager appears to be running, as Mint connects to previously-stored wiki on boot, and In Task Manager, i see
NetworkManager --no-daemon
nm-applet

Maybe i need to use

Code: Select all

/etc/dbus-1/system.d/NetworkManager.conf
? Something like:

Code: Select all

        <policy group="network">
                <allow send_destination="org.freedesktop.NetworkManager"/>
                <allow send_interface="org.freedesktop.NetworkManager"/>
        </policy>
https://gist.github.com/gsongsong/36fc7 ... b391cb98f9
https://developer.gnome.org/NetworkMana ... .conf.html
https://superuser.com/questions/219108/ ... 140#219140

Or, maybe need to use

Code: Select all

Action=org.freedesktop.NetworkManager.settings.modify.system
https://bugs.launchpad.net/ubuntu/+sour ... omments/41
But i thought the asterisk in my first try, above, would cover this.

Or, add "ck-launch-session" to my .xinitrc file?
https://www.linuxquestions.org/question ... ost4230988

Or, remove "ck-launch-session" from my .xinitrc file?
https://bbs.archlinux.org/viewtopic.php ... 9#p1099639

Or, change my login manager?
"Changed login manager, seems to have sorted it."
https://bbs.archlinux.org/viewtopic.php ... 5#p1084865

Or, use 'network' group, instead of 'netdev'?
https://wiki.archlinux.org/index.php/Ne ... ermissions

Or, 'plugdev' group?
https://www.linuxquestions.org/question ... ost4461109

I noticed the Admin user is not a member of netdev:

Code: Select all

$ id patty 
uid=1001(patty) gid=1001(patty) groups=1001(patty),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),27(sudo),29(audio),30(dip),44(video),46(plugdev),115(lpadmin),120(scanner),128(sambashare)
This comment seems to indicate i can add a new connection as non-root, but it won't be available to all users. However, when i try, everything in "Network Connections" app is disabled.
https://bugs.launchpad.net/ubuntu/+sour ... comments/4

Or, something like

Code: Select all

/lib/udev/rules.d/70-usb-modeswitch.rules
to get networking with my Aldi/Medion Mobile Huawei E173:

# own udev rules for Aldi/Medion Huawei E173
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446", RUN+="/usr/sbin/usb_modeswitch -v 12d1 -p 1446 -M '55534243123456780000000000000011062000000100000000000000000000'"
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1436", RUN+="/bin/bash -c 'modprobe option && echo 12d1 1436 > /sys/bus/usb-serial/drivers/option1/new_id'"
https://bugs.launchpad.net/ubuntu/+sour ... comments/4
Mint 19 xfce. Semi-noob

User avatar
smurphos
Level 6
Level 6
Posts: 1430
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Not authorized to control networking"

Post by smurphos » Fri Aug 24, 2018 1:42 am

Adding the user to the netdev group should be sufficient. It is in Cinnamon in any case...

In XFCE in the Users and Groups app, under Advanced Settings > User Privileges there is a checkbox for 'Connect to Wireless and Ethernet Networks'. This is the same as adding the user to the netdev group. I've just checked an XFCE 19 VM install and that allows a standard user to manage network connections with no other changes required.

Desktop agnostic command line method sudo usermod -a -G netdev <user>

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: "Not authorized to control networking"

Post by johnywhy » Fri Aug 24, 2018 2:33 am

smurphos wrote:
Fri Aug 24, 2018 1:42 am
in the Users and Groups app, under Advanced Settings > User Privileges there is a checkbox for 'Connect to Wireless and Ethernet Networks'. This is the same as adding the user to the netdev group. I've just checked an XFCE 19 VM install and that allows a standard user to manage network connections with no other changes required.
it's already checked. Prolly cuz i already added the user to netdev.
Still can't manage wireless connections.

Code: Select all

$ id
uid=1000(johny) gid=1000(johny) groups=1000(johny),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),29(audio),30(dip),44(video),46(plugdev),108(netdev),120(scanner)
Mint 19 xfce. Semi-noob

User avatar
smurphos
Level 6
Level 6
Posts: 1430
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Not authorized to control networking"

Post by smurphos » Sat Aug 25, 2018 1:31 am

I've just checked again with another fresh standard user in XFCE, adding the netdev group only and it works fine for me out of the box, both via the Network applet and the tray indicator. Just deleted the default network connection and re-added it to double check.

Have you applied any of the other 'solutions' you have found? Maybe roll those changes back. Membership of the netdev group should be enough. It's why the group exists - https://wiki.debian.org/SystemGroups

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: "Not authorized to control networking"

Post by johnywhy » Sat Aug 25, 2018 1:50 am

smurphos wrote:
Sat Aug 25, 2018 1:31 am
adding the netdev group only
How? Command line? I'm adding via the /etc/adduser.conf. https://askubuntu.com/a/748223
Have you applied any of the other 'solutions' you have found? Maybe roll those changes back.
I removed the polkit file (I assumed a reboot isn't necessary), created a new user, confirmed they're in netdev, logged out, then logged in as the new user.

Same problem with the new user.

Code: Select all

$ id why
uid=1002(why) gid=1002(why) groups=1002(why),4(adm),20(dialout),21(fax),24(cdrom),25(floppy),26(tape),29(audio),30(dip),44(video),46(plugdev),108(netdev),120(scanner)
Mint 19 xfce. Semi-noob

User avatar
smurphos
Level 6
Level 6
Posts: 1430
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Not authorized to control networking"

Post by smurphos » Sat Aug 25, 2018 2:24 am

johnywhy wrote:
Sat Aug 25, 2018 1:50 am
smurphos wrote:
Sat Aug 25, 2018 1:31 am
adding the netdev group only
How? Command line?
Just via the XFCE users and groups GUI app. Create a basic new user (I'm not setting the 'Desktop user' ) and adding the netdev group only.

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: "Not authorized to control networking"

Post by johnywhy » Sat Aug 25, 2018 2:28 am

smurphos wrote:
Sat Aug 25, 2018 2:24 am
Just via the XFCE users and groups GUI app. Create a basic new user (I'm not setting the 'Desktop user' ) and adding the netdev group only.
that may be why you're getting different results. I'm applying the Desktop user-type.
Mint 19 xfce. Semi-noob

User avatar
smurphos
Level 6
Level 6
Posts: 1430
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Not authorized to control networking"

Post by smurphos » Sat Aug 25, 2018 2:32 am

Just tried that as-well - the Desktop User type with netdev + other groups by default also works just fine. I think you've broken something....

User avatar
smurphos
Level 6
Level 6
Posts: 1430
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Not authorized to control networking"

Post by smurphos » Sat Aug 25, 2018 2:38 am

BTW any particular reason for not using an Admin user or are you setting up machines for multiusers whom you don't trust not to the break the system?

For a sole user machine not using an sudo capable user account is IMHO just adding unnecessary barriers to comfortable computer use.

johnywhy
Level 4
Level 4
Posts: 320
Joined: Tue Feb 05, 2008 9:22 pm
Contact:

Re: "Not authorized to control networking"

Post by johnywhy » Sat Aug 25, 2018 2:44 am

setting up machines for multiusers whom i don't trust not to the break the system.

Would be enlightening to figure out what's broken.

I assume you're running an updated 19.

THX
Mint 19 xfce. Semi-noob

User avatar
smurphos
Level 6
Level 6
Posts: 1430
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: "Not authorized to control networking"

Post by smurphos » Sat Aug 25, 2018 2:57 am

johnywhy wrote:
Sat Aug 25, 2018 2:44 am
I assume you're running an updated 19.
Yep.

Not sure how to diagnose this issue but first think I'd do is reverse any of the tweaks listed in your second post that you have tried.

You seem to be a fan of tinkering :wink: - nothing wrong with that but it may be something else you've tweaked is causing the issue. IIRC you were engaged in slimming down your system and disabling services a while back....maybe something that's been disabled/removed there is causing the issue.

Post Reply

Return to “Wireless”