Wifi USB adaopt isn't working

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Venus311
Level 1
Level 1
Posts: 1
Joined: Mon Nov 19, 2018 1:36 am

Wifi USB adaopt isn't working

Post by Venus311 » Mon Nov 19, 2018 1:51 am

Hi, im trying to install drivers for my wifi adapter but it is not working
if you can help me i will appreciate it
the wifi adapter is TENDA U6

Code: Select all

 lsusb
Bus 002 Device 004: ID 0bda:0138 Realtek Semiconductor Corp. RTS5138 Card Reader Controller
Bus 002 Device 005: ID 0bda:818b Realtek Semiconductor Corp. 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 005: ID 0cf3:e004 Atheros Communications, Inc. 
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Code: Select all

inxi -Fxn
System:    Host: edraisito-Inspiron-3520 Kernel: 4.15.0-20-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: portable System: Dell product: Inspiron 3520 serial: N/A
           Mobo: Dell model: 0G8TPV v: A10 serial: N/A
           UEFI: Dell v: A10 date: 11/04/2013
Battery    BAT0: charge: 24.3 Wh 52.8% condition: 46.0/48.8 Wh (94%)
           model: Samsung SDI DELL 7XFJJA2 status: Discharging
CPU:       Dual core Intel Core i3-2370M (-MT-MCP-) 
           arch: Sandy Bridge rev.7 cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9578
           clock speeds: max: 2400 MHz 1: 798 MHz 2: 798 MHz 3: 798 MHz
           4: 798 MHz
Graphics:  Card: Intel 2nd Generation Core Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
           version: 3.3 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card Intel 7 Series/C216 Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
           driver: ath9k bus-ID: 07:00.0
           IF: wlp7s0 state: up mac: 9c:2a:70:7d:0a:b5
           Card-2: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 09:00.0
           IF: enp9s0 state: down mac: e0:db:55:93:e1:8e
           Card-3: Atheros usb-ID: 001-005
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1008.0GB (16.9% used)
           ID-1: /dev/sda model: ST1000LM024_HN size: 1000.2GB
           ID-2: USB /dev/sdb model: Multi size: 7.8GB
Partition: ID-1: / size: 321G used: 8.0G (3%) fs: ext4 dev: /dev/sda9
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 205 Uptime: 1:58 Memory: 1925.6/7838.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56
Sorry for my english, thanks!

jglen490
Level 4
Level 4
Posts: 255
Joined: Sat Jul 15, 2017 9:57 pm

Re: Wifi USB adaopt isn't working

Post by jglen490 » Tue Nov 20, 2018 1:59 pm

It appears that you may have two competing wifi adapters.
This one
Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
driver: ath9k bus-ID: 07:00.0
IF: wlp7s0 state: up mac: 9c:2a:70:7d:0a:b5
And possibly an external USB adapter
Card-3: Atheros usb-ID: 001-005
IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
if that is true, then disconnect the USB adapter and see if the other Atheros AR9485 adapter takes control. You will probably need to set up the wifi using your network manager (userid and password for your router). If there is a network icon in your system tray, click on it to do the set up.
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

JeremyB
Level 19
Level 19
Posts: 9472
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi USB adaopt isn't working

Post by JeremyB » Tue Nov 20, 2018 2:44 pm

jglen490 wrote:
Tue Nov 20, 2018 1:59 pm
It appears that you may have two competing wifi adapters.
This one
Network: Card-1: Qualcomm Atheros AR9485 Wireless Network Adapter
driver: ath9k bus-ID: 07:00.0
IF: wlp7s0 state: up mac: 9c:2a:70:7d:0a:b5
And possibly an external USB adapter
Card-3: Atheros usb-ID: 001-005
IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
if that is true, then disconnect the USB adapter and see if the other Atheros AR9485 adapter takes control. You will probably need to set up the wifi using your network manager (userid and password for your router). If there is a network icon in your system tray, click on it to do the set up.
I think the Atheros USB device is actually the Bluetooth chipset that is built into the wifi card

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 422
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Wifi USB adaopt isn't working

Post by Joe2Shoe » Tue Nov 20, 2018 2:47 pm

JeremyB, that's right, I have an Asus with the same wifi chipset and no extra drivers needed.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

JeremyB
Level 19
Level 19
Posts: 9472
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi USB adaopt isn't working

Post by JeremyB » Tue Nov 20, 2018 5:46 pm

The added USB wifi ID 0bda:818b Realtek Semiconductor Corp. should be supported using rtl8xxxu module, post results for lsmod

Post Reply

Return to “Wireless”