[RESOLVED] Mint 19.2 rtl8814au

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Jaguar07
Level 1
Level 1
Posts: 4
Joined: Thu Jan 26, 2017 7:32 am

[RESOLVED] Mint 19.2 rtl8814au

Post by Jaguar07 » Wed Sep 11, 2019 5:16 am

Hi:

I have a Netgear A7000 USB 3.0 Wireless dongle.

Code: Select all

sudo apt install build-essential
sudo apt install bc
sudo apt install linux-headers-$(uname -r)
sudo apt install git dkms
sudo apt update && sudo apt upgrade
git clone https://github.com/tpircher/rtl8814AU
cd rtl8814au
make
sudo make install
sudo cp -R . /usr/src/rtl8814au-4.3.21
sudo dkms build -m rtl8814au -v 4.3.21
sudo dkms install -m rtl8814au -v 4.3.21
Ran all of that. Rebooted.
Result:

Wireless device is operational and working very nicely BUT
on running
dkms status
I see the following in the output:
rtl8814au, 4.3.21, 5.0.0-27-generic, x86_64: installed (WARNING! Diff between built and installed module!)

inxi -Fd
responds with

Code: Select all

System:
  Host: XXXXXXX Kernel: 5.0.0-27-generic x86_64 bits: 64 
  Desktop: Cinnamon 4.2.4 Distro: Linux Mint 19.2 Tina 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX Z370-E GAMING v: Rev X.0x 
  serial: <root required> UEFI: American Megatrends v: 2401 date: 07/12/2019 
CPU:
  Topology: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP 
  L2 cache: 12.0 MiB 
  Speed: 800 MHz min/max: 800/4700 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 801 5: 800 6: 800 7: 800 8: 801 9: 800 10: 800 11: 800 12: 800 
Graphics:
  Device-1: Intel driver: i915 v: kernel 
  Device-2: AMD driver: amdgpu v: 5.0.73 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,modesetting 
  unloaded: fbdev,vesa resolution: 2560x1440~144Hz 
  OpenGL: renderer: AMD Radeon RX 5700 XT 
  v: 4.6.13572 Core Profile Context 5.0.73 
Audio:
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel 
  Device-2: AMD driver: snd_hda_intel 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo 
  Sound Server: ALSA v: k5.0.0-27-generic 
Network:
  Device-1: Intel Ethernet I219-V driver: e1000e 
  IF: enp0s31f6 state: down mac: 4c:ed:fb:c8:75:7c 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter driver: rtw_pci 
  IF: wlp6s0 state: up mac: 80:c5:f2:9e:4f:f7 
  Device-3: NetGear type: USB driver: rtl8814au 
  IF: wlx1459c0363305 state: up mac: 14:59:c0:36:33:05 
Drives:
  Local Storage: total: 2.29 TiB used: 636.20 GiB (27.2%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 PRO 512GB 
  size: 476.94 GiB 
  ID-2: /dev/sda vendor: Western Digital model: WD2003FZEX-00SRLA0 
  size: 1.82 TiB 
  Message: No Optical or Floppy data was found. 
RAID:
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci 
Partition:
  ID-1: / size: 32.67 GiB used: 10.71 GiB (32.8%) fs: ext4 
  dev: /dev/nvme0n1p5 
  ID-2: /home size: 164.62 GiB used: 7.46 GiB (4.5%) fs: ext4 
  dev: /dev/nvme0n1p6 
  ID-3: swap-1 size: 30.52 GiB used: 0 KiB (0.0%) fs: swap 
  dev: /dev/nvme0n1p7 
Sensors:
  System Temperatures: cpu: 29.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 298 Uptime: 19m Memory: 31.27 GiB used: 2.26 GiB (7.2%) 
  Shell: bash inxi: 3.0.32 
lsusb | grep NetGear
result:
Bus 001 Device 002: ID 0846:9054 NetGear, Inc.


I'd really like to find a solution to the error in the dkms status output.
Last edited by Jaguar07 on Wed Sep 11, 2019 9:08 am, edited 1 time in total.

User avatar
Pjotr
Level 21
Level 21
Posts: 13176
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Mint 19.2 rtl8814au strangeness

Post by Pjotr » Wed Sep 11, 2019 5:25 am

Jaguar07 wrote:
Wed Sep 11, 2019 5:16 am
Wireless device is operational and working very nicely
Don't know the answer. But in your stead, I'd be practical about this. If it's working fine, don't "fix" it until it's broken. :wink:
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Jaguar07
Level 1
Level 1
Posts: 4
Joined: Thu Jan 26, 2017 7:32 am

Re: Mint 19.2 rtl8814au strangeness

Post by Jaguar07 » Wed Sep 11, 2019 9:07 am

Point conceded and taken. Thank you.

Post Reply

Return to “Wireless”