Intel 9260 Wireless Card doesn't play nice with LM

Questions about Wi-Fi and other network devices, file sharing, firewalls, connection sharing etc
Forum rules
Before you post please read how to get help
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

Hey LM community!

Recently I've replaced the faulty Killer Wireless card in my Dell XPS 13 9360 with the Intel 9260 since I heard it was a great replacement. However, ever since I installed it, it seems to not integrate that well into Mint. What I mean is that it *is* recognized as a device:

Code: Select all

ion@ion-XPS-13-9360:~$ lspci -v | grep Network
3a:00.0 Network controller: Intel Corporation Wireless-AC 9260 (rev 29)
Yet is not in use at all. Doesn't work, and isn't listed as a wireless device:

Code: Select all

ion@ion-XPS-13-9360:~$ iwconfig
docker0   no wireless extensions.

lo        no wireless extensions.
HOWEVER, Bluetooth still works as proven by rfkill (I had it disabled here for the moment):

Code: Select all

ion@ion-XPS-13-9360:~$ rfkill
ID TYPE      DEVICE      SOFT      HARD
 0 bluetooth hci0     blocked unblocked

I've scoured many, many solutions to similar situations yet I've tried almost all of them and absolutely none of them worked. These include: Installing Drivers from intel, installing the latest driver from intel, reinstalling linux-firmware, using the backports (backtree?), using FN + F10 to switch on wireless, reenabling the iwlwifi using modprobe, removing it and readding it with modprobe, downgrading the kernel, upgrading the kernel, reinstalling iwlwifi, turning off Fast Boot in Windows. Yes, I do have a Dual-Boot setup and yet I've triple checked that everything relating to fastboot is turned off.

I know it's not related to hardware since when I've used it in Windows, it just works without a hitch, smoothly. Even identified it off the bat. But in LM, it seems to have some serious issues when using it for WiFi, confirming it's an issue on the software side. But I'm at a loss.

Here's my kernel:

Code: Select all

ion@ion-XPS-13-9360:~$ uname -r
5.4.0-70-generic
Also here are some logs from dmesg that should be helpful, but I couldn't find too much with it:

Code: Select all

ion@ion-XPS-13-9360:~$ dmesg | grep -i iwlwifi
[    5.585279] iwlwifi 0000:3a:00.0: enabling device (0000 -> 0002)
[    5.614130] iwlwifi 0000:3a:00.0: Found debug destination: EXTERNAL_DRAM
[    5.614134] iwlwifi 0000:3a:00.0: Found debug configuration: 0
[    5.614488] iwlwifi 0000:3a:00.0: loaded firmware version 46.6bf1df06.0 op_mode iwlmvm
[    5.752727] iwlwifi 0000:3a:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324
[    5.760482] iwlwifi 0000:3a:00.0: Applying debug destination EXTERNAL_DRAM
[    5.760938] iwlwifi 0000:3a:00.0: Allocated 0x00400000 bytes for firmware monitor.
[    5.804881] iwlwifi 0000:3a:00.0: Can't parse empty family 8000 OTP/NVM sections
[    5.804886] iwlwifi 0000:3a:00.0: Failed to read NVM: -61
[    5.804889] iwlwifi 0000:3a:00.0: Collecting data: trigger 16 fired.
[    5.806126] iwlwifi 0000:3a:00.0: Start IWL Error Log Dump:
[    5.806129] iwlwifi 0000:3a:00.0: Status: 0x00000040, count: 6
[    5.806131] iwlwifi 0000:3a:00.0: Loaded firmware version: 46.6bf1df06.0
[    5.806133] iwlwifi 0000:3a:00.0: 0x00000084 | NMI_INTERRUPT_UNKNOWN       
[    5.806135] iwlwifi 0000:3a:00.0: 0x000022F0 | trm_hw_status0
[    5.806137] iwlwifi 0000:3a:00.0: 0x00000000 | trm_hw_status1
[    5.806139] iwlwifi 0000:3a:00.0: 0x000214E4 | branchlink2
[    5.806141] iwlwifi 0000:3a:00.0: 0x00022FA6 | interruptlink1
[    5.806143] iwlwifi 0000:3a:00.0: 0x00003E7A | interruptlink2
[    5.806145] iwlwifi 0000:3a:00.0: 0x0000CF92 | data1
[    5.806146] iwlwifi 0000:3a:00.0: 0xFF000000 | data2
[    5.806148] iwlwifi 0000:3a:00.0: 0xF0000008 | data3
[    5.806150] iwlwifi 0000:3a:00.0: 0x00000000 | beacon time
[    5.806152] iwlwifi 0000:3a:00.0: 0x00002CBF | tsf low
[    5.806154] iwlwifi 0000:3a:00.0: 0x00000000 | tsf hi
[    5.806155] iwlwifi 0000:3a:00.0: 0x00000000 | time gp1
[    5.806157] iwlwifi 0000:3a:00.0: 0x00002CC0 | time gp2
[    5.806159] iwlwifi 0000:3a:00.0: 0x00000009 | uCode revision type
[    5.806161] iwlwifi 0000:3a:00.0: 0x0000002E | uCode version major
[    5.806163] iwlwifi 0000:3a:00.0: 0x6BF1DF06 | uCode version minor
[    5.806164] iwlwifi 0000:3a:00.0: 0x00000321 | hw version
[    5.806166] iwlwifi 0000:3a:00.0: 0x00C89004 | board version
[    5.806168] iwlwifi 0000:3a:00.0: 0x000C0188 | hcmd
[    5.806170] iwlwifi 0000:3a:00.0: 0x00022000 | isr0
[    5.806172] iwlwifi 0000:3a:00.0: 0x00000000 | isr1
[    5.806174] iwlwifi 0000:3a:00.0: 0x08001802 | isr2
[    5.806175] iwlwifi 0000:3a:00.0: 0x004000C0 | isr3
[    5.806177] iwlwifi 0000:3a:00.0: 0x00000001 | isr4
[    5.806179] iwlwifi 0000:3a:00.0: 0x000C0188 | last cmd Id
[    5.806181] iwlwifi 0000:3a:00.0: 0x0000CF92 | wait_event
[    5.806183] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_control
[    5.806184] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_duration
[    5.806186] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_mhvalid
[    5.806188] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_addr_match
[    5.806190] iwlwifi 0000:3a:00.0: 0x0000000F | lmpm_pmg_sel
[    5.806192] iwlwifi 0000:3a:00.0: 0x08081424 | timestamp
[    5.806194] iwlwifi 0000:3a:00.0: 0x0000002C | flow_handler
[    5.806277] iwlwifi 0000:3a:00.0: Start IWL Error Log Dump:
[    5.806279] iwlwifi 0000:3a:00.0: Status: 0x00000040, count: 7
[    5.806281] iwlwifi 0000:3a:00.0: 0x20000066 | NMI_INTERRUPT_HOST
[    5.806283] iwlwifi 0000:3a:00.0: 0x00000000 | umac branchlink1
[    5.806285] iwlwifi 0000:3a:00.0: 0xC008888E | umac branchlink2
[    5.806286] iwlwifi 0000:3a:00.0: 0xC0084414 | umac interruptlink1
[    5.806288] iwlwifi 0000:3a:00.0: 0xC0084414 | umac interruptlink2
[    5.806290] iwlwifi 0000:3a:00.0: 0x01000000 | umac data1
[    5.806292] iwlwifi 0000:3a:00.0: 0xC0084414 | umac data2
[    5.806294] iwlwifi 0000:3a:00.0: 0xDEADBEEF | umac data3
[    5.806295] iwlwifi 0000:3a:00.0: 0x0000002E | umac major
[    5.806297] iwlwifi 0000:3a:00.0: 0x6BF1DF06 | umac minor
[    5.806299] iwlwifi 0000:3a:00.0: 0x00002CBA | frame pointer
[    5.806301] iwlwifi 0000:3a:00.0: 0xC088627C | stack pointer
[    5.806303] iwlwifi 0000:3a:00.0: 0x000C0188 | last host cmd
[    5.806305] iwlwifi 0000:3a:00.0: 0x00000000 | isr status reg
[    5.806359] iwlwifi 0000:3a:00.0: Fseq Registers:
[    5.806411] iwlwifi 0000:3a:00.0: 0xC21DB78A | FSEQ_ERROR_CODE
[    5.806462] iwlwifi 0000:3a:00.0: 0x00000000 | FSEQ_TOP_INIT_VERSION
[    5.806512] iwlwifi 0000:3a:00.0: 0xC4DEDFA8 | FSEQ_CNVIO_INIT_VERSION
[    5.806564] iwlwifi 0000:3a:00.0: 0x0000A371 | FSEQ_OTP_VERSION
[    5.806615] iwlwifi 0000:3a:00.0: 0x0BCA4881 | FSEQ_TOP_CONTENT_VERSION
[    5.806666] iwlwifi 0000:3a:00.0: 0x3AD991C6 | FSEQ_ALIVE_TOKEN
[    5.806717] iwlwifi 0000:3a:00.0: 0x3DC7BF83 | FSEQ_CNVI_ID
[    5.806768] iwlwifi 0000:3a:00.0: 0xA0C633CA | FSEQ_CNVR_ID
[    5.806819] iwlwifi 0000:3a:00.0: 0x01000200 | CNVI_AUX_MISC_CHIP
[    5.806873] iwlwifi 0000:3a:00.0: 0x01300202 | CNVR_AUX_MISC_CHIP
[    5.806927] iwlwifi 0000:3a:00.0: 0x0000485B | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
[    5.807031] iwlwifi 0000:3a:00.0: 0x0BADCAFE | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
[    5.807082] iwlwifi 0000:3a:00.0: Firmware not running - cannot dump error
[    5.819224] iwlwifi 0000:3a:00.0: Failed to run INIT ucode: -61
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by sleeper12 »

Is secure boot off in Bios as well?
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by sleeper12 »

And maybe Fast Startup in Windows.
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

sleeper12 wrote:
Fri May 07, 2021 12:39 am
Is secure boot off in Bios as well?
Forgot to mention it but yeah, has always been off since I started Dual Booting. Everything Fast Startup is off too. Un-checked them both for the power button and the lid :)
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by hglee »

IonParticles wrote:
Fri May 07, 2021 12:27 am
Recently I've replaced the faulty Killer Wireless card in my Dell XPS 13 9360 with the Intel 9260 since I heard it was a great replacement. However, ever since I installed it, it seems to not integrate that well into Mint.

Greetings.


With XPS online: Open a Terminal (Ctrl-Alt-T), then click CODE:SELECT ALL to copy-and-paste the following as one block of text, then tap Enter...

Code: Select all

W=wireless-info;I=/usr/local/bin;sudo wget -q -nv -t 5 -T 10 https://github.com/UbuntuForums/$W/raw/master/$W -P $I/;\
cd ~/Downloads;sudo chmod +x $I/$W;$W>/dev/null;(inxi -Fxxxrz;modinfo `inxi -n|grep -Po 'ver: \K[^ ]+'`|grep parm)>>$W.txt;\
(lspci -nnk;lsusb -tv;rfkill list;(lsmod;dmesg)|egrep -i "wl|firm|fail|unab";dkms status;cat /proc/cmdline)>>$W.txt;\
(2>&1 iwconfig;2>&1 lshw -c network;mokutil --sb-state)>>$W.txt;tr -cd '\11\12\15\40-\176'<$W.txt|nc termbin.com 9999
There'll be a somewhat lengthy pause as detailed wifi info is collected, and finally a termbin.com URL will appear in the Terminal.

Post that URL in a reply here.


Last edited by hglee on Fri May 07, 2021 10:11 am, edited 1 time in total.
Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.8.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
User avatar
Larry78723
Level 11
Level 11
Posts: 3933
Joined: Wed Jan 09, 2019 7:01 pm
Location: Jasper County, SC, USA

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by Larry78723 »

Is Fast Startup turned off in Win10 power options?
Image
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »


Post that URL in a reply here.
https://termbin.com/gn9u

You might see some references to a Realtek 8811cu Wifi Dongle, using that as a placeholder for now
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

Larry78723 wrote:
Fri May 07, 2021 8:00 am
Is Fast Startup turned off in Win10 power options?
Yep! Made sure. I'll take conformation screenshots when I have the chance
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by sleeper12 »

Have you tried the 5.8 kernel?
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

sleeper12 wrote:
Fri May 07, 2021 11:42 am
Have you tried the 5.8 kernel?
Just saw this while installing it, will get back to you if it does
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

sleeper12 wrote:
Fri May 07, 2021 11:42 am
Have you tried the 5.8 kernel?
No dice :( Same exact error in dmesg
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by hglee »

IonParticles wrote:
Fri May 07, 2021 10:53 am
hglee wrote:Post that URL in a reply here.
https://termbin.com/gn9u
You might see some references to a Realtek 8811cu Wifi Dongle, using that as a placeholder for now


The iwlwifi backport does you no good, so just remove it to declutter:

Code: Select all

sudo dkms remove backport-iwlwifi/8324 --all


To download and install the available Intel 9260 firmware files (more than what's in the linux-firmware package):


Open a Terminal window (Ctrl-Alt-T), click CODE:SELECT ALL to copy-and-paste the following as one block of text, then tap Enter...

Code: Select all

sudo apt install -y aria2;cd ~/Downloads;L=/lib/firmware;I=iwlwifi-9260-th-b0-jf-b0;\
D=https://kernel.googlesource.com/pub/scm/linux/kernel/git/firmware/linux-firmware.git;\
E=/+/687d64a4da5ad8bbc9e95d51af75374d13c4bd0d;for F in 46 43 41 38 34 33;do G=$I-$F.ucode;\
H=$L/$G;aria2c $D/$E/$G;[ -f $H ]&&sudo cp $H{,-`date +%s`};sudo mv -f $G $L;done
Reboot.


Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.8.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

hglee wrote:
Fri May 07, 2021 12:28 pm
IonParticles wrote:
Fri May 07, 2021 10:53 am
hglee wrote:Post that URL in a reply here.
https://termbin.com/gn9u
You might see some references to a Realtek 8811cu Wifi Dongle, using that as a placeholder for now


The iwlwifi backport does you no good, so just remove it to declutter:

Code: Select all

sudo dkms remove backport-iwlwifi/8324 --all


To download and install the available Intel 9260 firmware files (more than what's in the linux-firmware package):


Open a Terminal window (Ctrl-Alt-T), click CODE:SELECT ALL to copy-and-paste the following as one block of text, then tap Enter...

Code: Select all

sudo apt install -y aria2;cd ~/Downloads;L=/lib/firmware;I=iwlwifi-9260-th-b0-jf-b0;\
D=https://kernel.googlesource.com/pub/scm/linux/kernel/git/firmware/linux-firmware.git;\
E=/+/687d64a4da5ad8bbc9e95d51af75374d13c4bd0d;for F in 46 43 41 38 34 33;do G=$I-$F.ucode;\
H=$L/$G;aria2c $D/$E/$G;[ -f $H ]&&sudo cp $H{,-`date +%s`};sudo mv -f $G $L;done
Reboot.


Didn't work unfortunately :?

dmesg now says there is no firmware:

Code: Select all

ion@ion-XPS-13-9360:~$ dmesg | grep -i iwlwifi
[    6.026778] iwlwifi 0000:3a:00.0: enabling device (0000 -> 0002)
[    6.030586] iwlwifi 0000:3a:00.0: uCode file size 3252 does not match expected size
[    6.030728] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-45.ucode failed with error -2
[    6.030746] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-44.ucode failed with error -2
[    6.030933] iwlwifi 0000:3a:00.0: uCode file size 3252 does not match expected size
[    6.031114] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-42.ucode failed with error -2
[    6.031243] iwlwifi 0000:3a:00.0: uCode file size 3252 does not match expected size
[    6.031262] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-40.ucode failed with error -2
[    6.031278] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-39.ucode failed with error -2
[    6.031401] iwlwifi 0000:3a:00.0: uCode file size 3252 does not match expected size
[    6.031419] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-37.ucode failed with error -2
[    6.031434] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-36.ucode failed with error -2
[    6.031448] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-35.ucode failed with error -2
[    6.031561] iwlwifi 0000:3a:00.0: uCode file size 3252 does not match expected size
[    6.031700] iwlwifi 0000:3a:00.0: uCode file size 3252 does not match expected size
[    6.031720] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-32.ucode failed with error -2
[    6.031735] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-31.ucode failed with error -2
[    6.031751] iwlwifi 0000:3a:00.0: Direct firmware load for iwlwifi-9260-th-b0-jf-b0-30.ucode failed with error -2
[    6.031753] iwlwifi 0000:3a:00.0: no suitable firmware found!
[    6.031755] iwlwifi 0000:3a:00.0: minimum version required: iwlwifi-9260-th-b0-jf-b0-30
[    6.031756] iwlwifi 0000:3a:00.0: maximum version supported: iwlwifi-9260-th-b0-jf-b0-46
[    6.031758] iwlwifi 0000:3a:00.0: check git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by hglee »

IonParticles wrote:
Fri May 07, 2021 2:49 pm
Didn't work unfortunately :?

dmesg now says there is no firmware:


Looks like it's complaining more now that it has more to see!


Tell it to reinstall the linux-firmware package, but one more recent than you now have:

Copy-and-paste these 2 command-lines, one by one...

Code: Select all

cd ~/Downloads && wget http://archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.197_all.deb
sudo dpkg -i linux-firmware_1.197_all.deb


Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.8.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

hglee wrote:
Fri May 07, 2021 3:08 pm

Copy-and-paste these 2 command-lines, one by one...

Code: Select all

cd ~/Downloads && wget http://archive.ubuntu.com/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.197_all.deb
sudo dpkg -i linux-firmware_1.197_all.deb
Now identified the correct firmware on the 1.197 version of linux-firmware, yet same exact error as before occurred:

Code: Select all

ion@ion-XPS-13-9360dmesg | grep -i iwlwifi
[    6.417668] iwlwifi 0000:3a:00.0: enabling device (0000 -> 0002)
[    6.434427] iwlwifi 0000:3a:00.0: loaded firmware version 46.6f9f215c.0 op_mode iwlmvm
[    6.548490] iwlwifi 0000:3a:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324
[    6.604318] iwlwifi 0000:3a:00.0: Can't parse empty family 8000 OTP/NVM sections
[    6.604323] iwlwifi 0000:3a:00.0: Failed to read NVM: -61
[    6.604326] iwlwifi 0000:3a:00.0: Collecting data: trigger 16 fired.
[    6.605496] iwlwifi 0000:3a:00.0: Start IWL Error Log Dump:
[    6.605500] iwlwifi 0000:3a:00.0: Status: 0x00000040, count: 6
[    6.605502] iwlwifi 0000:3a:00.0: Loaded firmware version: 46.6f9f215c.0
[    6.605505] iwlwifi 0000:3a:00.0: 0x00000084 | NMI_INTERRUPT_UNKNOWN       
[    6.605507] iwlwifi 0000:3a:00.0: 0x000022F0 | trm_hw_status0
[    6.605509] iwlwifi 0000:3a:00.0: 0x00000000 | trm_hw_status1
[    6.605511] iwlwifi 0000:3a:00.0: 0x00021C34 | branchlink2
[    6.605513] iwlwifi 0000:3a:00.0: 0x00023756 | interruptlink1
[    6.605515] iwlwifi 0000:3a:00.0: 0x00023756 | interruptlink2
[    6.605516] iwlwifi 0000:3a:00.0: 0x0000D2EE | data1
[    6.605518] iwlwifi 0000:3a:00.0: 0xFF000000 | data2
[    6.605520] iwlwifi 0000:3a:00.0: 0xF0000008 | data3
[    6.605522] iwlwifi 0000:3a:00.0: 0x00000000 | beacon time
[    6.605524] iwlwifi 0000:3a:00.0: 0x00002A47 | tsf low
[    6.605526] iwlwifi 0000:3a:00.0: 0x00000000 | tsf hi
[    6.605528] iwlwifi 0000:3a:00.0: 0x00000000 | time gp1
[    6.605529] iwlwifi 0000:3a:00.0: 0x00002A48 | time gp2
[    6.605531] iwlwifi 0000:3a:00.0: 0x00000009 | uCode revision type
[    6.605533] iwlwifi 0000:3a:00.0: 0x0000002E | uCode version major
[    6.605535] iwlwifi 0000:3a:00.0: 0x6F9F215C | uCode version minor
[    6.605537] iwlwifi 0000:3a:00.0: 0x00000321 | hw version
[    6.605539] iwlwifi 0000:3a:00.0: 0x00C89004 | board version
[    6.605541] iwlwifi 0000:3a:00.0: 0x000C0188 | hcmd
[    6.605543] iwlwifi 0000:3a:00.0: 0x00022000 | isr0
[    6.605544] iwlwifi 0000:3a:00.0: 0x00000000 | isr1
[    6.605546] iwlwifi 0000:3a:00.0: 0x08001802 | isr2
[    6.605548] iwlwifi 0000:3a:00.0: 0x004000C0 | isr3
[    6.605550] iwlwifi 0000:3a:00.0: 0x00000001 | isr4
[    6.605552] iwlwifi 0000:3a:00.0: 0x000C0188 | last cmd Id
[    6.605554] iwlwifi 0000:3a:00.0: 0x0000D2EE | wait_event
[    6.605555] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_control
[    6.605557] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_duration
[    6.605559] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_mhvalid
[    6.605561] iwlwifi 0000:3a:00.0: 0x00000000 | l2p_addr_match
[    6.605563] iwlwifi 0000:3a:00.0: 0x0000000F | lmpm_pmg_sel
[    6.605565] iwlwifi 0000:3a:00.0: 0x28010826 | timestamp
[    6.605567] iwlwifi 0000:3a:00.0: 0x0000082C | flow_handler
[    6.605650] iwlwifi 0000:3a:00.0: Start IWL Error Log Dump:
[    6.605652] iwlwifi 0000:3a:00.0: Status: 0x00000040, count: 7
[    6.605654] iwlwifi 0000:3a:00.0: 0x20000066 | NMI_INTERRUPT_HOST
[    6.605656] iwlwifi 0000:3a:00.0: 0x00000000 | umac branchlink1
[    6.605658] iwlwifi 0000:3a:00.0: 0xC0088BEE | umac branchlink2
[    6.605660] iwlwifi 0000:3a:00.0: 0xC0084484 | umac interruptlink1
[    6.605661] iwlwifi 0000:3a:00.0: 0xC0084484 | umac interruptlink2
[    6.605663] iwlwifi 0000:3a:00.0: 0x01000000 | umac data1
[    6.605665] iwlwifi 0000:3a:00.0: 0xC0084484 | umac data2
[    6.605667] iwlwifi 0000:3a:00.0: 0xDEADBEEF | umac data3
[    6.605669] iwlwifi 0000:3a:00.0: 0x0000002E | umac major
[    6.605671] iwlwifi 0000:3a:00.0: 0x6F9F215C | umac minor
[    6.605673] iwlwifi 0000:3a:00.0: 0x00002A42 | frame pointer
[    6.605675] iwlwifi 0000:3a:00.0: 0xC088627C | stack pointer
[    6.605677] iwlwifi 0000:3a:00.0: 0x000C0188 | last host cmd
[    6.605678] iwlwifi 0000:3a:00.0: 0x00000000 | isr status reg
[    6.605733] iwlwifi 0000:3a:00.0: Fseq Registers:
[    6.605784] iwlwifi 0000:3a:00.0: 0x821C378A | FSEQ_ERROR_CODE
[    6.605835] iwlwifi 0000:3a:00.0: 0x00000000 | FSEQ_TOP_INIT_VERSION
[    6.605886] iwlwifi 0000:3a:00.0: 0xCCDE5EA8 | FSEQ_CNVIO_INIT_VERSION
[    6.605937] iwlwifi 0000:3a:00.0: 0x0000A371 | FSEQ_OTP_VERSION
[    6.605989] iwlwifi 0000:3a:00.0: 0x0BCA508B | FSEQ_TOP_CONTENT_VERSION
[    6.606040] iwlwifi 0000:3a:00.0: 0xBAD98186 | FSEQ_ALIVE_TOKEN
[    6.606091] iwlwifi 0000:3a:00.0: 0x1DC7BF8B | FSEQ_CNVI_ID
[    6.606142] iwlwifi 0000:3a:00.0: 0xA4E6334A | FSEQ_CNVR_ID
[    6.606194] iwlwifi 0000:3a:00.0: 0x01000200 | CNVI_AUX_MISC_CHIP
[    6.606246] iwlwifi 0000:3a:00.0: 0x01300202 | CNVR_AUX_MISC_CHIP
[    6.606301] iwlwifi 0000:3a:00.0: 0x0000485B | CNVR_SCU_SD_REGS_SD_REG_DIG_DCDC_VTRIM
[    6.606405] iwlwifi 0000:3a:00.0: 0x0BADCAFE | CNVR_SCU_SD_REGS_SD_REG_ACTIVE_VDIG_MIRROR
[    6.606459] iwlwifi 0000:3a:00.0: Firmware not running - cannot dump error
[    6.617920] iwlwifi 0000:3a:00.0: Failed to run INIT ucode: -61

Starting to think this might be a new bug...
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

Booted into 5.8.0 Kernel to see if it made any difference and the output was different and interesting, yet same result:

Code: Select all

ion@ion-XPS-13-dmesg | grep -i iwlwifi
[    6.663067] iwlwifi 0000:3a:00.0: enabling device (0000 -> 0002)
[    6.667311] iwlwifi 0000:3a:00.0: WRT: Overriding region id 0
[    6.667314] iwlwifi 0000:3a:00.0: WRT: Overriding region id 1
[    6.667315] iwlwifi 0000:3a:00.0: WRT: Overriding region id 2
[    6.667317] iwlwifi 0000:3a:00.0: WRT: Overriding region id 3
[    6.667318] iwlwifi 0000:3a:00.0: WRT: Overriding region id 4
[    6.667319] iwlwifi 0000:3a:00.0: WRT: Overriding region id 6
[    6.667321] iwlwifi 0000:3a:00.0: WRT: Overriding region id 8
[    6.667322] iwlwifi 0000:3a:00.0: WRT: Overriding region id 9
[    6.667323] iwlwifi 0000:3a:00.0: WRT: Overriding region id 10
[    6.667324] iwlwifi 0000:3a:00.0: WRT: Overriding region id 11
[    6.667325] iwlwifi 0000:3a:00.0: WRT: Overriding region id 15
[    6.667326] iwlwifi 0000:3a:00.0: WRT: Overriding region id 16
[    6.667328] iwlwifi 0000:3a:00.0: WRT: Overriding region id 18
[    6.667329] iwlwifi 0000:3a:00.0: WRT: Overriding region id 19
[    6.667330] iwlwifi 0000:3a:00.0: WRT: Overriding region id 20
[    6.667331] iwlwifi 0000:3a:00.0: WRT: Overriding region id 21
[    6.667332] iwlwifi 0000:3a:00.0: WRT: Overriding region id 28
[    6.667668] iwlwifi 0000:3a:00.0: loaded firmware version 46.6f9f215c.0 9260-th-b0-jf-b0-46.ucode op_mode iwlmvm
[    6.667695] iwlwifi 0000:3a:00.0: Direct firmware load for iwl-debug-yoyo.bin failed with error -2
[    6.739149] iwlwifi 0000:3a:00.0: Detected Intel(R) Wireless-AC 9260 160MHz, REV=0x324
[    6.793212] iwlwifi 0000:3a:00.0: Can't parse empty family 8000 OTP/NVM sections
[    6.793216] iwlwifi 0000:3a:00.0: Failed to read NVM: -61
[    6.805801] iwlwifi 0000:3a:00.0: Failed to run INIT ucode: -61
At least we're getting something else :P
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by hglee »

IonParticles wrote:
Fri May 07, 2021 6:01 pm
Booted into 5.8.0 Kernel to see if it made any difference and the output was different and interesting, yet same result:
...
loaded firmware version 46.6f9f215c.0 9260-th-b0-jf-b0-46.ucode op_mode iwlmvm
...
At least we're getting something else :P


Yeah, before it complained Direct firmware load for iwlwifi-9260-th-b0-jf-b0-46.ucode failed with error -2.


Load another useful utility:

Code: Select all

sudo apt install sysfsutils
Then post the output of this command-line...

Code: Select all

systool -vm iwlwifi && systool -vm iwlmvm

Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.8.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

hglee wrote:
Fri May 07, 2021 7:52 pm
Load another useful utility:

Code: Select all

sudo apt install sysfsutils
Then post the output of this command-line...

Code: Select all

systool -vm iwlwifi && systool -vm iwlmvm

Hmm something to do with the parameters?

Code: Select all

ion@ion-XPS-13-9360:~$ systool -vm iwlwifi && systool -vm iwlmvm
Module = "iwlwifi"

  Attributes:
    coresize            = "352256"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "1"
    srcversion          = "E3A308F6AFCA99CA4F4BB33"
    taint               = ""
    uevent              = <store method only>

  Parameters:
    11n_disable         = "0"
    amsdu_size          = "0"
    bt_coex_active      = "Y"
    disable_11ac        = "N"
    disable_11ax        = "N"
    enable_ini          = "Y"
    fw_restart          = "Y"
    led_mode            = "0"
    nvm_file            = "(null)"
    power_level         = "0"
    power_save          = "N"
    remove_when_gone    = "N"
    swcrypto            = "0"
    uapsd_disable       = "3"

  Sections:

Module = "iwlmvm"

  Attributes:
    coresize            = "393216"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    srcversion          = "B92D5E8D3793142AE51EF76"
    taint               = ""
    uevent              = <store method only>

  Parameters:
    init_dbg            = "N"
    power_scheme        = "2"

  Sections:
User avatar
hglee
Level 5
Level 5
Posts: 955
Joined: Fri Jun 22, 2018 4:31 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by hglee »

IonParticles wrote:
Fri May 07, 2021 9:52 pm
Booted into 5.8.0 Kernel to see if it made any difference and the output was different and interesting, yet same result:

Is Bluetooth working normally?


The last time we did this the firmware hadn't loaded, so let's see what all has changed:

With XPS online: Open a Terminal (Ctrl-Alt-T), then click CODE:SELECT ALL to copy-and-paste the following as one block of text, then tap Enter...

Code: Select all

W=wireless-info;I=/usr/local/bin;sudo wget -q -nv -t 5 -T 10 https://github.com/UbuntuForums/$W/raw/master/$W -P $I/;\
cd ~/Downloads;[ -f $W.* ]&&rm $W.*;sudo chmod +x $I/$W;$W>/dev/null;(modinfo `inxi -n|grep -Po 'ver: \K[^ ]+'`|grep firm)>>$W.txt;\
(lspci -nnk;lsusb -tv;rfkill list;(lsmod;dmesg)|egrep -i "wl|firm|fail|unab";dkms status;cat /proc/cmdline)>>$W.txt;\
(2>&1 iwconfig;2>&1 sudo lshw -c network -businfo)>>$W.txt;tr -cd '\11\12\15\40-\176'<$W.txt|nc termbin.com 9999
There'll be a somewhat lengthy pause as detailed wifi info is collected, and finally a termbin.com URL will appear in the Terminal.

Post that URL in a reply here.


Linux Mint 20.1 Ulyssa, MATE 1.24.0, kernel 5.8.0*-hwe, Dell 2-in-1
AMD Ryzen 7 4700U / Renoir GPU - 14" FHD WVA Touchscreen
Intel AX200 WiFi-6 BT-5.1; 32GB DDR4@3200MHz; 2TB XPG NVMe
IonParticles
Level 1
Level 1
Posts: 30
Joined: Tue Jun 19, 2018 6:21 pm

Re: Intel 9260 Wireless Card doesn't play nice with LM

Post by IonParticles »

hglee wrote:
Fri May 07, 2021 11:17 pm
IonParticles wrote:
Fri May 07, 2021 9:52 pm
Booted into 5.8.0 Kernel to see if it made any difference and the output was different and interesting, yet same result:

Is Bluetooth working normally?

The last time we did this the firmware hadn't loaded, so let's see what all has changed:
Yes, Bluetooth is confirmed to be working without issues. Connected a couple devices to it and it works flawlessly, so no worries there
hglee wrote:
Fri May 07, 2021 11:17 pm
Post that URL in a reply here.
https://termbin.com/mntv
Post Reply