How to get Broadcom BCM4318 working?

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
linuxmatt7
Level 1
Level 1
Posts: 1
Joined: Sun May 06, 2012 8:19 am
Location: London, UK
Contact:

How to get Broadcom BCM4318 working?

Post by linuxmatt7 »

I need help on getting my Broadcom BCM4318 working in Linux Mint 12 Lisa. I install the firmware and driver software, and it still does nothing. Now it doesn't even show my Wireless in the settings. I need help fast.
NAS Computer - Xubuntu 12.04 LTS
Gateway NV53 Laptop - Xubuntu 12.04 LTS
Dell Latitude CPt Laptop - Customized Xubuntu 6.06 LTS
HP Laptop - Linux Mint 12 Lisa

User avatar
Danko8321
Level 4
Level 4
Posts: 206
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: How to get Broadcom BCM4318 working?

Post by Danko8321 »

linuxmatt7 wrote:I need help on getting my Broadcom BCM4318 working in Linux Mint 12 Lisa. I install the firmware and driver software, and it still does nothing. Now it doesn't even show my Wireless in the settings. I need help fast.
Did it show wireless in the panel before? And, if so, why did you install it?

Also, please type this command in a terminal and paste the output here

Code: Select all

inxi -F
Cheers. Danko.
Cheer up! Things are getting worse at a slower rate.

mister_lister
Level 1
Level 1
Posts: 49
Joined: Thu Dec 18, 2008 6:40 pm

Re: How to get Broadcom BCM4318 working?

Post by mister_lister »

do the following in your "/home/*user*/downloads/" directory through terminal...

sudo apt-get install b43-fwcutter
wget http://mirror2.openwrt.org/sources/broa ... .5.tar.bz2
tar xf broadcom-wl-4.150.10.5.tar.bz2
cd broadcom-wl-4.150.10.5/driver
sudo b43-fwcutter -w /lib/firmware wl_apsta.o
modprobe b43


I edited as administrator the "/etc/modules" file and found that the "b43" module was in fact spelled in Upper Case letters ("B43), so I put the letter "B" in lower case and saved, it loads everytime, but you have to select your network.

Post Reply

Return to “Wireless”