Mint 13 Mate - wireless network on Dell Latitude 2100

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 21
Joined: Thu May 31, 2012 9:34 am

Mint 13 Mate - wireless network on Dell Latitude 2100

Postby taylorkh » Thu May 31, 2012 9:43 am

The machine in question is a Dell Latitude 2100 netbook. It came from the factory with Ubuntu 9.04 and has been running Ubuntu 10.04 for the past couple of years. Today I decided to install Mint 13 Mate which I have been playing with in VMWare and seems to have a nice simple interface.

The install on the netbook went fine. I installed the "restricted" driver for the Broadcomm wireless card just as I had done previously with Ubuntu. I configured the wireless connection under networking by supplying the SSID (which is not broadcast) and password from my wireless router. I set the connection to WPA2 personal as the router is WPA2. The issues I have noticed are:

1 - the wireless connection does not connect
2 - WPA2 personal reverts to WPA personal

I changed the router to WPA and still no connection.

I installed Ubuntu 12.04 (from which Mint 13 is derived I think?) and allowed it to install the restricted driver. I configured the network connection to my wireless router and it works fine.

The driver package is bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu6.1_i386.deb in both cases. The files are identical on Ubuntu and Mint Mate.

I uninstalled and reinstalled the driver but Mint still does not connect. It still reverts WPA2 to WPA.

I noticed that in Ubuntu I had to add a new connection for wireless. Mint seems to know that there is a wireless device and I am only allow to change its properties. I changed Mint to "roaming" mode but that simply cleared the properties and I could not edit anything.

I am at the moment installing Mint 13 Cinnamon and will report what I find. I will then try some brute force investigation which I used to find a network bug in the CentOS (Red Hat) 6 installer.

In the mean time I would appreciate any advice.



Update 1 - I installed Mint 13 Cinnamon and configured the wireless network via the Network app from the menu. It did NOT work. I then opened a networking dialog from the icon in the notification bar and pointed that to the wireless network configuration previously created. It DID work :mrgreen: So now I am restoring my Mate backup to the netbook. The network configuration screens are much different but I will see if there is a dialog which can be raised from the network notification icon and see what I can do there. I will update when I have more info.

Update 2 - I was able to create a wireless connection from a dialog launched from the network notification icon. But it does not work. I rebooted and upon examining syslog I found the following line
May 31 10:21:21 taylor13 NetworkManager[443]: nm-ifupdown-connection.c.100 - invalid connection read from /etc/network/interfaces: (1) proto
/etc/network/interfaces shows
auto lo
iface lo inet loopback

iface wlan0 inet dhcp
wpa-psk (a long key)
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA2
wpa-ssid (the correct name of my router)

auto wlan0
Let me try and compare this with what I had in Mint Cinnamon - but it will take a while as I need to reinstall. I need a couple of these machines :(

Update 2a - I deleted the offending lines from /etc/network/interfaces and rebooted. I do NOT get the error in syslog. Nor do I get a wireless connection. I deleted and recreated the wireless entity using the dialog from the network notifier. NO information was written to /etc/network/interfaces. But still no wireless connection. It looks like the offending entry was created by mate-network-admin. I guess I need to file a bug against that program.

Level 1
Level 1
Posts: 21
Joined: Thu May 31, 2012 9:34 am

Re: Mint 13 Mate - wireless network on Dell Latitude 2100

Postby taylorkh » Thu May 31, 2012 2:25 pm

I have finally solved this. I will post a more generic thread explaining what I did as it may well apply to other wireless issues. Look for the subject "Broadcomm wireless on Mint 13 Mate".


Level 1
Level 1
Posts: 21
Joined: Thu May 31, 2012 9:34 am

Broadcomm wireless on Mint 13 Mate

Postby taylorkh » Thu May 31, 2012 2:58 pm

I had posted a previous thread about my attempts to get wireless networking working on a Dell Latitude 2100. To summarize the issue... I installed Mint 13 Mate and allowed it to download and install the Broadcomm driver. I tried to create the wireless connection using mate-network-admin (Networking app from the Menu; Administration). This created entries in /etc/network/interfaces which caused issues on boot. I confirmed that the identical Broadcomm driver worked OK on Mint 13 Cinnamon and Ubuntu 12.04 (from which Mint 13 is derived). Here step by step is how I managed to get wireless networking working on Mint 13 Mate:

1 - Connected the netbook to my router by an Ethernet cable
2 - Performed a clean install of Mint 13 Mate
3 - Had a look at the network situation as follows
Right click on the network icon in the notification area (which is nm-applet) and observed the following
Enable Networking was checked
Enable Wireless was checked
Connection Information showed me the details of the wired connection
Edit Connections took me to a dialog which showed
Wired tab - Wired connection 1 present
Wireless tab - no entries
4 - From the Menu; Preferences; Additional Drivers I downloaded and installed the Broadcomm driver. For reference the file is bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu6.1_i386.deb
5 - Rebooted to complete the installation of the driver.
6 - Right clicked on the network icon in the notification area and selected Edit connections.
7 - Selected the Wireless tab and pressed the + Add button. I supplied the following data
Connection name" Wireless connection 1" (the default which was shown)
SSID: Luca$Electric (the name of my router - British car fans will understand this :lol: ) This is not broadcast by the router
Mode: Infrastructure
I moved to the Wireless Security tab and set:
Security: WPA and WPA2 Personal
Password: (the appropriate password for my router/network)
Finally I saved the connection and closed the dialogs. I still did not have a connection. So...
8 - I again Right Clicked on the network icon in the notification area and this time I clicked Connect to hidden wireless network.

Behold - I was connected!!! :mrgreen: :mrgreen: :mrgreen:

9 - Disconnected the Ethernet cable and rebooted. I was again and automagically connected to my wireless network.

n.b. The option to "Connect to hidden wireless network" is no longer present when I right click on the network icon in the notification area.

If you are having trouble connecting a Broadcomm or any other wireless card in Mint 13 Mate consider trying these steps. Do NOT use the Menu; Administration; Network program. It doesn't work and thinking back it does not work in Ubuntu either going back at least to 9.04.

Hope this helps someone.


User avatar
Level 19
Level 19
Posts: 9647
Joined: Tue Aug 11, 2009 9:21 am
Location: United Kingdom

Re: Broadcomm wireless on Mint 13 Mate

Postby Oscar799 » Fri Jun 01, 2012 3:32 am

Threads merged - same OP,same question

Return to “Wireless”

Who is online

Users browsing this forum: No registered users and 2 guests