new to linux and MINT no wireless connection to airport

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
zen

new to linux and MINT no wireless connection to airport

Post by zen » Mon Feb 12, 2007 5:14 pm

greetings - I am in desperate need of help.

I am new to linux and also new to mint by about an hour. I did my homewrok but not a geek and do not know command line. I am coming from mac Os X and tried ubuntu on a newly boughten jsut for linux laptop. Installed 3 times the last 3 days and no luck for many issues and any possible resolution. so I tried mint on a suggestion from someone in the UK.

anyway I cannot get this wrieless working. It is imperative that I use this laptop via wireless only!!!

I am on an aiprot extreme. this takes a password - 'text' for macs and no issues. the 1 windows old dell that my wife uses for school work at times has a hex code which I have... but nothing works the dell is connected but this linux one won't connect

please help and do not leave me hanging.

thank you!





p.s. i just downloaded wifi radar and it says cannot get ip address...did the same in ubuntu


it also states b instead of g and it did the same in ubuntu before going to g but I am clueless and stumped... I tried everything

the computer is 3 days old


the hex code is the long set of letter and numbers that go for the wep ebcryption on pc's I am on an older linksys 4 port router and a airport extreme inside or behind that. cable modem high speed.

zen

Post by zen » Mon Feb 12, 2007 6:14 pm

i am trying to load the zipped driver in termonal but I do not know how to do the commands re: the xipped file to unzip from my desktop. could someone help please? I may have found the correct driver. Not sure. thanks.

zen

Post by zen » Mon Feb 12, 2007 7:05 pm

I do not know how to wrie the command to unzip the .exe driver from my desktop in terminal. Can someone help me out. I am stuck here at this point. thanks.

User avatar
|_NiGhTmArE_|
Level 1
Level 1
Posts: 48
Joined: Mon Feb 05, 2007 6:16 pm
Location: Italy

Post by |_NiGhTmArE_| » Mon Feb 12, 2007 7:54 pm

zen wrote:I do not know how to wrie the command to unzip the .exe driver from my desktop in terminal. Can someone help me out. I am stuck here at this point. thanks.
.exe is the extension of the executable file of windows... if you have a .exe try to open it with wine

zen

Post by zen » Mon Feb 12, 2007 8:14 pm

no wine - no windows....what is the command for this in terminal

zen

Post by zen » Tue Feb 13, 2007 8:58 am

any nibbles please? I really need to get the wirless and the sound fixed badly. It is crucial for the wireless to get fixed for using this laptop the way I want to in my home and office.

thank you very much

User avatar
hairy_Palms
Level 4
Level 4
Posts: 292
Joined: Mon Nov 27, 2006 10:46 am

Post by hairy_Palms » Tue Feb 13, 2007 9:26 am

first off if its a .exe files it not for linux i wouldnt think, try opening synaptic from the control center and installing
airport-utils
bcm43xx-fwcutter

Download this file:
http://boredklink.googlepages.com/wl_apsta.o

then run this command

Code: Select all

sudo bcm43xx-fwcutter -w /lib/firmware /PATH/TO/WHERE/YOU/SAVED/DRIVER/wl_apsta.o
and then put it in the kernel folder too with this command

Code: Select all

sudo bcm43xx-fwcutter -w /lib/firmware/`uname -r` /PATH/TO/WHERE/YOU/SAVED/DRIVER/wl_apsta.o
youll probably need to reboot after this


if it still doesnt work eneter this command

Code: Select all

modprobe bcm43xx
and reboot again.

zen

Post by zen » Tue Feb 13, 2007 9:44 am

hairy_Palms wrote:first off if its a .exe files it not for linux i wouldnt think, try opening synaptic from the control center and installing
airport-utils
bcm43xx-fwcutter




i did this yesterday i belive....





Download this file:
http://boredklink.googlepages.com/wl_apsta.o


this is saved as it is to the desktop..... when I download it it says nothing to open it wit so do I save it as it is???




then run this command

Code: Select all

sudo bcm43xx-fwcutter -w /lib/firmware /PATH/TO/WHERE/YOU/SAVED/DRIVER/wl_apsta.o
and then put it in the kernel folder too with this command

Code: Select all

sudo bcm43xx-fwcutter -w /lib/firmware/`uname -r` /PATH/TO/WHERE/YOU/SAVED/DRIVER/wl_apsta.o
youll probably need to reboot after this


if it still doesnt work eneter this command

Code: Select all

modprobe bcm43xx
and reboot again.

zen

Post by zen » Tue Feb 13, 2007 9:50 am

it didn't work the first command you gave me


Cannot open input file /PATH/TO/WHERE/YOU/SAVED/DRIVER/wl_apsta.o
zen@zen-linuxlaptop:~$




also if I get to that point --- in the following command that you gave me the username -r insingle quotes is that my realuser name - thanks - I told you i ws dumb and know no commnd line stuff.

User avatar
hairy_Palms
Level 4
Level 4
Posts: 292
Joined: Mon Nov 27, 2006 10:46 am

Post by hairy_Palms » Tue Feb 13, 2007 9:54 am

you need to substitute
/PATH/TO/WHERE/YOU/SAVED/DRIVER/wl_apsta.o
with wherever you download the file above,
eg /home/zen/Desktop/wl_apsta.o or whatever

noo 'uname -r' returns the name of the cureent kernel version.

zen

Post by zen » Tue Feb 13, 2007 9:59 am

ok when you had all those slashes in there I wasn't sure...

my fault. I apologize - I just learned not to assume anything with command line stuff or all hell breaks loose...

zen

Post by zen » Tue Feb 13, 2007 10:07 am

ok hold on I did it this time took me a few tries! (dumb americans, eh???? :-))))

zen

Post by zen » Tue Feb 13, 2007 10:11 am

ok 0 i am rebooting - thank you so very much for helping and stiking by me through this and not commenting and running away until 2 days from now....

zen

Post by zen » Tue Feb 13, 2007 10:17 am

Hairy ---- The light came on first time but I cannot get onto the internet....any clues - at least you helped me this far!!!!!

Cool what should i try the mod probe command??? awaiting your reply..tyhank you

zen

Post by zen » Tue Feb 13, 2007 10:20 am

it says in the wifiradar app I downloaded connected to K9DOG ip(NONE)


it should auto detect and I have the hecode in there the best that I know from my olde dell my wife uses. I am on airprot and airport takes text code as such or whatever you want to use - mine is just a word combination

do i have to try to find and use an ip address of or from the airport????

thank you

zen

Post by zen » Tue Feb 13, 2007 10:39 am

ok did the modprobe rebooted light still on no ip yet....any other suggestions.... we are on the right path...thanks

norman

User avatar
hairy_Palms
Level 4
Level 4
Posts: 292
Joined: Mon Nov 27, 2006 10:46 am

Post by hairy_Palms » Tue Feb 13, 2007 10:45 am

try running wifi-radar from the terminal to see what messages it shows

sudo wifi-radar -d

zen

Post by zen » Tue Feb 13, 2007 10:49 am

thanks for the reply...i am working from powerbook since the other is offline at present - the linux laptop

when I ran it it comes back with dhclient3 --version 2>&1

thank you...i mean it!!!

User avatar
hairy_Palms
Level 4
Level 4
Posts: 292
Joined: Mon Nov 27, 2006 10:46 am

Post by hairy_Palms » Tue Feb 13, 2007 10:55 am

no problem :)
i think you might need to install
wpasupplicant

[EDIT] oh and try running sudo iwconfig too[/EDIT]
to make your passwords etc work
then use wifi-radar to configure it
Image
Last edited by hairy_Palms on Tue Feb 13, 2007 10:58 am, edited 1 time in total.

zen

Post by zen » Tue Feb 13, 2007 10:57 am

Ok I am sorry - where do I get that? add and remove? please have patience

mu system is wep encrypted 128 bit


i have that - I also noticed that you have something listed under driver - I do not know of any driver info

thanks
Last edited by zen on Tue Feb 13, 2007 11:02 am, edited 1 time in total.

Post Reply

Return to “Wireless”