WiFi on D-Link DWA 160 keeps dropping

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
JFletch
Level 1
Level 1
Posts: 2
Joined: Sun Jun 10, 2012 8:30 am

WiFi on D-Link DWA 160 keeps dropping

Post by JFletch » Tue Jul 03, 2012 9:47 pm

I had this solved for Mint 11, but the same solution does not work for 13. Can anyone guide me through getting this back up? My system is a dual boot to Win7, but I much prefer working in Mint and am handicapped due to the wireless dropping.

I also have a spare dongle for Linksys AE3000 that I can plug in and use if someone knows a good method of getting that one to work instead.
Last edited by JFletch on Sat Jul 21, 2012 11:51 am, edited 1 time in total.

Gutknecht
Level 1
Level 1
Posts: 38
Joined: Mon Jul 27, 2009 7:32 pm
Contact:

Re: WiFi on D-Link DWA 140 keeps dropping

Post by Gutknecht » Mon Jul 09, 2012 9:06 am

Is wireless actually dropping out or are you losing DNS resolution? I'm researching an upstream bug that affects DNS resolution.

JFletch
Level 1
Level 1
Posts: 2
Joined: Sun Jun 10, 2012 8:30 am

Re: WiFi on D-Link DWA 140 keeps dropping

Post by JFletch » Mon Jul 09, 2012 6:20 pm

I'm kind of a newbie, but the WiFi was still working on other devices. The work around I used in Mint 11 to resolve the driver conflict was:

sudo modprobe -rf rt2870sta rt2800usb rt2800lib rt2x00usb rt2x00lib
sudo modprobe rt2870sta

Open the blacklist file and:
blacklist rt2800usb
blacklist rt2800lib
blacklist rt2x00usb
blacklist rt2x00lib

My understanding is the rt2870sta is no longer present in Mint 13.

Post Reply

Return to “Wireless”