Page 1 of 1

[SOLVED] After updates "Network Manager not running..."

Posted: Tue Aug 07, 2012 1:28 pm
by jaderiver
I am in a city where there is WiFi and trying to catch up on updates, etc., because I generally use dialup where I live, in rural area.

After Level 1 and 2 updates, everything seemed to be fine. I had also just downloaded Chrome.

Waited awhile to update Level 3 updates, because there were so many listed. After completing and then hibernating, everything still fine. But then, after complete reboot, "Network Manager not running..." :(

On terminal, tried:
service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

These last commands brought up window to configure VPN, but no wireless accounts listed to click on (although they were listed in Network Manager)

Now, other quirks starting to appear as well, such as not being able to access Network Manager at all!

What is happening and solutions? Mint 13 Mate was running beautifully until these updates. I am dual booting w/ WIN 7 to be able to communicate.

Thanks for help in advance.

Re: After Level 3 updates "Network Manager not running..."

Posted: Thu Aug 09, 2012 11:29 am
by oobetimer

Re: After Level 3 updates "Network Manager not running..."

Posted: Fri Aug 31, 2012 6:31 pm
by jaderiver
Hi oobetimer...

Finally getting back to you w/ results of your suggestion after returning home. I was still troubleshooting the wireless issue, which popped up after installing updates, and checking results at the local library where there is WiFi.

Your suggestions to
sudo service network-manager start

did indeed stop "Network Manager not running" contextual menu while pointing to the NM applet on the task panel. But then, the "wireless connection" still did not list available networks, but stated "device not managed." Grrr... :( Terminal said NM was running and listed job #, but nothing listed with the panel applet. To add insult to injury, after following instructions to make the terminal command permanent in gksudo pluma /etc/rc.local, the NM applet in the task panel disappeared altogether! :?

I was tempted to remove NM, and install wicd, but eventually found solution(s) on ubuntu forums:

First, reinstalled a new Network Manager (don't think I bothered to purge first); in terminal:
sudo apt-get install --reinstall network-manager network-manager-gnome

A) Then, in terminal:
sudo pluma /etc/NetworkManager/NetworkManager.conf

Change managed=false to managed=true.

B) Next, in terminal:
sudo pluma /etc/network/interfaces

Remove everything except:
auto lo
iface lo inet loopback

(One might want to save content before removing.)

Reboot. Applet reappears on task panel! Be sure to right-click applet and check "Enable Networking" and "Enable Wireless." I also deleted all other accounts in "Edit Connections" though not sure this step was necessary. In Network Manager, I checked "Enable roaming mode" for wireless.

Network Manager is working fine now, and the computer is working more efficiently than ever. :D For example, bootup no longer hangs on "Waiting for network configuration" & "Waiting up to 60 more seconds or network configuration."* Maybe the fixes enabled other updates to finally work.

Useful links for a more global understanding about "Device not managed" issue:

Hopefully this information helps others with similar update issues.

[* Tangent: Getting hung on boot messages "Waiting for network configurations" etc, can also be fixed this way:
In terminal:
sudo pluma /etc/init/failsafe.conf

>>>Add # (comment out) before every sleep command. There are four sleep commands. I did not have to do this after fixing Network Manager per above. Not sure why.]

Re: [SOLVED] After updates "Network Manager not running..."

Posted: Mon Sep 23, 2013 11:23 pm
by djalecc
Great Fix, thank you! Worked for my issue ( Wireless WiFi icon dissapeared from system tray ) this fix brings it back again :)

Re: [SOLVED] After updates "Network Manager not running..."

Posted: Tue Sep 24, 2013 4:48 pm
by jaderiver
Great to hear the fix worked for you! Thank you so much for feedback on a topic written awhile ago and good to see you were able to still use the information.


Re: [SOLVED] After updates "Network Manager not running..."

Posted: Tue Nov 19, 2013 12:40 pm
by pleurastic
Worked for a Dell Inspiron 5100, Broadcom 4306 (legacy). Thanks.

Re: [SOLVED] After updates "Network Manager not running..."

Posted: Tue Dec 16, 2014 1:32 pm
by CorSakov
Worked great, thanks, jaderiver

Re: [SOLVED] After updates "Network Manager not running..."

Posted: Tue Dec 16, 2014 4:05 pm
by jaderiver
So glad to see this older solution continues to help some of you :)

Thank you for your feedback.