Atheros AR9462 Wireless Problem on Mint 14

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Fri Feb 08, 2013 12:32 am

Atheros AR9462 Wireless Problem on Mint 14

Postby BillThePony » Fri Feb 08, 2013 1:03 am

I have a Acer Aspire V3-771G with Atheros AR9462 Wireless. The wireless card appear to be "Qualcomm Atheros AR5BWB222 Wireless Network Adapter" under windows 8. BTW, I was able to dual boot Win8 with Mint 14 with some effort. I need to disable "secure boot" in order to boot Linux. Initially only the bluetooth did not work under both Win8 and Mint. Since I did not care about bluetooth, everything was just fine. Yesterday, I updated the wireless driver under Win8, I don't know if that is the reason, but when I tried to boot into Linux the wireless would not work. The wireless would only work in Win8 if I reset my BIOS to use the default (with secure boot on). After updating my BIOS firmware under Win8 and reinstalling the wireless driver, now both the wireless and bluetooth can work under Win8 even with secure boot off. However, in Linux the wireless is still not working.

The wired thing is that if I boot Linux Mint 14 from a live usb drive, the wireless could work just fine using the driver "ath9k". So I am not sure whether it is the "dual boot" and the firmware that caused the problem or it is because the updated Linux kernel fails to work with this wireless card somehow. Now when I boot into Linux, the wireless LED light will not turn on.

Here is the output for mintWifi:
* I. scanning WIFI PCI devices...
-- Atheros Communications Inc. AR9462 Wireless Network Adapter (rev 01)
==> PCI ID = 168c:0034 (rev 01)
* II. querying ndiswrapper...
* III. querying iwconfig...
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr 4c:72:b9:71:67:d3
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:240 (240.0 B) TX bytes:240 (240.0 B)

* V. querying DHCP...
* VI. querying nslookup
;; connection timed out; no servers could be reached

What additional test should I run in order to diagnose the problem? Thank you for your help!

Level 1
Level 1
Posts: 2
Joined: Tue Mar 05, 2013 5:14 pm

Re: Atheros AR9462 Wireless Problem on Mint 14

Postby itowill » Tue Mar 12, 2013 7:42 pm

hey I have acer 5742 with same ard problem

what worked for me was sudo modprobe ath9k
then mintwifi

I am new to dual booting w7/linuxmint so I don't know this worked or if its permanent solution
but you should try it. Let me know and maybe someone can explain why this works,


Level 1
Level 1
Posts: 8
Joined: Fri Dec 12, 2014 9:07 pm

Re: Atheros AR9462 Wireless Problem on Mint 14

Postby sidser » Mon Dec 29, 2014 3:18 am

Hey Acer aspire.... same story i have... my wireless same i see all spots with wifi... but a cannot connect to any he drops them... but i windows i can... i searching how to resolve this problem already 2 weeks.... :D and nothing found... i trying a lot but still nothing

Return to “Wireless”

Who is online

Users browsing this forum: No registered users and 3 guests