Bluetooth error (Gio.DBusError / Obex)

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Mon Mar 11, 2013 5:17 am

Bluetooth error (Gio.DBusError / Obex)

Postby MintyCayenne » Wed Mar 13, 2013 6:59 pm


Bluetooth seems to suddenly not be working in th recent Mint (& Ubuntu) releases on my Dell, while stile working on previous versions (Mint 11) on the same machine (so it is not hardware).

I've been using Mint 11 for a long time. Aftera HDD semi-crash and forced reinstall, I tried Ubuntu 12.10 briefly. Bluetooth problem. Dumped it. The installed amd am currently using Mint 14.1 Cinnamon 32-bit -- exactlythe same problem.

The device is found and pairs easily enough. It is in trying to browse it that a 'Gio.DBusError' error occurs. Using Blueman, the error: "Failed to open "obex://[....]/" "Connection refused" appears.

I need it to get pics off my phone regularly. I've managed to send a file *to* the phone, but sending *from* the phone to the PC the operation fails.
Could this be protocol related? Kernel related?

lsusb gives me:
Bus 003 Device 006: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 003 Device 007: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth

I don't know what to run in the terminal for uselful output.

Suggestions anybody?

Level 5
Level 5
Posts: 602
Joined: Thu Nov 26, 2009 10:50 am

Re: Bluetooth error (Gio.DBusError / Obex)

Postby lauren » Thu Jun 20, 2013 10:40 am

Sorry: late and no help.
I have tested more than 10 distributions on 2 computers - including Maya, Nadia, Olivia MATE and Cinnamon, Xfce , KDE , conclusion:
Bluetooth only works with KDE, Mate BT does not work, Blueman works except browse on device. I was searching hours and I am thinking, it is a bug, even on XFCE editions with Thunar it does not work - blueman is developped for XFCE, I suppose.
What I do not understand: In each Linux forum there are unsolved BT problems, a thread with more than 15000 views [not really solved], the Mate BT problem is well known since months and nothing happens.
BT - of no importance for Linux ?
Notebook: BIOS Linux multiboot
Netbook: EFI Linux multiboot

Return to “Wireless”