network printer cannot be located

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 3
Level 3
Posts: 183
Joined: Thu Nov 11, 2010 4:46 am

network printer cannot be located

Postby banjoman » Thu Apr 04, 2013 4:35 pm

I have a GoFlex Home NAS disk which I can access through the Network link in File Explorer. I can attach a USB printer to it and then use it as a network printer, which I have successfully done with 2 Windows laptops in the house.

However my Mint 14 laptop cannot find the printer, when I try to add a network printer I get the following message;
FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall.

I used to be able to access my GoFlex through an IP address - http://goflex_home or http://<IP address>, but now this does not work, I cannot successfully add an address to the Add Printer search box...

I don't know what this means or how to remedy this!!
Last edited by banjoman on Thu Apr 04, 2013 4:56 pm, edited 1 time in total.

User avatar
Level 10
Level 10
Posts: 3452
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: network printer cannot be located

Postby kc1di » Thu Apr 04, 2013 4:47 pm

Hello banjoman,

there is an upstream problem with the Printer tool in Gnome3 which unfortunately has been transfered to mint cinnamon anyway, not sure about the other desktops.
you can set up your printer by opening your favorite browser and in the address type:

Code: Select all


this will bring the cups printer setup page up. under CUPS for Administrators click on adding printers and classes.
following the dialogues that follow and add your printer. you'll need the ip address.. (something like )

Code: Select all

Good luck

Level 18
Level 18
Posts: 8820
Joined: Tue Feb 03, 2009 10:27 am

Re: network printer cannot be located

Postby altair4 » Thu Apr 04, 2013 4:56 pm

FirewallD is a RedHat daemon so it will be kind of hard for you to start it.

kc1di's method will certainly work and you can also try the Gnome2 version of the printer utility. From the terminal:

Code: Select all


It should already be installed but if it isn't the above command will tell you to install the correct package.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Level 1
Level 1
Posts: 1
Joined: Sun May 30, 2010 3:47 am

Re: network printer cannot be located

Postby mpabele » Tue Apr 16, 2013 7:35 pm

Thanks Altair4 - worked like a charm! :D

Return to “Wireless”