Page 1 of 1

Ralink RT3072 USB Wireless adapter drops signal every 5 mins

Posted: Wed Apr 10, 2013 1:22 pm
by izzo
A little history.

Mint 11 Katya 64-bit, 2.6.38-16-generic-pae, 4GB RAM, Gnome 2

Moved to a new place, 3-story house, router is upstairs on the 3rd floor, no access to it,
I am on the first floor; phone and 2 laptops pick the signal fine (3/5 bars, about 800k download speed).

My desktop however is in the corner of the living room, and has an old RTL 8185 wireless PCI adapter,
which wouldn't even see the wireless network. I tried with an external USB stick (wireless G) on a 6 feet USB cable -
barely sees the network, don't even talk about connecting to it.

So I bought this external USB-N adapter: USB Wireless Lan 802.11N High Power Adapter w/ 2 Antenna - 2T2R (300Mbps) - two big antennas, bla-bla.
It has the Ralink RT3072 chip, I needed some time to find good linux drivers (the ones supplied didn't work - d'oh!!!).
The drivers I got were for the 3070 family and compiled fine after some playing with the file.
The only funny thing is that lsusb shows it as RT3072:

Code: Select all

	Bus 001 Device 002: ID 148f:3072 Ralink Technology, Corp. RT3072 Wireless Adapter
However in modprobe it is rt5370sta:

Code: Select all

	modprobe rt5370sta
Which didn't really bother me as the adapter worked FINE with these drivers, I see twice the amount of networks
compared to my laptop, and it gets 5/5 bars to my wireless when connected. Here's the result of a speedtest:

Output of /usr/lib/linuxmint/mintWifi/

Code: Select all

	ra0       Ralink STA  ESSID:"D9GY0"  Nickname:"RT2870STA"
		  Mode:Managed  Frequency=2.462 GHz  Access Point: 00:26:B8:18:86:D6   
		  Bit Rate=48 Mb/s

So... To the point. To the points, actually.

Upon restart, the blue light on the wireless adapter is blue, however I have NO "Wireless Networks" in network manager AT ALL.
As if the adapter is not seen/installed AT ALL. It takes disable/enable network a few times, a good 4-5 minutes of it before it
shows up in the network manager and connects. From then on it is all good, until...

When it connects, it stays connected - no problem, see history above.
Then the adapter drops the signal, and I have to disable the wireless adapter and re-enable it; then it's all over again...
Almost seems like the adapter doesn't like deluge running...

So... is it a driver issue or what?!?!

Re: Ralink RT3072 USB Wireless adapter drops signal every 5

Posted: Mon Apr 15, 2013 1:29 pm
by izzo
Update after a few days of running with said adapter...

ANY big file I try to download, OR when making a call either via Google Talk or Skype will make the adapter disconnect.
I can't even talk for a minute and bam.

Any input?