wireless disappears and will not reconnect without reboot

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
dehawkinz
Level 2
Level 2
Posts: 75
Joined: Tue Sep 13, 2011 5:09 pm

wireless disappears and will not reconnect without reboot

Post by dehawkinz »

I am having a problem with my wifes laptop. When the laptop starts up, we can connect to the wireless router no problem, and it runs OK for some time (hours) but then suddenly it will lose internet connectivity (that is the symptom) and after a while it will fail to connect to the router. The only way to restore the connection is to do a reboot, and then it will work again.
checking it when it is in the 'no internet' state shows it has in fact lost contact with the router, but has not realised it yet.
when it has no router connection, I am unable to connect to anything, I can not even ping the router (192.168.0.1)

this is the OK state just after booting

Code: Select all

joy@laptop ~ $ rfkill list
0: phy0: Wireless LAN	
Soft blocked: no
Hard blocked: no

joy@laptop ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:90:f5:8f:02:d9  
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000 
RX bytes:0 (0.0 B)  
TX bytes:0 (0.0 B)
Interrupt:45 

lo        Link encap:Local Loopback  
inet addr:127.0.0.1  Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING  MTU:16436  Metric:1
RX packets:32 errors:0 dropped:0 overruns:0 frame:0
TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0 
RX bytes:2160 (2.1 KB)  
TX bytes:2160 (2.1 KB)

wlan0     Link encap:Ethernet  HWaddr 00:25:d3:1d:b3:b4  
inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
inet6 addr: fe80::225:d3ff:fe1d:b3b4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:95 errors:0 dropped:0 overruns:0 frame:0
TX packets:278 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000 
RX bytes:17764 (17.7 KB)  
TX bytes:50057 (50.0 KB)

joy@laptop ~ $ iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.
wlan0     IEEE 802.11bgn  ESSID:"virginmedia4614975"  
Mode:Managed  Frequency:2.437 GHz  Access Point: 00:8E:F2:E0:D3:3C   
Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
Power Management:off
Link Quality=70/70  Signal level=-35 dBm  
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0   Missed beacon:0
when it has stopped responding I get this

Code: Select all

joy@laptop ~ $ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

joy@laptop ~ $ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:90:f5:8f:02:d9  
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000 
RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Interrupt:45 

lo        
Link encap:Local Loopback  
inet addr:127.0.0.1  Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING  MTU:16436  Metric:1
RX packets:473 errors:0 dropped:0 overruns:0 frame:0
TX packets:473 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0 
RX bytes:46607 (46.6 KB)  TX bytes:46607 (46.6 KB)

wlan0     Link encap:Ethernet  HWaddr 00:25:d3:1d:b3:b4  
inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
inet6 addr: fe80::225:d3ff:fe1d:b3b4/64 Scope:Link
UP BROADCAST MULTICAST  MTU:1500  Metric:1
RX packets:90522 errors:0 dropped:0 overruns:0 frame:0
TX packets:76502 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000 
RX bytes:68560176 (68.5 MB)  TX bytes:15572808 (15.5 MB)

joy@laptop ~ $ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
Mode:Managed  Access Point: Not-Associated   
Tx-Power=20 dBm   
Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
Power Management:off
I am no wireless or linux expert, so 'simple' advice would be appreciated :)
dehawkinz
Level 2
Level 2
Posts: 75
Joined: Tue Sep 13, 2011 5:09 pm

Re: wireless disappears and will not reconnect without reboo

Post by dehawkinz »

can anyone help with this?

I have tried with different routers, but get exactly the same problem
baanlanna
Level 1
Level 1
Posts: 2
Joined: Tue Jan 07, 2014 5:55 am

Re: wireless disappears and will not reconnect without reboo

Post by baanlanna »

BUMP !

I have exactly the same problem... all works fine until randomly wifi connection is lost. It's unable to reconnect (trying to but everytime fails).
The only thing that gets it running again is a reboot.

Help is appreciated!
Roland
Level 3
Level 3
Posts: 183
Joined: Sun Oct 04, 2009 9:44 am

Re: wireless disappears and will not reconnect without reboo

Post by Roland »

Same here; Mint 14 Cinnamon.
baanlanna
Level 1
Level 1
Posts: 2
Joined: Tue Jan 07, 2014 5:55 am

Re: wireless disappears and will not reconnect without reboo

Post by baanlanna »

Fixed it by installing latest backport

Code: Select all

$ wget http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.12.2/backports-3.12.2-1.tar.bz2
$ tar xvf backports-3.12.2-1.tar.bz2
$ cd backports-3.12.2-1/
$ make defconfig-wifi
$ make
$ sudo make install
Don't forget to shutdown and reboot
Roland
Level 3
Level 3
Posts: 183
Joined: Sun Oct 04, 2009 9:44 am

Re: wireless disappears and will not reconnect without reboo

Post by Roland »

Tried Linux 16 Cinnamon on external drive, and wireless was stable now! However, 'kernel panic' error emerged.
:-)
Will wait Mint 17.
Post Reply

Return to “Wireless”