Wireless keeps asking me for password

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Sub
Level 1
Level 1
Posts: 11
Joined: Thu May 23, 2013 9:55 am

Wireless keeps asking me for password

Post by Sub » Sat Aug 03, 2013 3:41 pm

The internet works if i plug it in but the wireless never works
the button in the right hand corner tells me that i have 80% wireless connection but when i try to connect it just repeatedly asks me for authentification and never actually connects, please help, thankyou

subal@subal-Monza-T200 ~ $ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
[sudo] password for subal:
-------------------------
* I. scanning WIFI PCI devices...
-- Realtek Semiconductor Co., Ltd. RTL8188CE 802.11b/g/n WiFi Adapter (rev 01)
==> PCI ID = 10ec:8176 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr=2347 B Fragment thr:off
Encryption key:off
Power Management:on

-------------------------
* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr 80:ee:73:4b:a5:df
inet addr:192.168.1.5 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::82ee:73ff:fe4b:a5df/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:21459638 errors:0 dropped:0 overruns:0 frame:0
TX packets:16333813 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21298207896 (21.2 GB) TX bytes:9648125461 (9.6 GB)
Interrupt:44

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:13343 errors:0 dropped:0 overruns:0 frame:0
TX packets:13343 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1326769 (1.3 MB) TX bytes:1326769 (1.3 MB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 192.168.1.1
Address: 192.168.1.1#53

Non-authoritative answer:
Name: google.com
Address: 173.194.34.142
Name: google.com
Address: 173.194.34.134
Name: google.com
Address: 173.194.34.132
Name: google.com
Address: 173.194.34.137
Name: google.com
Address: 173.194.34.136
Name: google.com
Address: 173.194.34.128
Name: google.com
Address: 173.194.34.130
Name: google.com
Address: 173.194.34.133
Name: google.com
Address: 173.194.34.131
Name: google.com
Address: 173.194.34.135
Name: google.com
Address: 173.194.34.129

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Sun Oct 20, 2013 4:11 pm

Hello everyone, I have exactly the same issue. I am a LMDE user. It seem to be common problem, I have installed on few other PCs lubuntu 12.04 and network manager never let connect to a wifi network, it always said the passphrase is incorrect. Complete deinstallation of gnome-network-manager and replacing it by wicd solved the problem, but I don't want to try it with my new Mint (because I like it's interface and I want to gather it).

The problem occurs with a network which uses WPA-Personal type of security and I would also like to say solution from this link does not apply to the problem because the line they ask to replace does not exist in network file.

http://forums.linuxmint.com/viewtopic.php?f=194&t=83599

Here I post some restults.

The mintwifi test script.

Code: Select all

pucek@hellion /var/log $ sudo mintwifi
-------------------------
* I. scanning WIFI PCI devices...
  -- Ralink corp. RT2561/RT61 802.11g PCI
      ==> PCI ID = 1814:0301
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo        no wireless extensions.

eth1      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
-------------------------
* IV. querying ifconfig...
eth1      Link encap:Ethernet  HWaddr 00:16:17:bf:98:eb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:45 Base address:0x4000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:1f:1f:32:2e:27  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...
;; connection timed out; no servers could be reached
Here's what nm-applet says when I try to connect:

Code: Select all

pucek@hellion /var/log $ nm-applet
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
** Message: No keyring secrets found for SFR_5458/802-11-wireless-security; asking user.
I don't what this one says, maybe it will be usefull for you guys.

Code: Select all

pucek@hellion ~ $ nmcli con
NAME                      UUID                                   TYPE              TIMESTAMP-REAL                    
Wired connection 1        88d2d634-5294-4186-9489-1fd9f4bd2db7   802-3-ethernet    Sun 20 Oct 2013 06:23:54 PM CEST  
SFR_5458                  088c36a1-2de2-4239-ae76-07b055263481   802-11-wireless   never 
I won't be posting ifconfig and iwconfig as mintwifi already printed them out.

Here is my wifi card:

Code: Select all

pucek@hellion /var/log $ lspci -vrm
(...)
01:00.0 Network controller: Ralink corp. RT2561/RT61 802.11g PCI
	Subsystem: Ralink corp. EW-7108PCg
	Flags: bus master, slow devsel, latency 64, IRQ 18
	Memory at fbff8000 (32-bit, non-prefetchable) [size=32K]
	Capabilities: <access denied>
	Kernel driver in use: rt61pci
(...)
And it's modules in the kernel. Those are three, rt61pci is the main one and it probes rt2x00pci which probes rt2x00lib.

Code: Select all

pucek@hellion /var/log $ lsmod
Module                  Size  Used by
(...)
rt61pci                26905  0 
rt2x00pci              12847  1 rt61pci
rt2x00lib              38335  2 rt2x00pci,rt61pci
(...)
I've checked what happends in syslog and daemon.log (network manager outputs to those files for debugging). I've removed the wificard modules and probed them again to the kernel to see if something happends and there was nothing interesting. Here's what happends when I try to connect.

Code: Select all

Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0) starting connection 'SFR_5458'
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0/wireless): connection 'SFR_5458' has security, and secrets exist.  No new secrets needed.
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Config: added 'ssid' value 'SFR_5458'
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Config: added 'scan_ssid' value '1'
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Config: added 'psk' value '<omitted>'
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Oct 20 21:42:07 hellion NetworkManager[2625]: <info> Config: set interface ap_scan to 1
Oct 20 21:42:08 hellion NetworkManager[2625]: <info> (wlan0): supplicant interface state: inactive -> scanning
Oct 20 21:42:32 hellion NetworkManager[2625]: <warn> Activation (wlan0/wireless): association took too long.
Oct 20 21:42:32 hellion NetworkManager[2625]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Oct 20 21:42:32 hellion NetworkManager[2625]: <warn> Activation (wlan0/wireless): asking for new secrets
Oct 20 21:42:32 hellion NetworkManager[2625]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
Oct 20 21:42:32 hellion NetworkManager[2625]: <warn> Couldn't disconnect supplicant interface: This interface is not connected.
Oct 20 21:42:33 hellion NetworkManager[2625]: <info> (wlan0): supplicant interface state: scanning -> inactive
Oct 20 21:43:13 hellion NetworkManager[2625]: <warn> No agents were available for this request.
Oct 20 21:43:13 hellion NetworkManager[2625]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
Oct 20 21:43:13 hellion NetworkManager[2625]: <warn> Activation (wlan0) failed for access point (SFR_5458)
Oct 20 21:43:13 hellion NetworkManager[2625]: <info> Marking connection 'SFR_5458' invalid.
Oct 20 21:43:13 hellion NetworkManager[2625]: <warn> Activation (wlan0) failed.
Oct 20 21:43:13 hellion NetworkManager[2625]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Oct 20 21:43:13 hellion NetworkManager[2625]: <info> (wlan0): deactivating device (reason 'none') [0]
I hope someone understands what is going on. It would be really a shame if the only solution is to deinstall network manager and install wifi. I find it strange because I see many users have this particular problem with wifi authentication and (at least I couldn't find it) there is no satisfying solution for the problem. I count on you. Cheers!

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Sun Oct 20, 2013 4:52 pm

UPDATE:
Added myself to a group netdev, didn't change anything. Still searching.

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Mon Oct 21, 2013 2:58 pm

Just to be sure I connected a different card, apparaintly better, because it detected all the networks with much better signal rate. The problem is the same. Won't connect, just keeps asking for password over and over.

A curious thing, I created a hotspot with my mobile phone just to check if it will connect, the authentication worked well, except that it wasn't WPA-PSK but WPA-AES.

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Mon Oct 21, 2013 3:48 pm

Reconfigured my router the way it would have the same parameters as my hotspot on mobile phone (WPA2 with AES key). Changes nothing.

EDIT: I got syslogs of the one that works and the one that fails, unfortunately can't post it here, forum says "Too few characters" which is strange. Anyway I don't think anyone is going to help me.

ArabiaAvonlea
Level 1
Level 1
Posts: 1
Joined: Mon Oct 21, 2013 11:10 pm

Re: Wireless keeps asking me for password

Post by ArabiaAvonlea » Mon Oct 21, 2013 11:37 pm

I just ran an "update-manager -d", installed everything that was
> available, and now the wireless works. I did an update yesterday, and
> it did not work after that. So something made the difference!
So, I was too drawing that conclusion.
ArabiaAvonlea

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Tue Oct 22, 2013 12:10 pm

Worked for me, thankss!!!

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Tue Oct 22, 2013 12:32 pm

Worked for some time, my WiFi disconnected for some reason and I'm back where I was, exactly the same issue.

A difference I noticed, when it worked, it didn't asked me anything, it just connected, now (and before it worked) it asks me all the time my user password and WPA2 authentication key over and over again.

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Tue Oct 22, 2013 2:53 pm

Ok here's my update.

Removed (purged) network-manager and network-manager-gnome, installed wicd.
The effect: it listed some networks but not all (including mine, it wasn't present on the list). Tryed to replug my wifi adapter and bang, kernel panic. A friend found me this:

https://bugs.launchpad.net/ubuntu/+sour ... omments/31

So I compiled the newest driver from here:

[url]http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=21&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#2742[/url]

Builded it, installed and replaced the older one.

The result: wicd started to see all the networks but still cannot connect while authentication!

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Tue Oct 22, 2013 3:17 pm

Tryed to conncet manually (yes, I am so stubborn) using wpa_supplicant.

Saving my key to a file. I put **** in place of my passphrase.

Code: Select all

pucek@hellion ~ $ wpa_passphrase SFR_5458 **** > konf.conf
And connecting gives me this...

Code: Select all

pucek@hellion ~ $ sudo wpa_supplicant -Dwext -iwlan1 -c konf.conf
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Wed Oct 23, 2013 2:58 pm

Since yesterday I changed nothing in my config. Suprisingly it connected (without authentification failure). Except that nothing could go through the network. System has seen the connection as still up, on the router it dissappeared right away like if disconnected.

Changed wifi card again, the same problem except that signal is weaker (the card is not that good as the other one). And once i retryed I got "Connection failed: Bad password". A password stored on the disc, nothing changed but suddenly it is wrong. So authentication problem once again.

One more info, I checked a live cd of other linux (lubuntu 12.04) and result was the same.

We can be sure it doesn't come from network card. I don't think the source of the problem lays in the router (however some people suggested it to me). It is not the system (since I tryed an other one, but I have to verify few others). What else could it be?!

EDIT:

I just connected and had bandwith. Started the upgrade (to see how it works). Between 5B/s and 50kB/s, very slow, the connection disconnected every few minutes (but reconnected without problems) until one minute ago when it suddenly said "bad password" (which of course is the same, loaded from the drive).

It looks very random to me. Hard to give any conclusion. Still hoping for some feedback.

ros09003
Level 1
Level 1
Posts: 1
Joined: Wed Oct 23, 2013 9:54 pm

Re: Wireless keeps asking me for password

Post by ros09003 » Wed Oct 23, 2013 10:20 pm

Was this issue ever resolved? I'm a total newb, just switched to linux mint. my wireless usb which worked fine with windows is giving me this same issue, it can see that there are networks out there but whenever I try to connect to my wifi my computer keeps asking me for a password but never successfully connects. Any gurus out there that can help with this?

pucek
Level 1
Level 1
Posts: 10
Joined: Sun Oct 20, 2013 3:50 pm

Re: Wireless keeps asking me for password

Post by pucek » Fri Oct 25, 2013 4:12 pm

For me it is a completely random thing. One minute ago it connected, now it won't even detect the networks.

And I don't think any "Guru" will help you or me, they don't care since it is not their problem. Sad true.

raqqos
Level 1
Level 1
Posts: 4
Joined: Mon Oct 21, 2013 12:39 pm

Re: Wireless keeps asking me for password

Post by raqqos » Sun Nov 03, 2013 5:38 pm

Hey, I've got the same problem and I've been searching for solution for about a week. Maybe if more people report this problem someone will help. But I'm beggining to regret that I got rid of Windows... Nice support for Mint:(

macfflei
Level 1
Level 1
Posts: 20
Joined: Sun Oct 09, 2011 4:07 am

Re: Wireless keeps asking me for password

Post by macfflei » Mon Nov 11, 2013 5:06 pm

I've never had any problems with connecting, but my wifi connection simply dropped out randomly every now and then, it then prompted for a password etc.
Anyway it bugged me for months, I suddenly noticed that it didn't happen when running on power! I finally found the solution an it never happened again. This may sound strange but here goes. Simple go to your power settings or hover over the battery icon and click on preferences, untick reduce back light brightness under the battery tab, and there you go...

Let me know how you get on.

macfflei
Level 1
Level 1
Posts: 20
Joined: Sun Oct 09, 2011 4:07 am

Re: Wireless keeps asking me for password

Post by macfflei » Fri Nov 22, 2013 6:11 am

Try this
open terminal and type "iwconfig"
power management should be off.

If it is on "sudo iwconfig wlan0 power off" will switch it off, however on restart it will be back on.

To over come type "sudo nautilus" in terminal, a file manager will appear, be careful, you can do some damage here!
Navigate to /etc/pm/config.d
simply create a text file called blacklist
in the file enter the below and save.
HOOK_BLACKLIST="wireless"

Restart.... it should work

zoddy01
Level 1
Level 1
Posts: 1
Joined: Fri Nov 22, 2013 8:25 am

Re: Wireless keeps asking me for password

Post by zoddy01 » Fri Nov 22, 2013 8:29 am

I am facing the same problem my system is asking me pasword again and again............please help me


[url=http://www.newtonit.co.uk/]disaster recovery data[/url]

macfflei
Level 1
Level 1
Posts: 20
Joined: Sun Oct 09, 2011 4:07 am

Re: Wireless keeps asking me for password

Post by macfflei » Fri Nov 22, 2013 12:25 pm

zoddy01 wrote:I am facing the same problem my system is asking me password again and again............please help me


[url=http://www.newtonit.co.uk/]disaster recovery data[/url]
Hi Zoddy01 open terminal and input iwconfig

If the power management is on then do the above. (navigate to /etc/pm/config.d create a text file called blacklist,
input the following in the new file and save.
HOOK_BLACKLIST="wireless"

Hope this helps

NHnewb
Level 1
Level 1
Posts: 2
Joined: Thu Nov 21, 2013 10:44 pm

Re: Wireless keeps asking me for password

Post by NHnewb » Mon Nov 25, 2013 3:17 pm

Hi all,
I'm having the same problem on my linux mint maya 13 mate 64 bit dual boot machine... I guess I ran an update that messed with my wireless, because it was fine until 10 days ago. I'm trying to post the info I have from running some command lines but I'm habing technical difficulties. I know the power management is off, and when I run mintwifi.py, the last lines say:

*V. querying DHCP...
--------------------
*VI. querying nslookup google.com...
;; connection timed out; no servers could be reached

Any advice for a brand new user who is still figuring out how to use the terminal window?
Many thanks in advance!

saumagen
Level 1
Level 1
Posts: 1
Joined: Thu Dec 19, 2013 10:12 am

Re: Wireless keeps asking me for password

Post by saumagen » Thu Dec 19, 2013 10:15 am

Hi I'm experiencing the very same problem, my wireless chipset is the Realtek RTL8188CUS (Netgear WNA1000M N150 USB Dongle, http://wikidevi.com/wiki/Netgear_WNA1000M).

I'm on 64bit Mint 16 Cinnamon.

This sucks :(

EDIT: After some more googling it turns out this is a common issue, at least with this specifc chipset (which is fairly common in many wireless devices of various brands), for example see:

http://ubuntuforums.org/showthread.php?t=1769669
http://ubuntuforums.org/showthread.php?t=2148130

A solution can be found here: http://ubuntuforums.org/showthread.php?t=2092934

Here you can download the latest official Realtek driver for the RTL8188CUS chipset: http://www.realtek.com.tw/downloads/dow ... =true#2742

I couldn't compile the driver yet though, the current version from realtek.com.tw is newer than the one mentioned in the solution thread on ubuntuforums, which required a patch and this patch doesn't work with the latest driver version. I tried manually patching the recent version based on the patch provided for the old one, but could't get it to compile without errors yet. Specifically, I'm stuck at "implicit declaration of function 'create_proc_entry'", which apparently isn't available anymore in modern kernels and could possibly be replaced by proc_create, or something..

Post Reply

Return to “Wireless”