Broadcom 4318 Howto for Elyssa **Update for Mint 8**

Questions about Wi-Fi and other network devices, file sharing, firewalls, connection sharing etc
Forum rules
Before you post please read how to get help
Arron

Re: Broadcom 4318 Howto for Elyssa

Post by Arron »

This may sound silly, but make sure it is turned up, and not muted (my mute button does not light up like in windows). run

Code: Select all

lsmod
and post the output. But for this start a new thread, and send me a private message with the new thread. Its most likely something else. Check out

http://ubuntuforums.org/showthread.php?t=809785

and

http://ubuntuforums.org/showthread.php?t=616845

May be of some help.

Welcome to Mint!
Arron

Re: Broadcom 4318 Howto for Elyssa

Post by Arron »

There has been some changes with WICD and a couple other small things with wifi. I have updated my Howto, to make it a lot shorter, and here it is.

Please let me know if this new howto get you up and running, before I replace the old one that works for many.

Thanks.

New Broadcom 4300 Hotwo:

1. Download your broadcom wifi driver for Windows, unzip it and save it somewhere u can access it on Mint ( like a usb stick ).
2. In mint go into your menu - Administration - Windows wireless Drivers
3. Add you wifi drivers here (should be a .inf file), and it should say the hardware is present.

Reboot, and see if you can connect with gnome network manager (or WICD with XFCE or Fluxbox edition). If you still have no luck with it running, you need to start up the drivers in a certain order:

Run this:

Code: Select all

sudo nano /etc/init.d/rc.local
add this onto the bottom of the file:

Code: Select all

# added for broadcom WIFI
modprobe -r b44
modprobe -r b43
modprobe -r b43legacy
modprobe -r ssb
modprobe -r ndiswrapper
modprobe ndiswrapper
modprobe b44
That *should* do it, good luck, post your success/failure stories please.

WICD Option.

Unfortunately I had no luck with gnome network manager with broadcom for some reason. After may hours I gave up on wifi for a while. Later on I read about some others who had the same problem, and found it was broadcom and gnome network manager did not work well together,so I used WICD, I like it a lot better and never had a problem since.

Thsi is their site:

Code: Select all

http://wicd.sourceforge.net/
If you have network connection in Mint, install instructions are on their website.

If you do not have an Internet connection in Mint, and you need to do this off line, go to this website and grab the .deb package:

Code: Select all

http://apt.wicd.net/
grab the wicd_1.5.6_all.deb file from there (or the current version)

Then run:

Code: Select all

sudo aptitude purge network-manager
sudo dpkg -i wicd_1.5.6_all.deb
Reboot is needed here. Then open WICD and configure for your network. You should be in action now.
Arron

Re: Broadcom 4318 Howto for Elyssa

Post by Arron »

active8 wrote:Hi,

your Broadcom-Mint-Install.tar.gz file is no longer available.

could you repost this again as I could really do with this.

thanks
Hi

Read my last post,

http://www.linuxmint.com/forum/viewtopi ... 18#p119930

You will probably have better luck this way, and a little simpler too.
Arron

Re: Broadcom 4318 Howto for Elyssa

Post by Arron »

This setup is still needed for Gloria, and works well for gloria.

Here is a cleaned up, simplified tarball of what I use without any problems. I am by no way a script junkie, and if someone is, please clean it up!

http://chillsphere.com/Broadcom-Mint-In ... 2.0.tar.gz

I tried to document it fairly well. People who use it, please leave me some feedback.

Arron
TitanTiger
Level 1
Level 1
Posts: 16
Joined: Sun Oct 04, 2009 1:43 pm

Re: Broadcom 4318 Howto for Elyssa

Post by TitanTiger »

Hate to bring up zombie threads, but I have this network card and I'm running Gloria. I cannot get it to work. I tried replacing network-manager-gnome with wicd, and it doesn't work. At least with network manager I can use an old Netgear PCMCIA wireless card I had on hand to get a wireless signal.

The ndiswrapper method got me up and running on Ubuntu 9.04, but not so far with Mint. And when I click on the network manager icon in the tray, I can see the Broadcom card as an option, but it's greyed out. Any thoughts?
TitanTiger
Level 1
Level 1
Posts: 16
Joined: Sun Oct 04, 2009 1:43 pm

Re: Broadcom 4318 Howto for Elyssa

Post by TitanTiger »

Any ideas? I'd really like to get this wireless card working because I'm loving everything else about Mint.
TitanTiger
Level 1
Level 1
Posts: 16
Joined: Sun Oct 04, 2009 1:43 pm

Re: Broadcom 4318 Howto for Elyssa

Post by TitanTiger »

Well, after retracing my steps and walking through this again, it still didn't work. So I went back and tried the Hardware Drivers tool in Mint and installed the fwcutter driver again (it never worked for me on Ubuntu). Rebooted and I'm in business. Go figure.
Arron

UPDATE: Broadcom 4318 Howto Mint 5 6 7 8 Elyssa to Helena

Post by Arron »

Update! For some reason some older broadcom wifi drivers dont work so well in Linux. This does work with Mint 5 6 7 8 with those troublesome drivers.

My original script does need some updating (any takers?), but it can be done very easily yourself and you dont even need the script.

It can be done in 5 easy steps:

1. Find your windows drivers for broadcom, save them somewhere you can access it with mint.

2. Go into "Windows Wireless Drivers" in Menu -> Administration and add your .inf driver here. It may popup "Unable to see if hardware is present.", mine says this, but still says "Hardware present: yes" in the driver screen, and it still works.

3. Add some lines to your /etc/rc.local file
run this to edit the file:

Code: Select all

sudo gedit /etc/rc.local
4. Add this before the "exit 0" line:

Code: Select all

# These lines are to load Broadcom ndiswrapper driver properly
modprobe -r b44
modprobe -r b43
modprobe -r b43legacy
modprobe -r ssb
modprobe -r ndiswrapper
modprobe ndiswrapper
modprobe b44
5. You can now run the script to see if it works,

Code: Select all

sudo /etc/rc.local
And hopefully your light comes on. The rc.local file is run at startup, so should come up on startup, reboot to make sure, if it doesn't you may need to make it executable ( run " sudo chmod a+x /etc/rc.local", these were the default permissions with my fresh install, so it shouldn't be needed).

Im not sure why this code needs to be run exactly, someone told me it was fussy on the order that the modules were loaded.

WICD is not needed any more, Gnome Network Manager seems to work well with the Broadcom drivers as of Mint 7, so unless you like WICD for your own use, don't worry about installing it.

Hope this helps, please let me know if you have any problems and how you make out, mint 8 is VERY nice.
linkin8k

Re: Broadcom 4318 Howto for Elyssa **Update for Mint 8**

Post by linkin8k »

im very new to linux infact like a week new. I installed the mint 8 but every since my wireless has never worked.
I tried your 5 steps but still it doesn't work, after the step 5 where i paste these codes into my terminal: "sudo /etc/rc.local" ,my wireless light still doesn't show or even blick once istead it gives me these line:

oem@oem-laptop ~ $ sudo gedit /etc/rc.local
[sudo] password for oem:
oem@oem-laptop ~ $ sudo /etc/rc.local
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release
WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release

oem@oem-laptop /etc/init.d $



Please help me im new to these linux stuff and i love it but the wireless keeps making me use my old OS
Husse

Re: Broadcom 4318 Howto for Elyssa **Update for Mint 8**

Post by Husse »

@ linkin8k
Welcome to Mint
Whatever you have done - don't do it, read the previous page(s) and start afresh
What you have posted looks like some cut and paste of bits and pieces
Please do not use oem as a user name as it is a reserved word for manufacturers install (and if you by any chance have used the oem install reinstall the correct normal version)
Arron

Re: Broadcom 4318 Howto for Elyssa **Update for Mint 8**

Post by Arron »

Reinstall a clean non-oem install as per Husse's post, and give it another go. What card do you have? "lspci" should have the info on it. Make sure you have the correct drivers for that card.

I have seen those errors before, but the card still came up. Try this again, and post how you made out. Wifi works very well with mint, just tricky for some broadcom drivers. Try the Windows wireless drivers first before you add anything else, that may work by itself for you.

Good luck!
Husse

Re: Broadcom 4318 Howto for Elyssa **Update for Mint 8**

Post by Husse »

Seems to work flawlessly for the 431x chips (maybe not Airport one which is 4311 if my memory serves me right)
Husse

Re: Broadcom 4318 Howto for Elyssa **Update for Mint 8**

Post by Husse »

I have split the install problem for linkin8k into a new post here
Please continue there
Post Reply

Return to “Networking”