Atheros wireless is working but syslog fills with errors?

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
herbie643
Level 3
Level 3
Posts: 160
Joined: Tue Oct 19, 2010 9:16 pm

Atheros wireless is working but syslog fills with errors?

Post by herbie643 »

I have Linux Mint Olivia, upgraded from Nadia about 3mos ago, and have not had any problems. Well I decided to look in the System Logs and found that Syslog has this error:
Sep 12 20:06:21 ajax-Satellite-L355 kernel: [14385.004873] ath5k: ath5k_hw_get_isr: ISR: 0x00000080 IMR: 0x00000000
over and over at different intervals.
I have Google'd everywhere but to no avail.
Any one have any ideas on how to correct this?
As I said, wireless works.
Configuration is:
Linux Mint 15
Intel® Pentium(R) Dual CPU T3400 @ 2.16GHz × 2
Mobile Intel® GM45 Express Chipset x86/MMX/SSE2
Linux ajax-Satellite-L355 3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:54:42 UTC 2013 i686 i686 i686 GNU/Linux
3gb mem

lspci is as follows:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
03:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
User avatar
hal8000
Level 4
Level 4
Posts: 399
Joined: Sun May 04, 2008 2:04 pm
Location: UK

Re: Atheros wireless is working but syslog fills with errors

Post by hal8000 »

Looks like a bug with Atheros gain calibration:


https://bugs.launchpad.net/ubuntu/+sour ... bug/983025


Although youre error log is showing the state of the ISR and IMR registers there will probably
be a gain callibration timeout error eventually.
This will probably be fixed with a newer atheros driver in the future.
herbie643
Level 3
Level 3
Posts: 160
Joined: Tue Oct 19, 2010 9:16 pm

Re: Atheros wireless is working but syslog fills with errors

Post by herbie643 »

Thank you hal8000 for your quick reply. I just checked the syslog and it was over 70mb.
I will wait patiently for a fix.
Thanks again.
Regards,
Marshall Neill
Post Reply

Return to “Wireless”