Broadcom 4318 not working with LM 16 32 bit

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Level 1
Level 1
Posts: 2
Joined: Tue Mar 04, 2014 9:18 pm

Broadcom 4318 not working with LM 16 32 bit

Postby dasc1976 » Tue Mar 04, 2014 9:32 pm

I used Linux Mint 10 successfully for a few years, and decided to upgrade to 16 (Not sure if it was wise at this point). While I was able to get almost everything I wanted out of LM, I am no expert, in fact would be considered a noob by most. I have an Acer Travelmate 2480 with a Broadcom 4318 wireless adapter. I have tried everything on every suggestion board I can but still no wireless. here is my inxi -C:
System: Host: greg-TravelMate-2480 Kernel: 3.11.0-12-generic i686 (32 bit, gcc: 4.8.1)
Desktop: N/A Distro: Linux Mint 16 Petra
Machine: System: Acer product: TravelMate 2480
Mobo: Acer model: Prespa1 Bios: Acer version: v1.3502 date: 02/02/07
CPU: Single core Intel Celeron M CPU 430 (-UP-) cache: 1024 KB flags: (nx sse sse2 sse3) bmips: 3466.79 clocked at 1733.395 MHz
Graphics: Card: Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.14.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1280x800@59.9hz
GLX Renderer: Mesa DRI Intel 945GM x86/MMX/SSE2 GLX Version: 1.4 Mesa 9.2.1 Direct Rendering: Yes
Audio: Card: Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: k3.11.0-12-generic
Network: Card-1: Marvell 88E8038 PCI-E Fast Ethernet Controller driver: sky2 ver: 1.30 port: 2000 bus-ID: 02:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Card-2: Broadcom BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller driver: wl bus-ID: 0a:03.0
IF: N/A state: N/A mac: N/A
Drives: HDD Total Size: 320.1GB (1.4% used) 1: id: /dev/sda model: WDC_WD3200BPVT size: 320.1GB
Partition: ID: / size: 292G used: 4.1G (2%) fs: ext4 ID: /boot size: 236M used: 42M (19%) fs: ext2
ID: swap-1 size: 1.60GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: None detected - is lm-sensors installed and configured?
Info: Processes: 150 Uptime: 23 min Memory: 328.9/1499.9MB Runlevel: 2 Gcc sys: 4.8.1 Client: Shell inxi: 1.8.4
Here is my rfkill:
0: acer-wireless: Wireless LAN
Soft blocked: no
Hard blocked: no
I am completely lost and not sure why it is not working with no hard or soft block. Please help

Also, My computer now freezes upon restart or shut down. Not sure what to do.

Level 1
Level 1
Posts: 26
Joined: Tue Mar 04, 2014 7:45 pm

Re: Broadcom 4318 not working with LM 16 32 bit

Postby pettijohne » Tue Mar 04, 2014 11:00 pm

try this:
sudo apt-get install firmware-b43-installer

Level 1
Level 1
Posts: 1
Joined: Sun Mar 09, 2014 11:25 am

Re: Broadcom 4318 not working with LM 16 32 bit

Postby kazoo_LM » Sun Mar 09, 2014 12:03 pm

I do not profess to be a linux guru at all. But I had similar issues with the B43 drivers before and recalled in order to correct it, i had to remove the b43 from the blacklist. I recently installed LinuxMint 16 on an older Gateway laptop with the "Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01) pci card..(lspci)
I did use the software manager to install the b43-fwcutter and firmware-b43-installer and it still did not recognize the wireless adapter under network connections. I eventaully tried a few things, and found that removing the "b43" from the blacklist in "/etc/modprobe.d/blacklist-bcm43.conf" (simply comment the line out using "#" ). IF, this doesn't work, try to also comment out the "blacklist bcm43xx" in the "/etc/modprobe.d/blacklist.conf" ..After a reboot, my network connections identified my WI-FI SSID's, provided the passwords, and waalaa. Sweet!
good luck..

Level 1
Level 1
Posts: 2
Joined: Tue Mar 04, 2014 9:18 pm

Re: Broadcom 4318 not working with LM 16 32 bit

Postby dasc1976 » Mon Mar 17, 2014 6:27 pm

pettijohne, I did that a long time ago, and not working still.

kazoo, forgive the ignorance, I am still learning, what commands exactly do I need to enter? I do not quite speak linux yet.

Level 3
Level 3
Posts: 144
Joined: Wed Mar 14, 2012 10:08 am

Re: Broadcom 4318 not working with LM 16 32 bit

Postby Clawinus » Sat May 03, 2014 6:40 pm

Thanks Kazoo for your note. I had the same problem with LM 16 32 bit and am running Wifi now.
I commented out the "blacklist bcm43xx" in the "/etc/modprobe.d/blacklist.conf.

Previously I have used LM 15, 14 and 13. In each case I had to apply a different medicine to get Wifi working with BCM 4311.

Return to “Wireless”