Wireless N not connecting only b/g speeds - Intel 6205

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
phez
Level 1
Level 1
Posts: 11
Joined: Thu Jul 31, 2014 6:52 am

Wireless N not connecting only b/g speeds - Intel 6205

Post by phez » Sat Aug 02, 2014 9:48 pm

Hi Folks,

Seeking help with why my Lenovo X230 laptop with Intel 6205 Wireless BGN adapter is not connecting at Wireless N speeds with Linux Mint 17. When I had Win 7 x64 as the host O/S it would and would be able to achieve 7MB (megabytes) per second transfer speed through my LAN. Now I can see it connecting at 54Mbps maximum and get 2.5MB per second maximum. I dont believe it is the Wireless access point as the issue as all my other network details connect at N and operate correctly.

I have checked and the adapter seems to be using the correct drivers located at \lib\firmware\iwlwifi-6000g2a-6.ucode and they are the latest from Intel according to their website http://www.intel.com/support/wireless/w ... 034398.htm

I am now at a loss. Can anyone advise have they got Wireless N working on Mint 17? If so, what was required?
Thanks
phez

*-network
description: Wireless interface
product: Centrino Advanced-N 6205 [Taylor Peak]
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 34
serial: 60:67:20:b7:16:d8
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=3.13.0-24-generic firmware=18.168.6.1 ip=192.168.100.21 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
resources: irq:47 memory:f1c00000-f1c01fff

Wifi Network details:
wlan0 Scan completed :
Cell 01 - Address: 06:27:22:15:EA:1C
Channel:7
Frequency:2.442 GHz (Channel 7)
Quality=70/70 Signal level=-40 dBm
Encryption key:on
ESSID:"XXX"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s
Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=0000000a3a7c1031
Extra: Last beacon: 84ms ago
IE: Unknown: 0003476F64
IE: Unknown: 010882848B960C121824
IE: Unknown: 030107
IE: Unknown: 2A0100
IE: Unknown: 2F0100
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK

User avatar
PatH57
Level 13
Level 13
Posts: 4583
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by PatH57 » Sun Aug 03, 2014 4:35 am

Hi,


since you are using kernel 3.13.0.24 the correct driver should be there (have to check if newer kernels have some more patches for it)

in the meantime try this

Code: Select all

sudo rmmod iwlwifi

Code: Select all

sudo modprobe iwlwifi 11n_disable=1
and see if it improves speed (if not just reboot and the changes are gone)
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

User avatar
eanfrid
Level 7
Level 7
Posts: 1861
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by eanfrid » Sun Aug 03, 2014 5:05 am

Wifi "N" connections need WPA2, with the AES/CCMP protocol (or no encryption at all :roll: ). Since you chose to connect with TKIP, you cannot use higher modes than "G".
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

User avatar
PatH57
Level 13
Level 13
Posts: 4583
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by PatH57 » Sun Aug 03, 2014 5:09 am

nice catch didn't notice it.
Thanks
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

phez
Level 1
Level 1
Posts: 11
Joined: Thu Jul 31, 2014 6:52 am

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by phez » Sun Aug 03, 2014 5:43 am

PatH57 wrote:Hi,


since you are using kernel 3.13.0.24 the correct driver should be there (have to check if newer kernels have some more patches for it)

in the meantime try this

Code: Select all

sudo rmmod iwlwifi

Code: Select all

sudo modprobe iwlwifi 11n_disable=1
and see if it improves speed (if not just reboot and the changes are gone)
Thank you, but it results in an error.
rmmod: ERROR: Module iwlwifi is in use by: iwldvm

User avatar
PatH57
Level 13
Level 13
Posts: 4583
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by PatH57 » Sun Aug 03, 2014 5:50 am

well the wpa2 is not really the problem then as you can't even get 54MB/s

try this they have directly used the intel driver instead of the one from the kernel (they should be the same but who knows.)
http://unix.stackexchange.com/questions ... tel-n-6235
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

phez
Level 1
Level 1
Posts: 11
Joined: Thu Jul 31, 2014 6:52 am

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by phez » Sun Aug 03, 2014 7:43 am

PatH57 wrote:well the wpa2 is not really the problem then as you can't even get 54MB/s

try this they have directly used the intel driver instead of the one from the kernel (they should be the same but who knows.)
http://unix.stackexchange.com/questions ... tel-n-6235
Thanks, I already tried that solution. No difference. I am trying to understand the comment about "Since you chose to connect with TKIP, you cannot use higher modes than "G".". I thought TKIP was set on the wireless AP, if so, how come under Win7 I could connect at 144Mbps yet on Mint it is 54Mbps? Is there a configuration I am missing?

User avatar
PatH57
Level 13
Level 13
Posts: 4583
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by PatH57 » Sun Aug 03, 2014 7:50 am

Really no idea according to netgear and other router manufacturers:
Overview:

The IEEE 802.11n wireless standard promises very high connection speeds for wireless networking. NETGEAR's "N" wireless routers and access points fully comply with the 802.11n standard, but they are also backward-compatible with earlier wireless networking standards, to ensure that you can still get connected with your legacy wireless devices.

In keeping with the need for backward-compatibility, NETGEAR "N" devices support a range of wireless security standards : WEP, WPA and WPA2. However, there is a catch ; the 802.11n standard only allows 2 security options :

No security at all (usually a bad idea, unless you have chosen to create a free public wifi hotspot).
WPA2

If you use one of the other security options, you will not be able to connect wirelessly at 802.11n speeds. You will be limited to the 802.11g speed of 54Mbps.

Therefore, NETGEAR recommends using WPA2 if possible.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

User avatar
eanfrid
Level 7
Level 7
Posts: 1861
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by eanfrid » Sun Aug 03, 2014 8:23 am

Set your router to mode "N only", forcing then all clients to use WPA2 (or no encryption as recalled by Netgear). As long as the AP accepts weaker security/encryption protocols, the wifi clients will connect using the easiest or the quickest way they can. Thus rarely in the most secure mode unless they are forced to do so.
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

phez
Level 1
Level 1
Posts: 11
Joined: Thu Jul 31, 2014 6:52 am

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by phez » Sun Aug 03, 2014 9:48 am

I just installed Back Track 5 via LiveCD and it connects at Wireless N 300Mbps. I have been able to transfer at 4.5MB (Megabytes) per second. I have not changed anything on the Wireless AP nor the PC. This indicates to me there is a software issue. I have noticed the driver version is different in this distro

description: Wireless interface
product: Centrino Advanced-N 6205
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wlan0
version: 34
serial: 60:67:20:b7:16:d8
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=3.2.6 firmware=17.168.5.3 build 42301 ip=192.168.100.21 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
resources: irq:46 memory:f1c00000-f1c01fff

Output of iwconfig
wlan0 IEEE 802.11abgn ESSID:"XXX"
Mode:Managed Frequency:2.442 GHz Access Point: 06:27:22:15:EA:1C
Bit Rate=216 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=55/70 Signal level=-55 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:146408 Invalid misc:89 Missed beacon:0


Is it a simple case of changing drivers to the older version?

User avatar
eanfrid
Level 7
Level 7
Posts: 1861
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by eanfrid » Sun Aug 03, 2014 10:00 am

In your Backtrack config, you actually do not use any encryption, so you get max speed. Also, is this Backtrack or Kali ? Kali uses the 3.14 kernel and LM17 uses 3.13. Maybe there is a difference in hardware support for your wifi chipset.
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

User avatar
PatH57
Level 13
Level 13
Posts: 4583
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by PatH57 » Sun Aug 03, 2014 10:02 am

3.2 kernel and no encryption?
I use kali and wpa2 but don't get this kind of speed.....
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

User avatar
eanfrid
Level 7
Level 7
Posts: 1861
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by eanfrid » Sun Aug 03, 2014 10:09 am

Okay if Backtrack 5 uses the older 3.2 kernel, the difference is only due to using unencrypted connections.
eanfrid wrote:As long as the AP accepts weaker security/encryption protocols, the wifi clients will connect using the easiest
Obviously, "nothing" is the easiest :D
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

User avatar
PatH57
Level 13
Level 13
Posts: 4583
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by PatH57 » Sun Aug 03, 2014 10:25 am

you wouldn't have some kind of "hotspot" enabled on your router?
try with backtrack to access a web page... hope it won't let you else you neighbors must be real happy :wink:
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

phez
Level 1
Level 1
Posts: 11
Joined: Thu Jul 31, 2014 6:52 am

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by phez » Sun Aug 03, 2014 10:39 am

eanfrid wrote:In your Backtrack config, you actually do not use any encryption, so you get max speed. Also, is this Backtrack or Kali ? Kali uses the 3.14 kernel and LM17 uses 3.13. Maybe there is a difference in hardware support for your wifi chipset.
Backtrack 5R3. So how can I prove that encryption is causing the slowdown in Mint? Can I disable it somewhere?

User avatar
PatH57
Level 13
Level 13
Posts: 4583
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by PatH57 » Sun Aug 03, 2014 10:46 am

you better go and check your router.
do you have the brand and type of the router?
and again under BT try to access the internet ?, if you can your network is a swiss cheese concerning security.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

phez
Level 1
Level 1
Posts: 11
Joined: Thu Jul 31, 2014 6:52 am

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by phez » Sun Aug 03, 2014 10:59 am

PatH57 wrote:you better go and check your router.
do you have the brand and type of the router?
and again under BT try to access the internet ?, if you can your network is a swiss cheese concerning security.
While I thank you for trying to help me, the Wireless AP is not the issue whatsoever !
Lenovo X230 Laptop + Win 7 + Wireless AP = 300Mbs
Lenovo X230 Laptop + Backtrack + Wireless AP = 300Mbps
Lenovo X230 Laptop + Mint 17 + Wireless AP = 54Mbps

Why would I change my Wireless AP? Maybe there between driver v18 vs v17 in the way it handles encryption? How can I downgrade from V18 to V17 as I deleted the driver and it still didnt use V17

phez
Level 1
Level 1
Posts: 11
Joined: Thu Jul 31, 2014 6:52 am

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by phez » Sun Aug 03, 2014 11:14 am

OK, I can see I am now using v17 firmware, but it is still not helping. Seems I need to downgrade driver from " iwlwifi driverversion=3.13.0-24-generic" to " iwlwifi driverversion=3.2.6" ... any guides on this?

User avatar
eanfrid
Level 7
Level 7
Posts: 1861
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by eanfrid » Sun Aug 03, 2014 11:29 am

phez wrote:So how can I prove that encryption is causing the slowdown in Mint? Can I disable it somewhere?
Encryption always causes at least some computing overhead. And believe me, you want encryption, otherwise your connection traffic is clear text and can be hacked in a snap.
phez wrote:While I thank you for trying to help me, the Wireless AP is not the issue whatsoever !
Indeed, it is. Its current settings are insecure, since you can connect in unencrypted mode without warning. While this can be intended if you run a public hotspot, it is a serious flaw if you can do this on your own private network which then is not private at all.
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

User avatar
eanfrid
Level 7
Level 7
Posts: 1861
Joined: Mon Apr 30, 2012 2:49 am
Location: FR

Re: Wireless N not connecting only b/g speeds - Intel 6205

Post by eanfrid » Wed Aug 06, 2014 7:50 am

Check here: http://forums.linuxmint.com/viewtopic.php?f=53&t=175048
There is indeed a regression in the 3.13 kernel (used by LM17). As a workaround, reverting to 3.12 solves the problem, so maybe it will work for you too.
Main desktop: Debian GNU/Linux Jessie 64bit - MATE
(i5 2400@3.7GHz - 16GB DDR3 - HD6770 w/radeon driver - SSD+RAID1)
Safer than Dropbox

Post Reply

Return to “Wireless”