Wifi issues

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
number
Level 1
Level 1
Posts: 4
Joined: Sun Aug 17, 2014 2:59 pm

Wifi issues

Post by number »

Hello!

First of all, english is not my main language, I am from Germany. Therefore I could not find anything helpful with the forum search function.

Normally I am using Windows 7 (because I am a gamer). But now I have switched to Linux Mint 17 "Qiana" MATE. (mate instead of cinnamon, because cinnamon uses too many system recources).
When I used Windows 7, I had Wifi connection aborts sometimes. But it was ok. I have tried anything, but I think the problem is the router. There is one thing I can say: The problem is not the distance from my "FRITZ! Wlan Stick N" -to the router. And there are not many walls or furniture between them. I swear this is not the problem.
But now on Mint, I have more connection aborts and the connection is generally weaker and slower. I do not know why. I have googled a bit, and maybe the wrong Driver for my Stick is installed?
I do not just hope that anyone will help me here, I also continue googling.

Any suggestions?

ClutchDisc
Level 5
Level 5
Posts: 633
Joined: Wed Mar 26, 2014 12:31 pm
Location: Detroit area

Re: Wifi issues

Post by ClutchDisc »

Did you try looking in the driver manager for any drivers? Menu > Control Center > Driver Manager.
Custom build
OS: Linux Mint 18.1 Cinnamon
CPU: Intel Core i5 2.70GHz quad core
RAM: 8GB DDR4
OS drive: 120GB SSD
Data drive: 2TB HDD

grumpus
Level 1
Level 1
Posts: 15
Joined: Sun Apr 21, 2013 11:26 am
Location: Third Stone from the Sun

Re: Wifi issues

Post by grumpus »

Having a similar problem with Mint 17 64bit and Ubuntu 12.4.5 it could be the supplied USB wireless driver timing out.
There may also be a conflict with your previous installed driver (look under /etc/Wireless to see if it is listed there)\
I had to remove the driver for my system as the supplied kernel level driver took over the system, I do not know if you would have to do this.

Been trying to resolve the issue and some of the following may help:
run iwconfig and see if power management is on. Found this contributes to the instability.
use the call for your wlan or ra0 or whatever the device is called and insert it where I have wlan0 in the following line

In a terminal try to turn the power management off with "sudo iwconfig wlan0 power off"
Follow this with "iwconfig" and see if it states the power management is off.
This helped me with both LinuxMint 17 Mate 64bit and with Ubuntu12.04.5 (after HWE updates bolexed the wireless)
There's more you can do to make it permanent if you wish:

This from the Ubuntu Forum:
Then, to disable the power management permanently on "wlan0", try the elegant method first
Code:
sudo touch /etc/pm/power.d/wireless

This will create a blank file named "wireless" in /etc/pm/power.d, which disables the default power management script located in /usr/lib/pm-utils/power.d directory. Then turn the PM off using the "sudo iwconfig wlan0 power off" command like before > reboot > check if it is still off. If it is, nothing else is required.

But if not, try making the "wireless" file we just created executable, putting the command in it -
Code:
echo "/sbin/iwconfig wlan0 power off" | sudo tee /etc/pm/power.d/wireless
sudo chmod +x /etc/pm/power.d/wireless

Then turn PM off with iwconfig command > reboot to make sure it remains off.
The "elegant" solution made the file but did not turn off the power management for my system the second set of instructions fixed the power management to a default state of "off".
Uhhh, maybe this will work?

Post Reply

Return to “Wireless”