Wifi not connecting at my college? (Linux Qiana) [CLOSED]

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Wifi not connecting at my college? (Linux Qiana) [CLOSED]

Post by devanand » Thu Sep 25, 2014 9:04 am

I have brought my laptop to my college campus recently. But I cannot connect to their wifi. In hostels it used to work. Dont know if it works from now? :(
Can someone help me. :(
Also lan is not working. But thats a different topic OK. So here goes output of mintwifi.py

devanand@BUSY-BOX /usr/lib/linuxmint/mintWifi $ sudo python mintWifi.py
-------------------------
* I. scanning WIFI PCI devices...
-- Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
==> PCI ID = 168c:002b (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"IMSc-WiFi"
Mode:Managed Frequency:2.437 GHz Access Point: 08:5B:0E:65:8E:B6
Bit Rate=39 Mb/s Tx-Power=15 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=41/70 Signal level=-69 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:3 Missed beacon:0

-------------------------
* IV. querying ifconfig...
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:197718 errors:0 dropped:0 overruns:0 frame:0
TX packets:197718 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:126624452 (126.6 MB) TX bytes:126624452 (126.6 MB)

wlan0 Link encap:Ethernet HWaddr 00:16:44:65:ed:5e
inet addr:10.96.95.18 Bcast:10.96.95.255 Mask:255.255.254.0
inet6 addr: fe80::216:44ff:fe65:ed5e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:734989 errors:0 dropped:1 overruns:0 frame:0
TX packets:3793 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:88521607 (88.5 MB) TX bytes:526177 (526.1 KB)

-------------------------
* V. querying DHCP...
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 10.96.65.71
Address: 10.96.65.71#53

Non-authoritative answer:
Name: google.com
Address: 173.194.36.1
Name: google.com
Address: 173.194.36.2
Name: google.com
Address: 173.194.36.3
Name: google.com
Address: 173.194.36.4
Name: google.com
Address: 173.194.36.5
Name: google.com
Address: 173.194.36.6
Name: google.com
Address: 173.194.36.7
Name: google.com
Address: 173.194.36.8
Name: google.com
Address: 173.194.36.9
Name: google.com
Address: 173.194.36.14
Name: google.com
Address: 173.194.36.0
Last edited by devanand on Wed Oct 01, 2014 10:52 pm, edited 1 time in total.

JeremyB
Level 20
Level 20
Posts: 10146
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by JeremyB » Thu Sep 25, 2014 11:50 am

I would try Linux Mint 13 Live DVD/USB and see if it will connect as Linux Mint 17/Ubuntu 14.04 are having issues dealing with WPA2 Enterprise wifi setups that either have no CA or a self signed CA

Watch this post to see if a solution is found
http://ubuntuforums.org/showthread.php?t=2245561

User avatar
txba516
Level 3
Level 3
Posts: 197
Joined: Fri Aug 10, 2007 11:57 am
Location: Atlanta, GA

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by txba516 » Thu Sep 25, 2014 12:15 pm

All of the info posted seems to indicate that you are connected to the WiFi network. Can you be more specific about what's not working? Since it's a college campus, there is a high likelihood that they have either a NAC (network access control) system in place or an authenticated proxy that you must provide credentials to for web browsing access. Have you checked another user's setup or asked the IT Support group at the school if there are certain steps or requirements for WiFi access?

Cheers!
LM17.2 x64 Cinnamon
Help the forums get answers faster! Mark your fixed problem thread as [SOLVED]

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Fri Sep 26, 2014 1:55 pm

OK, sorry for the late reply. But I used to connect the wifi in institute with my previous version julia and Windows7. (An authorization page comes certainly. But now even I can't view that page so that I can login). Once in between the authorization page poped up , but was not able to connect. Now I don't have windows installed in my laptop. :cry:

JeremyB
Level 20
Level 20
Posts: 10146
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by JeremyB » Fri Sep 26, 2014 4:49 pm

It looks like varun found a solution for that post but lets see how similar it is to your issue. With an internet connection

Code: Select all

wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script
in terminal and after attempting to connect at college

Code: Select all

./wireless_script

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Sat Sep 27, 2014 2:09 am

I have downloaded the script, will run it at the institute and reply.

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Sat Sep 27, 2014 8:21 am

OK here goes the script output:
--------------------------------------


########## wireless info START ##########

Report from: 27 Sep 2014 17:45 IST +0530

Booted last: 27 Sep 2014 00:15 IST +0530

Script from: 20 Sep 2014 23:04 UTC +0000

##### release ###########################

Distributor ID: LinuxMint
Description: Linux Mint 17 Qiana
Release: 17
Codename: qiana

##### kernel ############################

Linux 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

default

##### lspci #############################

02:00.0 Ethernet controller [0200]: Qualcomm Atheros AR8152 v1.1 Fast Ethernet [1969:2060] (rev c1)
Subsystem: Toshiba America Info Systems Device [1179:ff1e]
Kernel driver in use: atl1c

03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
Subsystem: Lite-On Communications Inc Device [11ad:6611]
Kernel driver in use: ath9k

##### lsusb #############################

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 10f1:1a2a Importek Laptop Integrated Webcam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

##### lsmod #############################

ath9k 164164 0
ath9k_common 13551 1 ath9k
ath9k_hw 453856 2 ath9k_common,ath9k
ath 28698 3 ath9k_common,ath9k,ath9k_hw
mac80211 626489 1 ath9k
cfg80211 484040 3 ath,ath9k,mac80211
wmi 19177 1 toshiba_acpi

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

eth0 Link encap:Ethernet HWaddr <MAC 'eth0' [IF]>
inet6 addr: fe80::226:6cff:fe56:9209/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3678 errors:0 dropped:0 overruns:0 frame:0
TX packets:7009 errors:0 dropped:0 overruns:0 carrier:3
collisions:0 txqueuelen:1000
RX bytes:1003380 (1.0 MB) TX bytes:1328290 (1.3 MB)

wlan0 Link encap:Ethernet HWaddr <MAC 'wlan0' [IF]>
inet addr:10.96.95.18 Bcast:10.96.95.255 Mask:255.255.254.0
inet6 addr: fe80::216:44ff:fe65:ed5e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:181614 errors:0 dropped:0 overruns:0 frame:0
TX packets:153849 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:176774575 (176.7 MB) TX bytes:22121246 (22.1 MB)

##### iwconfig ##########################

eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"IMSc-WiFi"
Mode:Managed Frequency:2.412 GHz Access Point: <MAC 'IMSc-WiFi' [AN9]>
Bit Rate=65 Mb/s Tx-Power=14 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=62/70 Signal level=-48 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:44 Missed beacon:0

##### route #############################

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
0.0.0.0 10.96.95.254 0.0.0.0 UG 0 0 0 wlan0
10.96.94.0 0.0.0.0 255.255.254.0 U 9 0 0 wlan0

##### resolv.conf #######################

nameserver 127.0.1.1
search imsc.res.in

##### nm-tool ###########################

NetworkManager Tool

State: connected (global)

- Device: wlan0 [Auto IMSc-WiFi] ----------------------------------------------
Type: 802.11 WiFi
Driver: ath9k
State: connected
Default: yes
HW Address: <MAC 'wlan0' [IF]>

Capabilities:
Speed: 65 Mb/s

Wireless Properties
WEP Encryption: yes
WPA Encryption: yes
WPA2 Encryption: yes

Wireless Access Points (* = current AP)
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN1]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 45
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN2]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 42
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN3]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 30
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN4]>, Freq 2437 MHz, Rate 54 Mb/s, Strength 29
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN5]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 25
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN6]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 22
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN7]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 19
IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN8]>, Freq 2462 MHz, Rate 54 Mb/s, Strength 19
*IMSc-WiFi: Infra, <MAC 'IMSc-WiFi' [AN9]>, Freq 2412 MHz, Rate 54 Mb/s, Strength 72

IPv4 Settings:
Address: 10.96.95.18
Prefix: 23 (255.255.254.0)
Gateway: 10.96.95.254

DNS: 10.96.65.71

- Device: eth0 [Auto Ethernet] ------------------------------------------------
Type: Wired
Driver: atl1c
State: connecting (getting IP configuration)
Default: no
HW Address: <MAC 'eth0' [IF]>

Capabilities:
Carrier Detect: yes
Speed: 10 Mb/s

Wired Properties
Carrier: on

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=false
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

no-auto-default=<MAC 'eth0' [IF]>,

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/Auto IMSc-Adyar]] (600 root)
[connection] id=Auto IMSc-Adyar | type=802-11-wireless
[802-11-wireless] ssid=IMSc-Adyar | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Auto IMSc-WiFi]] (600 root)
[connection] id=Auto IMSc-WiFi | type=802-11-wireless
[802-11-wireless] ssid=IMSc-WiFi | mac-address=<MAC 'wlan0' [IF]>
[ipv6] method=auto
[ipv4] method=auto

[[/etc/NetworkManager/system-connections/Auto IMSc-Adyar2]] (600 root)
[connection] id=Auto IMSc-Adyar2 | type=802-11-wireless
[802-11-wireless] ssid=IMSc-Adyar2 | mac-address=<MAC 'wlan0' [IF]>
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

Region: Asia/Kolkata (based on set time zone)

country SG:
(2402 - 2482 @ 40), (N/A, 20)
(5170 - 5250 @ 40), (N/A, 20)
(5250 - 5330 @ 40), (N/A, 20), DFS
(5735 - 5835 @ 40), (N/A, 20)

##### iwlist channels ###################

eth0 no frequency information.

lo no frequency information.

wlan0 13 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Channel 12 : 2.467 GHz
Channel 13 : 2.472 GHz
Current Frequency:2.412 GHz (Channel 1)

##### iwlist scan #######################

eth0 Interface doesn't support scanning.

lo Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Device or resource busy

##### module infos ######################

[ath9k]
filename: /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k.ko
license: Dual BSD/GPL
description: Support for Atheros 802.11n wireless LAN cards.
author: Atheros Communications
srcversion: BAF225EEB618908380B28DA
depends: ath9k_hw,mac80211,ath9k_common,cfg80211,ath
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo: sha512
parm: debug:Debugging mask (uint)
parm: nohwcrypt:Disable hardware encryption (int)
parm: blink:Enable LED blink on activity (int)
parm: btcoex_enable:Enable wifi-BT coexistence (int)
parm: bt_ant_diversity:Enable WLAN/BT RX antenna diversity (int)
parm: ps_enable:Enable WLAN PowerSave (int)

[ath9k_common]
filename: /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_common.ko
license: Dual BSD/GPL
description: Shared library for Atheros wireless 802.11n LAN cards.
author: Atheros Communications
srcversion: 696B00A6C59713EC0966997
depends: ath,ath9k_hw
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo: sha512

[ath9k_hw]
filename: /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ath/ath9k/ath9k_hw.ko
license: Dual BSD/GPL
description: Support for Atheros 802.11n wireless LAN cards.
author: Atheros Communications
srcversion: 4809F3842A0542CD6B556D3
depends: ath
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo: sha512

[ath]
filename: /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/ath/ath.ko
license: Dual BSD/GPL
description: Shared library for Atheros wireless LAN cards.
author: Atheros Communications
srcversion: 88A67C5359B02C5A710AFCF
depends: cfg80211
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo: sha512

[mac80211]
filename: /lib/modules/3.13.0-24-generic/kernel/net/mac80211/mac80211.ko
license: GPL
description: IEEE 802.11 subsystem
srcversion: C0F95BBF832E05DEFD722F4
depends: cfg80211
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo: sha512
parm: max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm: max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm: beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm: probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm: ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename: /lib/modules/3.13.0-24-generic/kernel/net/wireless/cfg80211.ko
description: wireless configuration support
license: GPL
author: Johannes Berg
srcversion: 8B3D642D1F2E6406EF33F74
depends:
intree: Y
vermagic: 3.13.0-24-generic SMP mod_unload modversions
signer: Magrathea: Glacier signing key
sig_key: 00:A5:A6:57:59:DE:47:4B:C5:C4:31:20:88:0C:1B:94:A5:39:F4:31
sig_hashalgo: sha512
parm: ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm: cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[ath9k]
blink: 0
bt_ant_diversity: 0
btcoex_enable: 0
nohwcrypt: 0
ps_enable: 0

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
probe_wait_ms: 500

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp
rtc

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x1969:0x2060 (atl1c)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'eth0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x168c:0x002b (ath9k)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'wlan0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #############################

[58587.340214] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[58588.228579] wlan0: authenticate with <MAC 'IMSc-WiFi' [AN9]>
[58588.251268] wlan0: send auth to <MAC 'IMSc-WiFi' [AN9]> (try 1/3)
[58588.253661] wlan0: authenticated
[58588.256169] wlan0: associate with <MAC 'IMSc-WiFi' [AN9]> (try 1/3)
[58588.261195] wlan0: RX AssocResp from <MAC 'IMSc-WiFi' [AN9]> (capab=0x421 status=0 aid=3)
[58588.261250] wlan0: associated
[58588.261282] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[58588.265687] ath: EEPROM regdomain: 0x82be
[58588.265691] ath: EEPROM indicates we should expect a country code
[58588.265693] ath: doing EEPROM country->regdmn map search
[58588.265694] ath: country maps to regdmn code: 0x5b
[58588.265696] ath: Country alpha2 being used: SG
[58588.265698] ath: Regpair used: 0x5b
[58588.265700] ath: regdomain 0x82be dynamically updated by country IE
[58588.267449] wlan0: deauthenticating from <MAC 'IMSc-WiFi' [AN9]> by local choice (reason=2)
[58588.277610] wlan0: authenticate with <MAC 'IMSc-WiFi' [AN9]>
[58588.296312] wlan0: send auth to <MAC 'IMSc-WiFi' [AN9]> (try 1/3)
[58588.302512] wlan0: authenticated
[58588.304077] wlan0: associate with <MAC 'IMSc-WiFi' [AN9]> (try 1/3)
[58588.310680] wlan0: RX AssocResp from <MAC 'IMSc-WiFi' [AN9]> (capab=0x421 status=0 aid=3)
[58588.310732] wlan0: associated
[58588.314385] ath: EEPROM regdomain: 0x82be
[58588.314389] ath: EEPROM indicates we should expect a country code
[58588.314391] ath: doing EEPROM country->regdmn map search
[58588.314393] ath: country maps to regdmn code: 0x5b
[58588.314395] ath: Country alpha2 being used: SG
[58588.314396] ath: Regpair used: 0x5b
[58588.314398] ath: regdomain 0x82be dynamically updated by country IE
[58598.315303] wlan0: deauthenticating from <MAC 'IMSc-WiFi' [AN9]> by local choice (reason=3)
[58610.317045] wlan0: authenticate with <MAC 'IMSc-WiFi' [AN9]>
[58610.338642] wlan0: send auth to <MAC 'IMSc-WiFi' [AN9]> (try 1/3)
[58610.341023] wlan0: authenticated
[58610.344061] wlan0: associate with <MAC 'IMSc-WiFi' [AN9]> (try 1/3)
[58610.349136] wlan0: RX AssocResp from <MAC 'IMSc-WiFi' [AN9]> (capab=0x421 status=0 aid=3)
[58610.349214] wlan0: associated
[58610.356000] ath: EEPROM regdomain: 0x82be
[58610.356037] ath: EEPROM indicates we should expect a country code
[58610.356041] ath: doing EEPROM country->regdmn map search
[58610.356045] ath: country maps to regdmn code: 0x5b
[58610.356048] ath: Country alpha2 being used: SG
[58610.356050] ath: Regpair used: 0x5b
[58610.356054] ath: regdomain 0x82be dynamically updated by country IE

########## wireless info END ############

JeremyB
Level 20
Level 20
Posts: 10146
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by JeremyB » Sat Sep 27, 2014 8:50 am

From the script, it appears to be working. Are you in/near Singapore? If you are having issues there are a couple more things that might work but I expected to see wifi with WPA2-Enterprise encryption and that isn't what is shown from the script

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Sat Sep 27, 2014 12:37 pm

I am from India. Now staying at Chennai. The institute is IMSc. :|

JeremyB
Level 20
Level 20
Posts: 10146
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by JeremyB » Sat Sep 27, 2014 12:58 pm

devanand wrote:I am from India. Now staying at Chennai. The institute is IMSc. :|
Strange that the

Code: Select all

iw reg get
command returned SG, so we will correct that

Code: Select all

sudo iw reg set IN
And we will set it in one more file

Code: Select all

sudo gedit /etc/default/crda
The last line in this file will show REGDOMAIN=?? and I am not sure what is in the place of ?? as it should be your country code but a lot of times it is 00

Make this be

Code: Select all

REGDOMAIN=IN
save and close gedit, reboot and see if things have improved

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Sat Sep 27, 2014 2:04 pm

Thanks for your effort, but unfortunately this is not working and SG thing is getting overwriting in "iw reg get " command. I saved the "crda" file to IN. reboot...... but nothing working

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Mon Sep 29, 2014 10:50 am

I tried with a ubuntu live pen drive. Even that can't access Internet. :( So I am in trouble. I have installed computational softwares and my coding assignments are going on, so I cannot even reinstall my OS now.

JeremyB
Level 20
Level 20
Posts: 10146
Joined: Fri Feb 21, 2014 8:17 am

Re: Re: Wifi not connecting at my college? (Linux Qiana Cinn

Post by JeremyB » Mon Sep 29, 2014 11:06 am

devanand wrote:I tried with a ubuntu live pen drive. Even that can't access Internet. :( So I am in trouble. I have installed computational softwares and my coding assignments are going on, so I cannot even reinstall my OS now.
I don't know why you can't access the internet but it looked to be connected to wifi. In terminal

Code: Select all

ping google.com
let it display a few lines and then CTRL+c to stop it and do the same for ping 8.8.8.8

If you can ping 8.8.8.8 but not google you may have to change connection settings in network manager to add DNS 8.8.8.8

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by PatH57 » Mon Sep 29, 2014 11:16 am

usually such connection use a proxy for internet.

Code: Select all

ping google.com
if this works you may need to know what's the proxy setting, ask the IT department of your college.
here is a quick tip
http://www.imsc.res.in/IMScWiki/Categor ... ckStartWeb
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Mon Sep 29, 2014 11:53 am

ping 8.8.8.8 did'nt worked. Even the admins here are confused.

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by PatH57 » Mon Sep 29, 2014 12:27 pm

admins are often quickly confused but their site says they use a proxy, so what kind of settings do they give users when they connect (windows or other)?
once we know this we can setup yours.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

devanand
Level 1
Level 1
Posts: 9
Joined: Thu Sep 25, 2014 8:59 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by devanand » Tue Sep 30, 2014 9:25 am

Sorry guys for the trouble. My mac address was blocked for some reason. I am sorry and I was not knowing this. Only just now the senior admins checked for blocked mac addresses.

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by PatH57 » Tue Sep 30, 2014 10:09 am

:lol: too many attempts and not the right settings? the "normal" script blocks it. Good to know they have enforced rules and don't just let anyone access the wifi.
Talking to people has always seem to me being the best way to resolve problems.
Don't forget to mark it as closed please.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

JeremyB
Level 20
Level 20
Posts: 10146
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not connecting at my college? (Linux Qiana Cinnamon

Post by JeremyB » Tue Sep 30, 2014 6:24 pm

I guess you could edit the topic from your original post to add [SOLVED]

These things happen from time to time

Post Reply

Return to “Wireless”