blinking wifi - difficulty to connect

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
qiumera
Level 1
Level 1
Posts: 7
Joined: Mon Sep 29, 2014 10:19 am

blinking wifi - difficulty to connect

Post by qiumera » Mon Sep 29, 2014 10:38 am

Hi Everybody!

3 days ago I changed my old debian 6 to Linux Mint 17 with xcfe. First of all I like it, but it gives me a hard time with the internet. I was researching about it, but I could not find solutions, so here I am, asking for help...

Code: Select all

 I. scanning WIFI PCI devices...
  -- Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
      ==> PCI ID = 14e4:4311 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
wlan0     IEEE 802.11bg  ESSID:"daniel23"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: BC:96:81:34:87:39   
          Bit Rate=48 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=69/70  Signal level=-41 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:7  Invalid misc:558   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 00:1c:23:b5:17:ee  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:157 errors:0 dropped:0 overruns:0 frame:0
          TX packets:157 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11167 (11.1 KB)  TX bytes:11167 (11.1 KB)

wlan0     Link encap:Ethernet  HWaddr 00:1d:d9:5f:ca:cd  
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:d9ff:fe5f:cacd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3834 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3640 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2854292 (2.8 MB)  TX bytes:614847 (614.8 KB)
Although I am not a newbie to linux, I neither spend too much time on looking after the system - if it runs, great, if not - time to care. What I realized is that wlan0 is recognized as Ethernet - is it normal?? As well, it says, wifi is unavalaible (I am on its wifi right now)
the same shows up in the network manager.
It takes some time to connect. When booting, the wifi led is on, then it switches off, so I have to manually switch it on again to connect to the network, however when connecting it starts to blink, and either it catches the wifi or not regardless of the strenght of the signal, it just does not want to connect.
Once it is connected, it is stable. I have no problem with the wired connection.
I am using a DELL Inspiron 6400.
03:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
0b:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)

Code: Select all

nm-tool

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            b44
  State:             unavailable
  Default:           no
  HW Address:        00:1C:23:B5:17:EE

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            b43
  State:             unavailable
  Default:           no
  HW Address:        00:1D:D9:5F:CA:CD

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 
Thank you for your in advance!

Qiumera

JeremyB
Level 19
Level 19
Posts: 9459
Joined: Fri Feb 21, 2014 8:17 am

Re: blinking wifi - difficulty to connect

Post by JeremyB » Mon Sep 29, 2014 11:11 am

Please run the following in a new terminal window and paste the contents of the wireless-info.txt or attach the wireless-info tar.gz file

Code: Select all

 wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script

qiumera
Level 1
Level 1
Posts: 7
Joined: Mon Sep 29, 2014 10:19 am

Re: blinking wifi - difficulty to connect

Post by qiumera » Mon Sep 29, 2014 11:30 am

Hi there!

Thank you for getting back to me so fast. Here is the outcome:

Code: Select all

########## wireless info START ##########

Report from: 29 Sep 2014 23:23 MYT +0800

Booted last: 29 Sep 2014 21:52 MYT +0800

Script from: 20 Sep 2014 23:04 UTC +0000

##### release ###########################

Distributor ID:	LinuxMint
Description:	Linux Mint 17 Qiana
Release:	17
Codename:	qiana

##### kernel ############################

Linux 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686 i686 i686 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

default

##### lspci #############################

03:00.0 Ethernet controller [0200]: Broadcom Corporation BCM4401-B0 100Base-TX [14e4:170c] (rev 02)
	Subsystem: Dell Inspiron 6400 [1028:01af]
	Kernel driver in use: b44

0b:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
	Subsystem: Dell Wireless 1390 WLAN Mini-Card [1028:0007]
	Kernel driver in use: b43-pci-bridge

##### lsusb #############################

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 005: ID 0a5c:4503 Broadcom Corp. Mouse (Boot Interface Subclass)
Bus 005 Device 004: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 005 Device 003: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
Bus 005 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

##### lsmod #############################

dell_wmi               12665  0 
sparse_keymap          13708  1 dell_wmi
dell_laptop            17808  0 
dcdbas                 14448  1 dell_laptop
ssb_hcd                12749  0 
b43                   356470  0 
bcma                   42043  1 b43
mac80211              545990  1 b43
cfg80211              409394  2 b43,mac80211
ssb                    51854  3 b43,b44,ssb_hcd
wmi                    18673  1 dell_wmi

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

eth0      Link encap:Ethernet  HWaddr <MAC 'eth0' [IF]>  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:63 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7150 (7.1 KB)  TX bytes:11533 (11.5 KB)
          Interrupt:17 

wlan0     Link encap:Ethernet  HWaddr <MAC 'wlan0' [IF]>  
          inet addr:192.168.0.10  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::21d:d9ff:fe5f:cacd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11496 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10627 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8941938 (8.9 MB)  TX bytes:1996670 (1.9 MB)

##### iwconfig ##########################

lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"daniel23"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: <MAC 'daniel23' [AC1]>   
          Bit Rate=54 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-39 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:26  Invalid misc:598   Missed beacon:0

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    0      0        0 wlan0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0

##### resolv.conf #######################

nameserver 192.168.0.1
search WirelessAP

##### nm-tool ###########################

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            b44
  State:             unavailable
  Default:           no
  HW Address:        <MAC 'eth0' [IF]>

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         off

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            b43
  State:             unavailable
  Default:           no
  HW Address:        <MAC 'wlan0' [IF]>

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points 

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

##### iw reg get ########################

Region: Asia/Kuala_Lumpur (based on set time zone)

country 00:
	(2402 - 2472 @ 40), (3, 20)
	(2457 - 2482 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
	(2474 - 2494 @ 20), (3, 20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
	(5170 - 5250 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS
	(5735 - 5835 @ 40), (3, 20), PASSIVE-SCAN, NO-IBSS

##### iwlist channels ###################

lo        no frequency information.

eth0      no frequency information.

wlan0     14 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 14 : 2.484 GHz
          Current Frequency=2.412 GHz (Channel 1)

##### iwlist scan #######################

Channel occupancy:

      1   APs on   Frequency:2.412 GHz (Channel 1)
      1   APs on   Frequency:2.462 GHz (Channel 11)

lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: <MAC 'daniel23' [AC1]>
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=66/70  Signal level=-44 dBm  
                    Encryption key:on
                    ESSID:"daniel23"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000000053919636c
                    Extra: Last beacon: 5088ms ago
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : TKIP CCMP
                        Authentication Suites (1) : PSK
          Cell 02 - Address: <MAC 'kayymaqq' [AC2]>
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=38/70  Signal level=-72 dBm  
                    Encryption key:on
                    ESSID:"kayymaqq"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000051d6149f2
                    Extra: Last beacon: 880ms ago
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK

##### module infos ######################

[ssb_hcd]
filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/usb/host/ssb-hcd.ko
license:        GPL
description:    Common USB driver for SSB Bus
author:         Hauke Mehrtens
srcversion:     2A4C0EB5791EE9A11133FCB
depends:        ssb
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 686 
signer:         Magrathea: Glacier signing key
sig_key:        56:82:F3:37:B8:A0:A1:7E:EF:58:C6:AC:5E:9A:85:71:2C:92:08:DF
sig_hashalgo:   sha512

[b43]
filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/net/wireless/b43/b43.ko
firmware:       b43/ucode9.fw
firmware:       b43/ucode5.fw
firmware:       b43/ucode16_mimo.fw
firmware:       b43/ucode15.fw
firmware:       b43/ucode14.fw
firmware:       b43/ucode13.fw
firmware:       b43/ucode11.fw
license:        GPL
author:         Rafał Miłecki
author:         Gábor Stefanik
author:         Michael Buesch
author:         Stefano Brivio
author:         Martin Langer
description:    Broadcom B43 wireless driver
srcversion:     BED87D210887FFC71A4BDE0
depends:        bcma,ssb,mac80211,cfg80211
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 686 
signer:         Magrathea: Glacier signing key
sig_key:        56:82:F3:37:B8:A0:A1:7E:EF:58:C6:AC:5E:9A:85:71:2C:92:08:DF
sig_hashalgo:   sha512
parm:           bad_frames_preempt:enable(1) / disable(0) Bad Frames Preemption (int)
parm:           fwpostfix:Postfix for the .fw files to load. (string)
parm:           hwpctl:Enable hardware-side power control (default off) (int)
parm:           nohwcrypt:Disable hardware encryption. (int)
parm:           hwtkip:Enable hardware tkip. (int)
parm:           qos:Enable QOS support (default on) (int)
parm:           btcoex:Enable Bluetooth coexistence (default on) (int)
parm:           verbose:Log message verbosity: 0=error, 1=warn, 2=info(default), 3=debug (int)
parm:           pio:Use PIO accesses by default: 0=DMA, 1=PIO (int)
parm:           allhwsupport:Enable support for all hardware (even it if overlaps with the brcmsmac driver) (int)

[bcma]
filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/bcma/bcma.ko
license:        GPL
description:    Broadcom's specific AMBA driver
srcversion:     E41B811D88783DD5BC38565
depends:        
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 686 
signer:         Magrathea: Glacier signing key
sig_key:        56:82:F3:37:B8:A0:A1:7E:EF:58:C6:AC:5E:9A:85:71:2C:92:08:DF
sig_hashalgo:   sha512

[mac80211]
filename:       /lib/modules/3.13.0-24-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     C0F95BBF832E05DEFD722F4
depends:        cfg80211
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 686 
signer:         Magrathea: Glacier signing key
sig_key:        56:82:F3:37:B8:A0:A1:7E:EF:58:C6:AC:5E:9A:85:71:2C:92:08:DF
sig_hashalgo:   sha512
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/3.13.0-24-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     8B3D642D1F2E6406EF33F74
depends:        
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 686 
signer:         Magrathea: Glacier signing key
sig_key:        56:82:F3:37:B8:A0:A1:7E:EF:58:C6:AC:5E:9A:85:71:2C:92:08:DF
sig_hashalgo:   sha512
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

[ssb]
filename:       /lib/modules/3.13.0-24-generic/kernel/drivers/ssb/ssb.ko
license:        GPL
description:    Sonics Silicon Backplane driver
srcversion:     3DE188310F77C566C2E8CB3
depends:        
intree:         Y
vermagic:       3.13.0-24-generic SMP mod_unload modversions 686 
signer:         Magrathea: Glacier signing key
sig_key:        56:82:F3:37:B8:A0:A1:7E:EF:58:C6:AC:5E:9A:85:71:2C:92:08:DF
sig_hashalgo:   sha512

##### module parameters #################

[b43]
allhwsupport: 0
bad_frames_preempt: 0
btcoex: 1
hwpctl: 0
hwtkip: 0
nohwcrypt: 0
pio: 0
qos: 1
verbose: 2

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
probe_wait_ms: 500

[cfg80211]
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp
b43

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwled.conf]
options iwlegacy lede=1

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211
options iwlwifi led_mode=1

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

[/etc/modprobe.d/wlan.conf]
options iwlcore led_mode=1

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

[/etc/udev/rules.d/70-persistent-net.rules]
# PCI device 0x14e4:0x170c (b44)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'eth0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
# PCI device 0x14e4:0x4311 (b43)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="<MAC 'wlan0' [IF]>", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

##### dmesg #############################

[   22.496079] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[   22.576988] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready (repeated 2 times)
[   33.208110] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[   33.292690] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   33.486291] b44 ssb1:0 eth0: powering down PHY
[   34.124173] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[   34.205241] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   72.616114] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[   72.697009] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   72.948120] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[   73.029064] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   73.183061] b44 ssb1:0 eth0: powering down PHY
[   78.588114] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[   78.669350] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   78.817252] b44 ssb1:0 eth0: powering down PHY
[   79.372131] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[   79.453027] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   81.598203] wlan0: authenticate with <MAC 'daniel23' [AC1]>
[   81.598589] wlan0: send auth to <MAC 'daniel23' [AC1]> (try 1/3)
[   81.600282] wlan0: authenticated
[   81.604125] wlan0: associate with <MAC 'daniel23' [AC1]> (try 1/3)
[   81.606807] wlan0: RX AssocResp from <MAC 'daniel23' [AC1]> (capab=0x431 status=0 aid=6)
[   81.612351] wlan0: associated
[   81.612446] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 4461.996236] b44 ssb1:0 eth0: Link is up at 100 Mbps, full duplex
[ 4461.996243] b44 ssb1:0 eth0: Flow control is off for TX and off for RX
[ 4519.996168] b44 ssb1:0 eth0: Link is down
[ 4523.621649] b44 ssb1:0 eth0: powering down PHY
[ 4530.337944] wlan0: deauthenticating from <MAC 'daniel23' [AC1]> by local choice (reason=3)
[ 4530.600094] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4530.681036] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4531.645803] b44 ssb1:0 eth0: powering down PHY
[ 4531.944124] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4532.025326] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4539.404106] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4539.484968] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4539.660661] b44 ssb1:0 eth0: powering down PHY
[ 4539.872121] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4539.945564] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4540.448111] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4540.529060] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4540.892109] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4540.973008] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4579.744087] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4579.825422] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4580.084128] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4580.165066] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4580.464116] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4580.545096] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4580.558764] b44 ssb1:0 eth0: powering down PHY
[ 4583.224141] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4583.305309] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4583.608106] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4583.697057] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4583.706243] b44 ssb1:0 eth0: powering down PHY
[ 4584.284137] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4584.364994] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4594.612144] b43-phy0: Loading firmware version 666.2 (2011-02-23 01:15:07)
[ 4594.692975] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 4594.732661] wlan0: authenticate with <MAC 'daniel23' [AC1]>
[ 4594.732948] wlan0: send auth to <MAC 'daniel23' [AC1]> (try 1/3)
[ 4594.734528] wlan0: authenticated
[ 4594.736537] wlan0: associate with <MAC 'daniel23' [AC1]> (try 1/3)
[ 4594.739054] wlan0: RX AssocResp from <MAC 'daniel23' [AC1]> (capab=0x431 status=0 aid=6)
[ 4594.744137] wlan0: associated
[ 4594.744230] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

########## wireless info END ############

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: blinking wifi - difficulty to connect

Post by PatH57 » Mon Sep 29, 2014 11:34 am

Device: wlan0 ----------------------------------------------------------------
Type: 802.11 WiFi
Driver: b43
it is recognized as wlan not eth? but because both are broacom chips it can be confusing
let's see what the script does tell us.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

JeremyB
Level 19
Level 19
Posts: 9459
Joined: Fri Feb 21, 2014 8:17 am

Re: blinking wifi - difficulty to connect

Post by JeremyB » Mon Sep 29, 2014 5:44 pm

First thing to do is set the wifi router to WPA2-AES as TKIP causes issues at times

qiumera
Level 1
Level 1
Posts: 7
Joined: Mon Sep 29, 2014 10:19 am

Re: blinking wifi - difficulty to connect

Post by qiumera » Mon Sep 29, 2014 7:34 pm

Thank you for it! Unfortunately that is not an option - I want to use the laptop at my workplace. Any other suggestion?

JeremyB
Level 19
Level 19
Posts: 9459
Joined: Fri Feb 21, 2014 8:17 am

Re: blinking wifi - difficulty to connect

Post by JeremyB » Mon Sep 29, 2014 7:49 pm

That might make this difficult if you can not convince those at your workplace to switch to WPA2-AES as it is much better for wifi security but try this and reboot

Code: Select all

echo "options b43 hwtkip=1" | sudo tee /etc/modprobe.d/b43.conf

qiumera
Level 1
Level 1
Posts: 7
Joined: Mon Sep 29, 2014 10:19 am

Re: blinking wifi - difficulty to connect

Post by qiumera » Tue Sep 30, 2014 12:22 am

What should have been the outcome? I do not see any changes.

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: blinking wifi - difficulty to connect

Post by PatH57 » Tue Sep 30, 2014 3:52 am

you won't see any visual changes, it just changes the way the encryption is handled.
did you run the test at home or at work?
[ 4594.739054] wlan0: RX AssocResp from <MAC 'daniel23' [AC1]> (capab=0x431 status=0 aid=6)
[ 4594.744137] wlan0: associated
[ 4594.744230] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
here it seems that the wlan connected to daniel23 and
wlan0 Link encap:Ethernet HWaddr <MAC 'wlan0' [IF]>
inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::21d:d9ff:fe5f:cacd/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:11496 errors:0 dropped:0 overruns:0 frame:0
TX packets:10627 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8941938 (8.9 MB) TX bytes:1996670 (1.9 MB)
data has been exchanged.
could you expand a bit more on what kind of problems you do see? at work and at home?
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

qiumera
Level 1
Level 1
Posts: 7
Joined: Mon Sep 29, 2014 10:19 am

Re: blinking wifi - difficulty to connect

Post by qiumera » Tue Sep 30, 2014 10:10 am

Hi again!
Oh, all right. thanks!
I experience the problem everywhere - at home (I can connect because I only need a passphrase = daniel23), at my workplace (so it is connected to wired internet because I need the username and password and somehow I can't pass through of it) and even if I share the network from my phone. The bluetooth is fine, always on without any problem, just the wifi led is switching on-off. Out of 3 times trying to connect, 2 times will fail - it says "bad password", although nothing I change.

Beside of it, I noticed that at my workplace as I move (it is a pretty big building) it recognizes the same named wifi as a different one (???), asking in different locations to login. Is it the wicd's problem / it is just because I am actually not able connect / ???

JeremyB
Level 19
Level 19
Posts: 9459
Joined: Fri Feb 21, 2014 8:17 am

Re: blinking wifi - difficulty to connect

Post by JeremyB » Tue Sep 30, 2014 6:20 pm

qiumera wrote:Hi again!
Oh, all right. thanks!
I experience the problem everywhere - at home (I can connect because I only need a passphrase = daniel23), at my workplace (so it is connected to wired internet because I need the username and password and somehow I can't pass through of it) and even if I share the network from my phone. The bluetooth is fine, always on without any problem, just the wifi led is switching on-off. Out of 3 times trying to connect, 2 times will fail - it says "bad password", although nothing I change.

Beside of it, I noticed that at my workplace as I move (it is a pretty big building) it recognizes the same named wifi as a different one (???), asking in different locations to login. Is it the wicd's problem / it is just because I am actually not able connect / ???
Your issues at work could likely be resolved by setting up a seperate connection in wicd for each AP unless there is a way in wicd to ignore the different MAC addresses or the AP's with the same name

qiumera
Level 1
Level 1
Posts: 7
Joined: Mon Sep 29, 2014 10:19 am

Re: blinking wifi - difficulty to connect

Post by qiumera » Wed Oct 01, 2014 6:14 am

All right, thank you, I will try it.
Any idea what does cause the original problem? Why is blinking (wifi on, off, on, off situation)? I can't connect at work, and at home also takes at least 3 trial to connect.

Again, many thanks for your time, advice and help!

User avatar
PatH57
Level 13
Level 13
Posts: 4576
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: blinking wifi - difficulty to connect

Post by PatH57 » Thu Oct 02, 2014 5:15 am

let's make sure you have the latest version of the drivers.

Code: Select all

sudo apt-get update

Code: Select all

sudo apt-get install linux-firmware-nonfree
then reboot.
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.

qiumera
Level 1
Level 1
Posts: 7
Joined: Mon Sep 29, 2014 10:19 am

Re: blinking wifi - difficulty to connect

Post by qiumera » Thu Oct 02, 2014 10:29 am

Yeap, it was, I run the commands, but no change, it is up to date.
Today I was able to connect first time at my workplace, hurray!!! That is not a problem anymore. How did I do it? Good question...

The issue remains: the wifi is blinking when connecting (on-off, and it is based on luck to connect).
It has to be switched on manually because after booting it switches off.

Post Reply

Return to “Wireless”