Page 1 of 1

[SOLVED] Can't use wifi

Posted: Thu Apr 09, 2015 8:25 am
by girlggc
I'm at a loss. I've been using Linux successfully for quite some time now so I probably should know how to fix this problem but, alas, I do not. Anyway, up until yesterday my wifi was working fine. Now it won't work. The icon is not appearing in the system tray. Wired Ethernet does work, though. I am running Linux Mint 17.1 Cinnamon 64-bit on a Dell XPS 15 L521x, if that matters.

Re: Can't use wifi

Posted: Thu Apr 09, 2015 8:30 am
by Pjotr
Please generate an overview of your system like this:
- launch a terminal window and make it fullscreen, to avoid chopped lines;
- copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
if you type: the letter F is a capital letter

Press Enter.

Copy/paste the output in your next message.

Also post the output of this command:

Code: Select all

sudo rfkill list all
And of this command:

Code: Select all

iwconfig

Re: Can't use wifi

Posted: Thu Apr 09, 2015 8:42 am
by girlggc
Okay, here's what I got

From inxi -Fxz
rachel@purple-blossom ~ $ inxi -Fxz
rachel@purple-blossom ~ $ inxi -Fxz
System: Host: purple-blossom Kernel: 3.13.0-37-generic x86_64 (64 bit, gcc: 4.8.2)
Desktop: Gnome Distro: Linux Mint 17.1 Rebecca
Machine: System: Dell (portable) product: XPS L521X version: A04
Mobo: Dell model: 07C1H7 version: A00 Bios: Dell version: A04 date: 06/26/2012
CPU: Dual core Intel Core i5-3210M CPU (-HT-MCP-) cache: 3072 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9976.74
Clock Speeds: 1: 1200.00 MHz 2: 1200.00 MHz 3: 1200.00 MHz 4: 1200.00 MHz
Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
X.Org: 1.15.1 drivers: (unloaded: fbdev,vesa) FAILED: nouveau,intel Resolution: 1920x1080@60.0hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio: Card: Intel 7 Series/C210 Series Chipset Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
driver: r8169 ver: 2.3LK-NAPI port: 2000 bus-ID: 07:00.0
IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: 532.1GB (2.1% used) 1: id: /dev/sda model: Hitachi_HTS72755 size: 500.1GB
2: id: /dev/sdb model: SAMSUNG_SSD_PM83 size: 32.0GB
Partition: ID: / size: 453G used: 11G (3%) fs: ext4 ID: swap-1 size: 6.34GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 54.0C mobo: N/A gpu: 45.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 194 Uptime: 17 min Memory: 1422.4/5871.5MB Runlevel: 2 Gcc sys: 4.8.2 Client: Shell inxi: 1.8.4

From sudo rfkill list all I got absolutely nothing. Seriously. I'll copy and paste.
rachel@purple-blossom ~ $ sudo rfkill list all
rachel@purple-blossom ~ $

From iwconfig I got
rachel@purple-blossom ~ $ iwconfig
eth0 no wireless extensions.

lo no wireless extensions.

Re: Can't use wifi

Posted: Thu Apr 09, 2015 8:45 am
by Pjotr
Apparently, there's absolutely no wireless chipset to be found at all.... :shock:

Unfortunately, I'm at a loss. Hopefully someone else can help you.

Re: Can't use wifi

Posted: Thu Apr 09, 2015 10:08 am
by JeremyB
Check BIOS to see if wifi is enabled, if it is enabled or there is no option to disable, power off the computer then remove and insert the wifi card

Re: Can't use wifi

Posted: Thu Apr 09, 2015 11:12 am
by girlggc
I just checked the BIOS and there is no option to disable. I'll reseat the wifi card later on when I'm not at work.

Re: Can't use wifi

Posted: Thu Apr 09, 2015 5:30 pm
by edwardr
Is there a physical switch or button to turn off the wifi? Maybe it has been accidentally switched off? I know I've done that before.

Re: Can't use wifi

Posted: Sun Apr 12, 2015 6:34 pm
by girlggc
I forgot to update. I reseated the wifi card and that did the trick.