Very slow WiFi in Linux Mint

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Locked
j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Very slow WiFi in Linux Mint

Post by j00lz » Mon Nov 02, 2015 4:59 am

Code: Select all

System:    Host: j00lz-Inspiron-7520 Kernel: 4.2.5-040205-generic x86_64 (64 bit, gcc: 5.2.1) 
           Desktop: Cinnamon 2.6.13  Distro: Linux Mint 17.2 Rafaela
Machine:   System: Dell product: Inspiron 7520 version: A11
           Mobo: Dell model: 0PXH02 version: A00 Bios: Dell version: A11 date: 02/20/2014
CPU:       Quad core Intel Core i7-3612QM CPU (-HT-MCP-) cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 16760.3 
           Clock Speeds: 1: 1327.511 MHz 2: 1345.886 MHz 3: 1583.449 MHz 4: 1218.738 MHz 5: 1201.101 MHz 6: 1501.417 MHz 7: 1427.261 MHz 8: 1558.675 MHz
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0 
           Card-2: Advanced Micro Devices [AMD/ATI] Chelsea LP [Radeon HD 7730M] bus-ID: 01:00.0 
           X.Org: 1.15.1 driver: intel Resolution: 1920x1080@60.0hz 
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card: Intel 7 Series/C210 Series Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 
           Sound: Advanced Linux Sound Architecture ver: k4.2.5-040205-generic
Network:   Card-1: Intel Centrino Wireless-N 2230 driver: iwlwifi bus-ID: 08:00.0
           IF: wlan0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 
           driver: r8169 ver: 2.3LK-NAPI port: 2000 bus-ID: 07:00.0
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 1032.2GB (5.2% used) 1: id: /dev/sda model: WDC_WD10JPVT size: 1000.2GB 
           2: id: /dev/sdb model: SAMSUNG_SSD_PM83 size: 32.0GB 
Partition: ID: / size: 74G used: 51G (73%) fs: ext4 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 71.0C mobo: N/A gpu: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 266 Uptime: 1:23 Memory: 4203.4/7859.2MB Runlevel: 2 Gcc sys: 4.8.4 
           Client: Shell (bash 4.3.11) inxi: 1.9.17 
My internet speed using speedtest.net from the Linux Mint installation:
Image

and the speed using either Windows 10 on the same machine or from a Macbook Air on the same WiFi router are almost identical and usually similar to this:
Image

Any idea what's throttling the connection in Linux, and how to fix it?

Cheers

Rusty1
Level 2
Level 2
Posts: 67
Joined: Thu Feb 17, 2011 6:19 pm

Re: Very slow WiFi in Linux Mint

Post by Rusty1 » Mon Nov 02, 2015 9:41 am

In Update manager, shield icon lower right, View, install the latest kernel and reboot.

You can also try disabling ipv6 in network settings.

Also try changing the channel the router broadcasts on.

JeremyB
Level 18
Level 18
Posts: 8281
Joined: Fri Feb 21, 2014 8:17 am

Re: Very slow WiFi in Linux Mint

Post by JeremyB » Mon Nov 02, 2015 6:54 pm

Check your wireless router settings to make sure it is using WPA2 only, it might be called WPA2-AES or WPA2-PSK, you do not want TKIP or WEP enabled

And with Intel wireless cards using iwlwifi module like yours, you can try

Code: Select all

echo "options iwlwifi 11n_disable=8" | sudo tee /etc/modprobe.d/iwlopt.conf
Reboot and see if it improves, it if doesn't you can also try

Code: Select all

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlopt.conf
Reboot

The 11n_disable=8 command is actually preferred as is enables aggressive tx for wireless 11N and the 11n_disable=1 disables 11N

j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Re: Very slow WiFi in Linux Mint

Post by j00lz » Wed Nov 25, 2015 3:09 am

Thanks for your replies, I've tried all the suggestions (except changing the router setting as all other devices work fine on it) ), at first the problem seemed to be resolved.
However now it's back operating at the slower speed again.

I'm also having trouble with the machine freezing for extended periods of time and am wondering if this may be connected.
Basically the mouse freezes or becomes increadibly unresponsive and delayed, after a number of seconds it 'unlocks' and works ok again but this happens repeatedly. Mostly when using chrome or firefox with many windows open but even after closing them all down the problem persists when accessing nemo and browsing files, and any number of other simple activities.

Any help would be much appreciated, at the moment due to these two issues that I've spent hours trying to resolve, I'm using Windows far more than I'd like to :(

JeremyB
Level 18
Level 18
Posts: 8281
Joined: Fri Feb 21, 2014 8:17 am

Re: Very slow WiFi in Linux Mint

Post by JeremyB » Wed Nov 25, 2015 9:13 pm

Are the other devices using Linux Mint or other Linux distros? Windows, Android and Apple's iOS will work fine with TKIP/WEP as they wouldn't sell as many devices if they had problems.

WEP/TKIP encryption is a security risk as it is easy for someone to eavesdrop on the communication

j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Re: Very slow WiFi in Linux Mint

Post by j00lz » Mon Nov 30, 2015 6:44 am

I'm only having issues with Linux Mint, all other devices and OS on this device work fine and fast too !

The router is using WPA-Personal - AES Encryption.

User avatar
Pjotr
Level 20
Level 20
Posts: 10159
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Very slow WiFi in Linux Mint

Post by Pjotr » Mon Nov 30, 2015 8:04 am

You're running the 4.2.x kernel. I advise to try the latest kernel from the 3.19 series:
https://sites.google.com/site/easylinux ... el-updates
(item 3, right column)
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Re: Very slow WiFi in Linux Mint

Post by j00lz » Thu Dec 03, 2015 5:46 am

Just installed the 3..19.0-33-generic Kernal and unfortunately it's not made any improvement to the wifi speed :(

Is there any other settings or ways of monitoring the connection that I could investigate?

Rusty1
Level 2
Level 2
Posts: 67
Joined: Thu Feb 17, 2011 6:19 pm

Re: Very slow WiFi in Linux Mint

Post by Rusty1 » Thu Dec 03, 2015 2:28 pm

Can you type:

Code: Select all

dmesg
in a terminal and post the last , say, 50 to 100 lines - we are looking for 802.11 and ipv6 related messages.

You could also post output of:

Code: Select all

sudo iwconfig
maybe we'll see something.

JeremyB
Level 18
Level 18
Posts: 8281
Joined: Fri Feb 21, 2014 8:17 am

Re: Very slow WiFi in Linux Mint

Post by JeremyB » Thu Dec 03, 2015 7:19 pm

j00lz wrote:I'm only having issues with Linux Mint, all other devices and OS on this device work fine and fast too !

The router is using WPA-Personal - AES Encryption.
Post the result of

Code: Select all

iwlist scan | egrep -i 'essid|cipher'
in terminal and the name of your network

j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Re: Very slow WiFi in Linux Mint

Post by j00lz » Fri Dec 04, 2015 8:07 am

dmesg

Code: Select all

[    5.365077] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    5.365118] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    5.365426] scsi 1:0:0:0: Direct-Access     ATA      SAMSUNG SSD PM83 2D1Q PQ: 0 ANSI: 5
[    5.365664] sd 1:0:0:0: [sdb] 62533296 512-byte logical blocks: (32.0 GB/29.8 GiB)
[    5.365666] sd 1:0:0:0: Attached scsi generic sg1 type 0
[    5.365812] sd 1:0:0:0: [sdb] Write Protect is off
[    5.365814] sd 1:0:0:0: [sdb] Mode Sense: 00 3a 00 00
[    5.365865] sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    5.366261]  sdb: sdb1
[    5.366556] sd 1:0:0:0: [sdb] Attached SCSI disk
[    5.374692] ata3.00: ATAPI: MATSHITA DVD+/-RW UJ8C1, D.02, max UDMA/100
[    5.387969] ata3.00: configured for UDMA/100
[    5.395499] [drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[    5.395516] [drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[    5.398359]  sda: sda1 sda2 sda3 < sda5 > sda4
[    5.398887] sd 0:0:0:0: [sda] Attached SCSI disk
[    5.399584] scsi 2:0:0:0: CD-ROM            MATSHITA DVD+-RW UJ8C1    D.02 PQ: 0 ANSI: 5
[    5.438174] sr 2:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    5.438176] cdrom: Uniform CD-ROM driver Revision: 3.20
[    5.438414] sr 2:0:0:0: Attached scsi CD-ROM sr0
[    5.438538] sr 2:0:0:0: Attached scsi generic sg2 type 5
[    5.817278] psmouse serio1: elantech: assuming hardware version 3 (with firmware version 0x450f02)
[    5.828925] Console: switching to colour frame buffer device 240x67
[    5.834123] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device
[    5.847792] psmouse serio1: elantech: Synaptics capabilities query result 0x79, 0x17, 0x0c.
[    5.879409] psmouse serio1: elantech: Elan sample query result 03, 4d, 85
[    6.041903] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input6
[    6.080757] random: nonblocking pool is initialized
[    7.307964] md: linear personality registered for level -1
[    7.309878] md: multipath personality registered for level -4
[    7.311785] md: raid0 personality registered for level 0
[    7.313939] md: raid1 personality registered for level 1
[    7.332465] raid6: sse2x1   gen()  7964 MB/s
[    7.349460] raid6: sse2x1   xor()  6468 MB/s
[    7.366474] raid6: sse2x2   gen() 10101 MB/s
[    7.383480] raid6: sse2x2   xor()  7199 MB/s
[    7.400488] raid6: sse2x4   gen() 11945 MB/s
[    7.417496] raid6: sse2x4   xor()  8843 MB/s
[    7.417511] raid6: using algorithm sse2x4 gen() 11945 MB/s
[    7.417530] raid6: .... xor() 8843 MB/s, rmw enabled
[    7.417547] raid6: using ssse3x2 recovery algorithm
[    7.418531] xor: automatically using best checksumming function:
[    7.428503]    avx       : 21836.000 MB/sec
[    7.429535] async_tx: api initialized (async)
[    7.435092] md: raid6 personality registered for level 6
[    7.435114] md: raid5 personality registered for level 5
[    7.435134] md: raid4 personality registered for level 4
[    7.439183] md: raid10 personality registered for level 10
[   12.719910] EXT4-fs (sda4): INFO: recovery required on readonly filesystem
[   12.719943] EXT4-fs (sda4): write access will be enabled during recovery
[   13.421967] EXT4-fs (sda4): orphan cleanup on readonly fs
[   13.422032] EXT4-fs (sda4): 1 orphan inode deleted
[   13.422059] EXT4-fs (sda4): recovery complete
[   13.571221] EXT4-fs (sda4): mounted filesystem with ordered data mode. Opts: (null)
[   36.729504] systemd-udevd[656]: starting version 204
[   37.388679] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20150818/utaddress-254)
[   37.388685] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   37.388689] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150818/utaddress-254)
[   37.388693] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x000000000000055F (\_SB_.PCI0.PEG0.PEGP.GPIO) (20150818/utaddress-254)
[   37.388695] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   37.388696] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150818/utaddress-254)
[   37.388699] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000055F (\_SB_.PCI0.PEG0.PEGP.GPIO) (20150818/utaddress-254)
[   37.388701] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   37.388702] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20150818/utaddress-254)
[   37.388704] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000055F (\_SB_.PCI0.PEG0.PEGP.GPIO) (20150818/utaddress-254)
[   37.388707] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   37.388707] lpc_ich: Resource conflict(s) found affecting gpio_ich
[   37.419594] device-mapper: multipath: version 1.9.0 loaded
[   37.508746] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   37.710763] lp: driver loaded but no devices found
[   37.765425] usb 1-4: ep 0x2 - rounding interval to 8 microframes, ep desc says 10 microframes
[   37.765430] usb 1-4: ep 0x81 - rounding interval to 8 microframes, ep desc says 10 microframes
[   37.818279] Bluetooth: Core ver 2.20
[   37.818296] NET: Registered protocol family 31
[   37.818297] Bluetooth: HCI device and connection manager initialized
[   37.818301] Bluetooth: HCI socket layer initialized
[   37.818303] Bluetooth: L2CAP socket layer initialized
[   37.818308] Bluetooth: SCO socket layer initialized
[   37.932754] ppdev: user-space parallel port driver
[   37.935313] input: Dell WMI hotkeys as /devices/virtual/input/input9
[   37.980124] dcdbas dcdbas: Dell Systems Management Base Driver (version 5.6.0-3.2)
[   38.075954] usbcore: registered new interface driver btusb
[   38.087701] Intel(R) Wireless WiFi driver for Linux
[   38.087703] Copyright(c) 2003- 2015 Intel Corporation
[   38.087817] iwlwifi 0000:08:00.0: can't disable ASPM; OS doesn't have ASPM control
[   38.153198] media: Linux media interface: v0.10
[   38.174834] AVX version of gcm_enc/dec engaged.
[   38.174837] AES CTR mode by8 optimization enabled
[   38.191306] cfg80211: World regulatory domain updated:
[   38.191309] cfg80211:  DFS Master region: unset
[   38.191310] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   38.191312] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   38.191313] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   38.191314] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[   38.191316] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   38.191317] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[   38.249919] Linux video capture interface: v2.00
[   38.266195] ipheth 1-4:4.2: Apple iPhone USB Ethernet device attached
[   38.266214] usbcore: registered new interface driver ipheth
[   38.442005] iwlwifi 0000:08:00.0: loaded firmware version 18.168.6.1 op_mode iwldvm
[   38.558776] uvcvideo: Found UVC 1.00 device Laptop_Integrated_Webcam_HD (0c45:648d)
[   38.583903] input: Laptop_Integrated_Webcam_HD as /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.5/3-1.5:1.0/input/input10
[   38.584054] usbcore: registered new interface driver uvcvideo
[   38.584056] USB Video Class driver (1.1.1)
[   38.726568] iwlwifi 0000:08:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   38.726572] iwlwifi 0000:08:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   38.726573] iwlwifi 0000:08:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   38.726575] iwlwifi 0000:08:00.0: Detected Intel(R) Centrino(R) Wireless-N 2230 BGN, REV=0xC8
[   38.726669] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[   38.776395] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   38.798406] intel_rapl: Found RAPL domain package
[   38.798410] intel_rapl: Found RAPL domain core
[   38.798413] intel_rapl: Found RAPL domain uncore
[   39.047651] snd_hda_codec_conexant hdaudioC0D0: CX20590: BIOS auto-probing.
[   39.048128] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20590: line_outs=1 (0x1f/0x0/0x0/0x0/0x0) type:speaker
[   39.048131] snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   39.048133] snd_hda_codec_conexant hdaudioC0D0:    hp_outs=1 (0x19/0x0/0x0/0x0/0x0)
[   39.048135] snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
[   39.048136] snd_hda_codec_conexant hdaudioC0D0:    inputs:
[   39.048138] snd_hda_codec_conexant hdaudioC0D0:      Internal Mic=0x23
[   39.048139] snd_hda_codec_conexant hdaudioC0D0:      Mic=0x1a
[   39.049184] snd_hda_codec_conexant hdaudioC0D0: Enable sync_write for stable communication
[   39.133823] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
[   39.133920] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
[   39.133969] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
[   41.183521] EXT4-fs (sda4): re-mounted. Opts: errors=remount-ro
[   41.244834] init: failsafe main process (1079) killed by TERM signal
[   41.548595] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   41.548597] Bluetooth: BNEP filters: protocol multicast
[   41.548609] Bluetooth: BNEP socket layer initialized
[   41.557262] Bluetooth: RFCOMM TTY layer initialized
[   41.557268] Bluetooth: RFCOMM socket layer initialized
[   41.557272] Bluetooth: RFCOMM ver 1.11
[   41.753676] init: cups main process (1188) killed by HUP signal
[   41.753692] init: cups main process ended, respawning
[   42.415779] zram: Added device: zram0
[   42.415926] zram: Added device: zram1
[   42.416491] zram: Added device: zram2
[   42.416971] zram: Added device: zram3
[   42.418236] zram: Added device: zram4
[   42.418669] zram: Added device: zram5
[   42.418856] zram: Added device: zram6
[   42.420729] zram: Added device: zram7
[   42.425075] zram0: detected capacity change from 0 to 250826752
[   42.426420] Adding 244944k swap on /dev/zram0.  Priority:5 extents:1 across:244944k SSFS
[   42.426669] zram1: detected capacity change from 0 to 250826752
[   42.430409] Adding 244944k swap on /dev/zram1.  Priority:5 extents:1 across:244944k SSFS
[   42.430688] zram2: detected capacity change from 0 to 250826752
[   42.433506] Adding 244944k swap on /dev/zram2.  Priority:5 extents:1 across:244944k SSFS
[   42.433763] zram3: detected capacity change from 0 to 250826752
[   42.435744] Adding 244944k swap on /dev/zram3.  Priority:5 extents:1 across:244944k SSFS
[   42.435973] zram4: detected capacity change from 0 to 250826752
[   42.437675] Adding 244944k swap on /dev/zram4.  Priority:5 extents:1 across:244944k SSFS
[   42.437915] zram5: detected capacity change from 0 to 250826752
[   42.439718] Adding 244944k swap on /dev/zram5.  Priority:5 extents:1 across:244944k SSFS
[   42.439999] zram6: detected capacity change from 0 to 250826752
[   42.441719] Adding 244944k swap on /dev/zram6.  Priority:5 extents:1 across:244944k SSFS
[   42.441976] zram7: detected capacity change from 0 to 250826752
[   42.443376] Adding 244944k swap on /dev/zram7.  Priority:5 extents:1 across:244944k SSFS
[   42.809280] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   43.037593] r8169 0000:07:00.0 eth0: link down
[   43.037659] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   43.039987] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[   43.047486] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[   43.047573] iwlwifi 0000:08:00.0: Radio type=0x2-0x0-0x0
[   43.184374] init: plymouth-upstart-bridge main process ended, respawning
[   43.187882] init: plymouth-upstart-bridge main process (1645) terminated with status 1
[   43.187890] init: plymouth-upstart-bridge main process ended, respawning
[   43.287753] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[   43.295273] iwlwifi 0000:08:00.0: L1 Enabled - LTR Disabled
[   43.295361] iwlwifi 0000:08:00.0: Radio type=0x2-0x0-0x0
[   43.348486] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   43.980346] wlan0: authenticate with c4:e9:84:a1:38:6c
[   43.985112] wlan0: send auth to c4:e9:84:a1:38:6c (try 1/3)
[   43.987344] wlan0: authenticated
[   43.987961] wlan0: associate with c4:e9:84:a1:38:6c (try 1/3)
[   43.991151] wlan0: RX AssocResp from c4:e9:84:a1:38:6c (capab=0x431 status=0 aid=1)
[   43.998812] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   43.998869] wlan0: associated
[   51.074615] init: plymouth-stop pre-start process (2669) terminated with status 1
[  216.141032] systemd-hostnamed[7663]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname!
[  318.518073] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[  318.541939] psmouse serio1: Touchpad at isa0060/serio1/input0 - driver resynced.
[  438.485650] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[  438.508562] psmouse serio1: Touchpad at isa0060/serio1/input0 - driver resynced.
[ 1453.233397] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 1453.247857] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 1453.262261] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 1453.280191] psmouse serio1: Touchpad at isa0060/serio1/input0 lost sync at byte 6
[ 1453.398571] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.398620] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.398659] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.398700] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.398712] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.398793] pci_bus 0000:07: Allocating resources
[ 1453.398808] pcieport 0000:00:1c.0: bridge window [mem 0x00100000-0x000fffff] to [bus 07] add_size 400000 add_align 100000
[ 1453.398814] pci_bus 0000:08: Allocating resources
[ 1453.398850] pcieport 0000:00:1c.1: bridge window [io  0x1000-0x0fff] to [bus 08] add_size 1000
[ 1453.398852] pcieport 0000:00:1c.1: bridge window [mem 0x00100000-0x000fffff 64bit pref] to [bus 08] add_size 200000 add_align 100000
[ 1453.398854] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.398857] pcieport 0000:00:1c.0: res[14]=[mem 0x00100000-0x000fffff] res_to_dev_res add_size 400000 min_align 100000
[ 1453.398859] pcieport 0000:00:1c.0: res[14]=[mem 0x00100000-0x004fffff] res_to_dev_res add_size 400000 min_align 100000
[ 1453.398861] pcieport 0000:00:1c.1: res[15]=[mem 0x00100000-0x000fffff 64bit pref] res_to_dev_res add_size 200000 min_align 100000
[ 1453.398863] pcieport 0000:00:1c.1: res[15]=[mem 0x00100000-0x002fffff 64bit pref] res_to_dev_res add_size 200000 min_align 100000
[ 1453.398865] pcieport 0000:00:1c.1: res[13]=[io  0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[ 1453.398866] pcieport 0000:00:1c.1: res[13]=[io  0x1000-0x1fff] res_to_dev_res add_size 1000 min_align 1000
[ 1453.398871] pcieport 0000:00:1c.0: BAR 14: assigned [mem 0x9fb00000-0x9fefffff]
[ 1453.398876] pcieport 0000:00:1c.1: BAR 15: assigned [mem 0xc1700000-0xc18fffff 64bit pref]
[ 1453.398880] pcieport 0000:00:1c.1: BAR 13: assigned [io  0x5000-0x5fff]
[ 1453.399143] [Firmware Bug]: Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1"if the current driver doesn't work.
[ 1453.399171] pci_bus 0000:01: Allocating resources
[ 1453.399177] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.399271] i915 0000:00:02.0: BAR 6: [??? 0x00000000 flags 0x2] has bogus alignment
[ 1453.620894] psmouse serio1: Touchpad at isa0060/serio1/input0 - driver resynced.
[ 1455.511199] PM: Syncing filesystems ... done.
[ 1456.063019] PM: Preparing system for sleep (mem)
[ 1456.063358] Freezing user space processes ... (elapsed 0.001 seconds) done.
[ 1456.065050] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 1456.066206] PM: Suspending system (mem)
[ 1456.066219] Suspending console(s) (use no_console_suspend to debug)
[ 1456.066357] wlan0: deauthenticating from c4:e9:84:a1:38:6c by local choice (Reason: 3=DEAUTH_LEAVING)
[ 1456.091314] sd 1:0:0:0: [sdb] Synchronizing SCSI cache
[ 1456.091323] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 1456.092489] sd 1:0:0:0: [sdb] Stopping disk
[ 1456.104174] sd 0:0:0:0: [sda] Stopping disk
[ 1456.130092] ipheth 1-4:4.2: Apple iPhone USB Ethernet now disconnected
[ 1456.682492] PM: suspend of devices complete after 615.804 msecs
[ 1456.693409] PM: late suspend of devices complete after 10.906 msecs
[ 1456.694427] ehci-pci 0000:00:1d.0: System wakeup enabled by ACPI
[ 1456.694615] pcieport 0000:00:1c.0: System wakeup enabled by ACPI
[ 1456.694696] xhci_hcd 0000:00:14.0: System wakeup enabled by ACPI
[ 1456.705508] PM: noirq suspend of devices complete after 12.089 msecs
[ 1456.705742] ACPI: Preparing to enter system sleep state S3
[ 1456.705980] ACPI : EC: EC stopped
[ 1456.705981] PM: Saving platform NVS memory
[ 1456.705985] Disabling non-boot CPUs ...
[ 1456.714457] smpboot: CPU 1 is now offline
[ 1456.731462] smpboot: CPU 2 is now offline
[ 1456.752435] Broke affinity for irq 23
[ 1456.752437] Broke affinity for irq 25
[ 1456.753461] smpboot: CPU 3 is now offline
[ 1456.770451] Broke affinity for irq 23
[ 1456.770454] Broke affinity for irq 25
[ 1456.771483] smpboot: CPU 4 is now offline
[ 1456.786448] Broke affinity for irq 16
[ 1456.786451] Broke affinity for irq 23
[ 1456.786453] Broke affinity for irq 25
[ 1456.786454] Broke affinity for irq 27
[ 1456.787479] smpboot: CPU 5 is now offline
[ 1456.803451] Broke affinity for irq 16
[ 1456.803455] Broke affinity for irq 23
[ 1456.803457] Broke affinity for irq 25
[ 1456.803459] Broke affinity for irq 27
[ 1456.804480] smpboot: CPU 6 is now offline
[ 1456.818458] Broke affinity for irq 16
[ 1456.818462] Broke affinity for irq 23
[ 1456.818463] Broke affinity for irq 25
sudo iwconfig

Code: Select all

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"TP-LINK_A1386C"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: C4:E9:84:A1:38:6C   
          Bit Rate=2 Mb/s   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=54/70  Signal level=-56 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:11088   Missed beacon:0

eth1      no wireless extensions.

lo        no wireless extensions.
iwlist scan | egrep -i 'essid|cipher'

Code: Select all

eth0      Interface doesn't support scanning.

eth1      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

                    ESSID:"TP-LINK_A1386C"
                        Group Cipher : CCMP

JeremyB
Level 18
Level 18
Posts: 8281
Joined: Fri Feb 21, 2014 8:17 am

Re: Very slow WiFi in Linux Mint

Post by JeremyB » Fri Dec 04, 2015 6:20 pm

A lot of errors in dmesg that might cause the problem, post

Code: Select all

lspci

j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Re: Very slow WiFi in Linux Mint

Post by j00lz » Sun Dec 06, 2015 4:09 am

Issues with sluggish response of the UI have increased a lot too :(

lspci

Code: Select all

00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Chelsea LP [Radeon HD 7730M]
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
08:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)

JeremyB
Level 18
Level 18
Posts: 8281
Joined: Fri Feb 21, 2014 8:17 am

Re: Very slow WiFi in Linux Mint

Post by JeremyB » Sun Dec 06, 2015 6:22 am

This parameter might help according to a bug report

Code: Select all

sudo gedit /etc/default/grub
Find the line that should start with GRUB_CMDLINE_LINUX_DEFAULT and inside the quotes add pci=nocrs
Then you will likely have

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nocrs"
Save and exit gedit then

Code: Select all

sudo update-grub
Reboot

j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Re: Very slow WiFi in Linux Mint

Post by j00lz » Sun Dec 06, 2015 1:02 pm

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="nomdmonddf nomdmonisw zswap.enabled=1 pci=nocrs"

JeremyB
Level 18
Level 18
Posts: 8281
Joined: Fri Feb 21, 2014 8:17 am

Re: Very slow WiFi in Linux Mint

Post by JeremyB » Sun Dec 06, 2015 1:57 pm

j00lz wrote:

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="nomdmonddf nomdmonisw zswap.enabled=1 pci=nocrs"
That should work but what is the reason for mondmonddf and nomdmonisw, a search brought up info about RAID but your inxi info didn't reveal such an array?

j00lz
Level 1
Level 1
Posts: 8
Joined: Mon Nov 02, 2015 4:38 am

Re: Very slow WiFi in Linux Mint

Post by j00lz » Tue Dec 08, 2015 5:50 am

The internet speed issue seems totally cured now :) Many thanks for that. (I also upgraded to 17.3 today and am still in the process of testing everything)

As for the 'mondmonddf and nomdmonisw' I'm not certain what they are for either.

My machine is a Dell Inspiron 15r SE with a 32gb Intel SSD drive which is functioning correctly in Windows, is this the RAID array you are referring to?
I'm not certain it's status, I spent some time before making sure it was working but that was a long time ago and have upgraded Mint since then and am not certain it is functioning correctly.
this may well be the reason the machine feels so much slower in Linux than Windows, high memory usage in browsers for example seems to totally lock the machine which is not the case in Windows.

JeremyB
Level 18
Level 18
Posts: 8281
Joined: Fri Feb 21, 2014 8:17 am

Re: Very slow WiFi in Linux Mint

Post by JeremyB » Tue Dec 08, 2015 6:55 am

j00lz wrote:The internet speed issue seems totally cured now :) Many thanks for that. (I also upgraded to 17.3 today and am still in the process of testing everything)

As for the 'mondmonddf and nomdmonisw' I'm not certain what they are for either.

My machine is a Dell Inspiron 15r SE with a 32gb Intel SSD drive which is functioning correctly in Windows, is this the RAID array you are referring to?
I'm not certain it's status, I spent some time before making sure it was working but that was a long time ago and have upgraded Mint since then and am not certain it is functioning correctly.
this may well be the reason the machine feels so much slower in Linux than Windows, high memory usage in browsers for example seems to totally lock the machine which is not the case in Windows.
If you are dual boot, when the grub menu appears press e to edit then use arrow keys to scroll down and delete the

Code: Select all

zswap.enabled=1
and see if it behaves better without it. If it does work better without you can make the change permanent by editing the /etc/default/grub file and doing a sudo update-grub after the edit

rteuigu475gr
Level 1
Level 1
Posts: 1
Joined: Tue Feb 06, 2018 10:47 pm

Re: Very slow WiFi in Linux Mint

Post by rteuigu475gr » Tue Feb 06, 2018 10:52 pm

https://github.com/pvaret/rtl8192cu-fixes
This method helped me!!!
Scroll to the word "Installation" and install drivers!!!

These devices are known to work with this driver:

ASUSTek USB-N13 rev. B1 (0b05:17ab)
Belkin N300 (050d:2103)
D-Link DWA-121 802.11n Wireless N 150 Pico Adapter [RTL8188CUS]
Edimax EW-7811Un (7392:7811)
Kootek KT-RPWF (0bda:8176)
OurLink 150M 802.11n (0bda:8176)
TP-Link TL-WN821Nv4 (0bda:8178)
TP-Link TL-WN822N (0bda:8178)
TP-Link TL-WN823N (only models that use the rtl8192cu chip)
TRENDnet TEW-648UBM N150

These devices are known not to be supported:

Alfa AWUS036NHR
TP-Link WN8200ND

Locked

Return to “Wireless”