rtl8723be - hp notebook ac122tu wifi issues

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
rakegks
Level 1
Level 1
Posts: 7
Joined: Thu May 19, 2016 7:24 pm

rtl8723be - hp notebook ac122tu wifi issues

Post by rakegks » Thu May 19, 2016 7:51 pm

Hi everyone!

I have installed linux mint 17.3 rosa on my new hp notebook ac122tu which is having wifi rtl8723be (Dual boot with windows 8.1)

but wifi not working on linux mint, works fine with windows 8.1

it show wifi signal, when i enter password and try to connect it never connects,

some time it shows connected but no internet,it wont ping and websites wont load,

we tried with different routes (home and office routers)

contacted HP support, they told if wifi connect to windows os their is no hardware issues.

and they don't support for linux!

i have already searched, read and even done all suggestions provided for the same issue with rtl8723be wifi, without any success!

it will be great if i get this issue resolved through linuxmint forum!

#waiting for reply#

Thank you

JeremyB
Level 18
Level 18
Posts: 8653
Joined: Fri Feb 21, 2014 8:17 am

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by JeremyB » Fri May 20, 2016 7:33 am

Code: Select all

sudo apt-get install git build-essential
git clone -b rock.new_btcoex https://github.com/lwfinger/rtlwifi_new
cd rtlwifi_new
make
sudo make install
Reboot and then

Code: Select all

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=1
Test wireless, if no change then

Code: Select all

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2
Test wireless again, one or the other should result in better reception

When you find that one works better than the other

Code: Select all

echo "options rtl8723be ant_sel=X fwlps=N" | sudo tee /etc/modprobe.d/rtlbtcoex.conf
Where X is 1 or 2- whatever resulted in better performance then the parameter will be remembered following a restart

rakegks
Level 1
Level 1
Posts: 7
Joined: Thu May 19, 2016 7:24 pm

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by rakegks » Fri May 20, 2016 10:20 am

Hi JeremyB

Now wifi working great, the second option works for me.

sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2

echo "options rtl8723be ant_sel=2 fwlps=N" | sudo tee /etc/modprobe.d/rtlbtcoex.conf

Jeremy Thanks a lot, you are great, i thought this issue will never solve, wifi working like charm now.

one more question, is this settings saved permanently or i need to do it again when i update from update manager.

Thanks once again.

JeremyB
Level 18
Level 18
Posts: 8653
Joined: Fri Feb 21, 2014 8:17 am

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by JeremyB » Fri May 20, 2016 10:26 am

It should work until a kernel update happens which by default is manual only in Linux Mint

rakegks
Level 1
Level 1
Posts: 7
Joined: Thu May 19, 2016 7:24 pm

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by rakegks » Fri May 20, 2016 11:12 am

Okay,

Thank you very much JeremyB

have a great day and best of luck!

GlennJohnson
Level 1
Level 1
Posts: 25
Joined: Mon Dec 07, 2009 7:24 pm
Location: Salem, Mass USA

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by GlennJohnson » Fri May 20, 2016 5:57 pm

Regarding the rtl8723be. I had that same wireless adapter in my Toshiba laptop. I got so tired of the thing dropping the wireless signal and so tired of attempting to "fix" it I finally came upon the ultimate solution. But an Intel adapter on Amazon for $20 USD, replace existing adapter with Intel adapter, toss original adapter into the trash. Problem solved. :D
Glenn
The Bassinator
© ®

rakegks
Level 1
Level 1
Posts: 7
Joined: Thu May 19, 2016 7:24 pm

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by rakegks » Tue Nov 28, 2017 9:05 am

Hi JeremyB

I have reinstalled linux mint 18.3 and when i am tweaking wifi with your code i get below error

after below steps i get error

sudo apt-get install git build-essential
git clone -b rock.new_btcoex https://github.com/lwfinger/rtlwifi_new
cd rtlwifi_new

these 3 steps executed with no issues, but when i enter make i got below error

linuxtechi@linuxtechi-HP-Notebook ~/rtlwifi_new $ make
make -C /lib/modules/4.10.0-38-generic/build M=/home/linuxtechi/rtlwifi_new modules
make[1]: Entering directory '/usr/src/linux-headers-4.10.0-38-generic'
CC [M] /home/linuxtechi/rtlwifi_new/base.o
In file included from /home/linuxtechi/rtlwifi_new/base.c:26:0:
/home/linuxtechi/rtlwifi_new/wifi.h:43:2: error: #error "This branch is abandoned. Please do not use"
#error "This branch is abandoned. Please do not use"
^
scripts/Makefile.build:294: recipe for target '/home/linuxtechi/rtlwifi_new/base.o' failed
make[2]: *** [/home/linuxtechi/rtlwifi_new/base.o] Error 1
Makefile:1524: recipe for target '_module_/home/linuxtechi/rtlwifi_new' failed
make[1]: *** [_module_/home/linuxtechi/rtlwifi_new] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.10.0-38-generic'
Makefile:57: recipe for target 'all' failed
make: *** [all] Error 2
linuxtechi@linuxtechi-HP-Notebook ~/rtlwifi_new $

can you please solve this? waiting for your replay, i can get solutions only from linux mint forum.

JeremyB
Level 18
Level 18
Posts: 8653
Joined: Fri Feb 21, 2014 8:17 am

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by JeremyB » Tue Nov 28, 2017 12:13 pm

You don't need that in LM 18+ because the antenna select parameter is there you just need to find if ant_sel=1 or ant_sel=2 is the better choice

rakegks
Level 1
Level 1
Posts: 7
Joined: Thu May 19, 2016 7:24 pm

Re: rtl8723be - hp notebook ac122tu wifi issues

Post by rakegks » Wed Nov 29, 2017 12:28 am

Hello JeremyB

followed steps from github
https://github.com/lwfinger/rtlwifi_new/issues/258

removed #error line as they suggested, wifi working now

but is that correct way to tweak wifi in LM 18.3?

You don't need that in LM 18+ because the antenna select parameter is there you just need to find if ant_sel=1 or ant_sel=2 is the better choice
-- you mean only need to do last steps?
sudo modprobe -rv rtl8723be
sudo modprobe -v rtl8723be ant_sel=2
echo "options rtl8723be ant_sel=2 fwlps=N" | sudo tee /etc/modprobe.d/rtlbtcoex.conf

Thank you very much!

Post Reply

Return to “Wireless”