Page 1 of 1

Problems with Wi-Fi usb adapter

Posted: Wed Jul 27, 2016 7:33 am
by mprince93
Hello all,
I recently purchased an EdimaxAC1750 Dual-Band Wi-Fi USB 3.0 Adapter an am having a hell of a time getting Mint(18) to recognize/utilize it.

I successfully installed the driver for it (8814au), and have modprobed it as well.

The device itself shows up in lsusb but not in ifconfig.

I've spent hours scouring the web trying to find a solution with no luck.

Could someone please help me out?

Thank you

Re: Problems with Wi-Fi usb adapter

Posted: Wed Jul 27, 2016 7:52 am
by mprince93
Also please forgive me for not posting the inxi -Fxz output. Ive stayed up til 7am troubleshooting the damned thing to no avail. :x Ill post later on today.

Cheers

Re: Problems with Wi-Fi usb adapter

Posted: Wed Jul 27, 2016 10:53 am
by JeremyB
Please post the output for

Code: Select all

lsusb

Re: Problems with Wi-Fi usb adapter

Posted: Wed Jul 27, 2016 12:29 pm
by DEcosse

Re: Problems with Wi-Fi usb adapter

Posted: Wed Jul 27, 2016 3:03 pm
by mprince93
JeremyB wrote:Please post the output for

Code: Select all

lsusb

Code: Select all

$ lsusb
Bus 002 Device 002: ID 5986:0299 Acer, Inc 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 04ca:2007 Lite-On Technology Corp. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 004: ID 7392:a833 Edimax Technology Co., Ltd 
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Re: Problems with Wi-Fi usb adapter

Posted: Wed Jul 27, 2016 3:06 pm
by mprince93
Also, here's the output for inxi -Fxz:

Code: Select all

System:    Host: mprince93-ThinkPad-X140e Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: Cinnamon 3.0.7 (Gtk 3.18.9-1ubuntu3.1)
           Distro: Linux Mint 18 Sarah
Machine:   System: LENOVO product: 20BLCTO1WW v: ThinkPad X140e
           Mobo: LENOVO model: 20BLCTO1WW
           Bios: LENOVO v: GSET61WW (2.06 ) date: 09/26/2014
CPU:       Quad core AMD A4-5000 APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 11977
           clock speeds: max: 1500 MHz 1: 800 MHz 2: 1500 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8330]
           bus-ID: 00:01.0
           Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.02hz
           GLX Renderer: Gallium 0.4 on AMD KABINI (DRM 2.43.0, LLVM 3.8.0)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card-1: Broadcom BCM43142 802.11b/g/n driver: wl bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
Drives:    HDD Total Size: 500.1GB (2.4% used)
           ID-1: /dev/sda model: ST500LM021 size: 500.1GB
Partition: ID-1: / size: 456G used: 8.0G (2%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 3.51GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.9C mobo: 0.0C gpu: 49.0
           Fan Speeds (in rpm): cpu: 597
Info:      Processes: 216 Uptime: 7:51 Memory: 1401.7/3219.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.421) inxi: 2.2.35 

Re: Problems with Wi-Fi usb adapter

Posted: Wed Jul 27, 2016 6:08 pm
by DEcosse
Question - do you see the adapter in your Network Manager, just can't get it to connect?

Seriously, please take a look at the thread I referenced

I just plugged my WiFi adapter into my little notebook (with LM18 "live" stick ) and loaded the driver - same issue as on my NUC
I can SEE the adapter but it just won't connect. Roll back the Network Manage and Bingo.

Your Edimax AC1750 uses similar family of Realtek device to my Asus AC56 .

You're risking nothing to try it - go to synaptic and roll back the Network Manager - you can always move it forward again if need be.
If you don't want to do on your installed set-up, boot your system on the live disk and try it there

Re: Problems with Wi-Fi usb adapter

Posted: Thu Jul 28, 2016 2:19 am
by mprince93
Yes, I read your post. The thing is, when I tried rolling the network manager drivers back and rebooted my system I got the upstart failed "It looks like you were logged in for less than 10 seconds" message. I ended up having to reinstall the OS. I don't know what I did wrong but I'm kinda hesitant to try it again.

I suppose I'll try it with the live CD.

To answer your question about seeing it in Network manager, no it doesn't show up there.

Here's the ifconfig dump:

Code: Select all

ifconfig
enp3s0    Link encap:Ethernet  HWaddr c4:54:44:bf:9d:fb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:888 errors:0 dropped:0 overruns:0 frame:0
          TX packets:888 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:79201 (79.2 KB)  TX bytes:79201 (79.2 KB)

wlp1s0    Link encap:Ethernet  HWaddr 18:cf:5e:01:d3:e7  
          inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::a5d0:5c77:8469:4da7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:89496 errors:0 dropped:0 overruns:0 frame:1201
          TX packets:45574 errors:4770 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:125053531 (125.0 MB)  TX bytes:4140428 (4.1 MB)
          Interrupt:32 
and the modinfo dump:

Code: Select all

modinfo 8814au
filename:       /lib/modules/4.4.0-21-generic/kernel/drivers/net/wireless/8814au.ko
version:        v4.3.21_17997.20160531
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     D177C2A81A82DCE03F0933D
alias:          usb:v7392pA834d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v056Ep400Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v056Ep400Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0B05p1817d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p331Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp8813d*dc*dsc*dp*ic*isc*ip*in*
depends:        cfg80211
vermagic:       4.4.0-21-generic SMP mod_unload modversions 
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           rtw_usb_rxagg_mode:int
parm:           rtw_qos_opt_enable:int
parm:           ifname:The default name to allocate for first interface (charp)
parm:           if2name:The default name to allocate for second interface (charp)
parm:           rtw_rfkfree_enable:int
parm:           rtw_initmac:charp
parm:           rtw_channel_plan:int
parm:           rtw_special_rf_path:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_bw_mode:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_ampdu_amsdu:int
parm:           rtw_vht_enable:int
parm:           rtw_beamform_cap:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_rf_config:int
parm:           rtw_power_mgnt:int
parm:           rtw_smart_ps:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_antdiv_type:int
parm:           rtw_switch_usb_mode:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_hw_wps_pbc:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_mc2u_disable:int
parm:           rtw_80211d:Enable 802.11d mechanism (int)
parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)
parm:           rtw_hiq_filter:0:allow all, 1:allow special, 2:deny all (uint)
parm:           rtw_adaptivity_en:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_mode:0:normal, 1:carrier sense (uint)
parm:           rtw_adaptivity_dml:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_dc_backoff:DC backoff for Adaptivity (uint)
parm:           rtw_adaptivity_th_l2h_ini:TH_L2H_ini for Adaptivity (int)
parm:           rtw_adaptivity_th_edcca_hl_diff:TH_EDCCA_HL_diff for Adaptivity (int)
parm:           rtw_amplifier_type_2g:BIT3:2G ext-PA, BIT4:2G ext-LNA (uint)
parm:           rtw_amplifier_type_5g:BIT6:5G ext-PA, BIT7:5G ext-LNA (uint)
parm:           rtw_RFE_type:default init value:64 (uint)
parm:           rtw_GLNA_type:default init value:0 (uint)
parm:           rtw_TxBBSwing_2G:default init value:0xFF (uint)
parm:           rtw_TxBBSwing_5G:default init value:0xFF (uint)
parm:           rtw_OffEfuseMask:default open Efuse Mask value:0 (uint)
parm:           rtw_FileMaskEfuse:default drv Mask Efuse value:0 (uint)
parm:           rtw_kfree:default kfree config value:0 (uint)
parm:           rtw_rxgain_offset_2g:default RF Gain 2G Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gl:default RF Gain 5GL Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gh:uint
parm:           rtw_rxgain_offset_5gm:default RF Gain 5GM Offset value:0 (uint)
parm:           rtw_pll_ref_clk_sel:force pll_ref_clk_sel, 0xF:use autoload value (uint)
parm:           rtw_tx_pwr_lmt_enable:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_tx_pwr_by_rate:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_phy_file_path:The path of phy parameter (charp)
parm:           rtw_load_phy_file:PHY File Bit Map (int)
parm:           rtw_decrypt_phy_file:Enable Decrypt PHY File (int)

Re: Problems with Wi-Fi usb adapter

Posted: Thu Jul 28, 2016 3:22 am
by mprince93
DEcosse wrote:Question - do you see the adapter in your Network Manager, just can't get it to connect?

Seriously, please take a look at the thread I referenced

I just plugged my WiFi adapter into my little notebook (with LM18 "live" stick ) and loaded the driver - same issue as on my NUC
I can SEE the adapter but it just won't connect. Roll back the Network Manage and Bingo.

Your Edimax AC1750 uses similar family of Realtek device to my Asus AC56 .

You're risking nothing to try it - go to synaptic and roll back the Network Manager - you can always move it forward again if need be.
If you don't want to do on your installed set-up, boot your system on the live disk and try it there
I did as you said. Rolled back the driver (although I couldn't get network-manager-gnome to roll back for some reason) and it still doesn't recognize it. The usb dongle's light won't turn on, and it doesn't show up in ifconfig.

Re: Problems with Wi-Fi usb adapter

Posted: Thu Jul 28, 2016 5:35 am
by JeremyB
Where did you find that driver? It may be possible to change the source code so that it will support your device

Re: Problems with Wi-Fi usb adapter

Posted: Tue Dec 06, 2016 12:33 am
by sbosshardt
mprince93 wrote:
JeremyB wrote:Please post the output for

Code: Select all

lsusb

Code: Select all

$ lsusb
Bus 002 Device 002: ID 5986:0299 Acer, Inc 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 04ca:2007 Lite-On Technology Corp. 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 004: ID 7392:a833 Edimax Technology Co., Ltd 
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Based on your lsusb output, you seem to be having the problem I was. The driver is missing the vendor/product id entry. I posted a solution to this problem in another thread. If you are still having the problem, you may want to check the thread out.

Edit: changed hyperlink so that it goes directly to my post

Problems with Wi-Fi usb adapter

Posted: Sat Mar 23, 2019 1:15 am
by informel
I had a Edimax AC1750 USB WIFI adaptor that was working fine with LM. Then it stop working after a reboot and it would not work anymore

lsusb would show the device so device was recognise, driver did not load for some reason.

ifconfig would not show anything, so problem does seem to point to a driver not laoded

I started by removing averything with the following

dkms remove rtl8814au/4.3.21 --all
rm -rf /usr/src/rtl8814au-4.3.21
rm -rf rtl8814AU
reboot

then I re-installed everything following info on this page:
https://edimax.freshdesk.com/support/so ... -than-v4-4

Re: Problems with Wi-Fi usb adapter

Posted: Mon Mar 25, 2019 5:17 pm
by JeremyB
I use my own driver I forked and added dkms too as some dkms.conf files on github are broken, https://github.com/jeremyb31/rtl8814AU
If you are using any source code from github and it fails after a kernel update, check the dkms.conf file and see if it has

Code: Select all

MAKE="'make'"
If it does replace with

Code: Select all

MAKE="'make' all KVER=${kernelver}"
You can do it in /usr/src/rtl8814au-4.3.21/dkms.conf before a kernel update to save some time