[SOLVED] Network-manager/Wireless issue on Linux Mint 18

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
User avatar
Moem
Level 17
Level 17
Posts: 7211
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Post by Moem » Wed Mar 07, 2018 5:38 pm

Ernesto R518 wrote:
Wed Mar 07, 2018 5:20 pm
sudo <your text editor> /etc/NetworkManager/NetworkManager.conf
That should be gksudo since your text editor is a graphical application. Using sudo for graphical applications will land you in hot water with regards to permissions, sooner or later.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

polaatx2
Level 1
Level 1
Posts: 10
Joined: Sat Jun 18, 2016 1:02 pm

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Post by polaatx2 » Sat Mar 24, 2018 1:06 pm

Hello,

Related to this issue: when I disabled Bluetooth on my mint 18.3, I also lost wifi! None of the available wifi connections no longer appeared. Possible to add connection manually, but would not connect. When I enabled Bluetooth, WiFi immediately returned.

monsterman
Level 1
Level 1
Posts: 35
Joined: Sun Jan 14, 2018 11:43 pm

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Post by monsterman » Sun Mar 25, 2018 3:02 pm

i also find that 2 out of 5 logins the network manager does not connect to my wifi i have to shutdown both router and laptop and it then works but its so frustrating

is there a default cure for thsi issue in Mint 18.3

JeremyB
Level 19
Level 19
Posts: 9450
Joined: Fri Feb 21, 2014 8:17 am

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Post by JeremyB » Sun Mar 25, 2018 3:27 pm

monsterman wrote:
Sun Mar 25, 2018 3:02 pm
i also find that 2 out of 5 logins the network manager does not connect to my wifi i have to shutdown both router and laptop and it then works but its so frustrating

is there a default cure for thsi issue in Mint 18.3
You should start a new topic for your issue and include results for the wireless script link in my signature

JohannvL
Level 1
Level 1
Posts: 1
Joined: Sat Apr 28, 2018 2:14 pm

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Post by JohannvL » Sun Apr 29, 2018 2:51 pm

I've read the thread and the common cause seems to be a bug in the power management implemantation that causes the connection to drop.

I can't claim credit for the solution below , but i have tested it and found it worked for my wifi adapter (TPLINK WN823N with a Realtek RTL8192CU chipset) . Unfortunately I haven't been able to find the original posting.

This will require a recompile of the RTL8192CU driver (detailed guide below)
==============
Step by step guide
==============

Ensure you have the necessary prerequisites:

Code: Select all

	sudo apt-get install linux-headers-generic build-essential dkms
Install "git" if it isn't installed yet. You'll need it for the next command.

Code: Select all

    sudo apt-get install git
Clone this git repository:(it will create "rtl8192cu-fixes" subdirectory in you $HOME directory )

Code: Select all

	git clone https://github.com/pvaret/rtl8192cu-fixes.git
Set it up as a DKMS module:

Code: Select all

	sudo dkms add ./rtl8192cu-fixes
Build and install it (this version number may change, it is .11 in the package I installed.
(Check the PACKAGE_VERSION entry in $HOME/rtl8192cu-fixes/dkms.conf)

Code: Select all

    sudo dkms install 8192cu/1.11
Refresh the module list:

Code: Select all

	sudo depmod -a
Ensure the native (and broken) kernel driver is blacklisted: (this item disables powersaving for the RTL8192CU adapter)

Code: Select all

	sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/
And reboot. You're done.


With the following terminal command you can check whether the right driver is active now (copy and paste it into the terminal):

Code: Select all

  lsmod | grep 8192

============
The network driver update above works. There is another alternative as well but I haven't tested it:
If github is your thing then these guys also have a driver that is up-to-date with patches:
=> https://github.com/Mange/rtl8192eu-linux-driver
============

## Background ##
=========
Realtek rtl8192cu wireless dongle (TP-Link TL-WIN823N)
--------
The TL-WN823N WLAN USB stick bases on the Realtek chip set RTL8192CU and provides a transmission rate up to 300Mbps.

The TL-WN823N is recognized by the kernel with the USB ID 0bda:8178:

Code: Select all

lsusb
1	Bus 001 Device 006: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter


However, the stick is not fully supported by the kernel module rtl8192cu that is used by Ubuntu 12.10, e.g. the connection drops regularly. To prevent this behaviour one has to add the following module options in the file /etc/modprobe.d/rtl8192cu.conf to disable the hardware encryption and use software based encryption instead:
/etc/modprobe.d/rtl8192cu.conf
1 options rtl8192cu swenc=1
Realtek Module 8192cu

It is recommended to replace the standard driver by the original Realtek drivers 8192cu. If the Realtek driver is used instead of the module which is part of the standard kernel, the automatic loading of the kernel module has to be inhibited. To achieve this, the rtl8192cu driver provided by the standard kernel has to be blacklisted in the file /etc/modprobe.d/blacklist.conf by adding the following line:
1 blacklist rtl8192cu

The module from the Realtek homepage is called 8192cu and has to be compiled by hand. Under Ubuntu compiladmesg\tion will need the build-essentials to be installed:
1 sudo apt-get install build-essential

Compilation will be achieved by the install script that is part of the downloaded file:
1

sudo sh install.sh

The compiled driver can be loaded by the command
1 sudo modprobe 8192cu

Due to a bug in the power management of the 8192cu driver the connection can drop if the device is set to power save mode. This can be seen in the log files:
dmesg
1
2
3
4
5
6

rtl8192c_dm_RF_Saving(): RF_Normal
rtl8192c_set_FwPwrMode_cmd(): Mode = 1, SmartPS = 2
rtw_set_ps_mode(): Busy Traffic , Leave 802.11 power save..
rtl8192c_set_FwPwrMode_cmd(): Mode = 0, SmartPS = 0
rtl8192c_dm_RF_Saving(): RF_Save
rtw_set_ps_mode(): Enter 802.11 power save mode...

To prevent the power save mode one has to add the following module options in the file /etc/modprobe.d/8192cu.conf:
/etc/modprobe.d/8192cu.conf
1

options 8192cu rtw_power_mgnt=0 rtw_enusbss=0
creation date: 21/04/2013, last update: 06/12/2014 , Linux-Hardware-Guide

## END ##

redpinkoZ1917
Level 1
Level 1
Posts: 1
Joined: Sun Dec 09, 2018 11:22 pm

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Post by redpinkoZ1917 » Sun Dec 09, 2018 11:28 pm

Ernesto R518 wrote:
Wed Mar 07, 2018 5:20 pm
I know this is marked as "Solved', but my 2 cents:
System:
Lenovo IdeaCentre 720-18ASU Desktop
Realtek RTL8821AE 02.11ac PCIe Wireless Network Adapter
Linux Mint 18.3 Cinnamon Edition 64-bit.

I was having the same issue as you; Wifi would connect, then less than a couple minutes later, quit. Restarting Network Manager did not work.I tried some of the other recommendations here (installing WICD, removing Network Manager), which killed Cinnamon. It was a fresh install, so I reinstalled (I had some other changes to make, anyway) and once back up, did a little more digging. On another forum, I found this, [re : network manager issue in 18.1], and it worked perfectly.

"...edit /etc/NetworkManager/NetworkManager.conf and change dns=dnsmasq to #dns=dnsmasq."

sudo <your text editor> /etc/NetworkManager/NetworkManager.conf

There's not much there:

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

---

changed, saved, and rebooted. I've been on for a couple of hours already, no problems.
I just wanted to chime in incase anyone like me was scouring the internet to solve this issue.

I have the rt8812au driver, and after deleting cinnamon on accident like those above, I tried this quoted solution and it worked perfectly for me. No more erratic wifi. The only thing I have to add is that there was no "dns=dnsmasq" option existing in the .conf for me, so I added "#dns=dnsmasq" right below "plugins=ifupdown,keyfile,ofono" with vim editor, saved, and then did "sudo systemctl restart NetworkManager".

No more wifi issues, and the network manager works like its supposed to now.

Thanks to the wonderful community!

Post Reply

Return to “Wireless”