Page 1 of 2

[SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Thu Sep 29, 2016 4:55 am
by Cassoulet
Hi everybody, I'm new here and, well I'm also seeking for help :o

I recently installed Linux Mint 18 on my laptop just two days ago (first linux experience) but because of a booting issue, I had to reinstall it again yesterday.

The networking was working flawlessly on my first install when I used the software switch (right clicking the wifi icon and click "enable networking") to switch on/off the wireless connection. This feature is really important for me because I use it a lot in college so I can save battery life. The only annoying thing was that the bluetooth networking was set "on" by default on every startup, which I had to manually switch off every time.

However since I reinstalled Mint yesterday, I seem to have a network manager issue. On boot, the wifi seems to work perfectly: I have four black bars icon in the toolbar and right-clicking shows all wifi networks available in the surroundings. However, when I switch wifi off then back on, the available wifi networks list shows empty (or only one network shows up) but my computer still automatically connects to my home's network which is already registered.
Strangely, the icon on the toolbar shows the wired connection icon and not the wireless icon (or sometimes it shows the wireless one with four empty bars, but I still can surf).

After switching on/off several times, the wifi eventually shows "device not ready" and doesn't even connect to my network. I have to restart the computer to make it work. However, one strange thing is that the bluetooth is actually disabled on boot if I didn't use it which is nice and not automatically enabled like on my first install.

This issue is particularly strange since I didn't have it on my first Mint install, which was identical: the only difference in installation is that I was connected to the wifi during the installation the second time which may have downloaded some softwares.

I have fully updated my computer. I don't really know about the drivers, my wifi card is an Intel Dual Band Wireless-AC 3160 and i have downloaded their linux driver and put the "iwlwifi-3160-14.ucode" in /lib/firmware. Didn't seem to do anything. My driver manager only shows my CPU and nothing else so I can't configure my wireless drivers. Anyways, didn't seem to have changed anything.

For now, if I use

Code: Select all

sudo service network-manager restart
the wifi service network restarts and I can actually switch my wifi on/off flawlessly, like in my first install, until I reboot.[/b]

Anyways, thank you for reading, I will put some images if it is not clear enough :D

And sorry if my grammar is kind of broken, I'm not native English speaker.

Re: Network-manager Service issue on Linux Mint 18 XFCE

Posted: Thu Sep 29, 2016 5:44 am
by JeremyB
You may want to install updates using the Update Manager as there were a few bugs in Network Manager

Re: Network-manager Service issue on Linux Mint 18 XFCE

Posted: Thu Sep 29, 2016 4:01 pm
by Cassoulet
I have already installed all the updates from the update manager. Is there a way to reinstall the network-manager by any means ?

Re: Network-manager Service issue on Linux Mint 18 XFCE

Posted: Thu Sep 29, 2016 5:36 pm
by JeremyB
Can you post the results for

Code: Select all

dpkg -l | grep network-manager
Then I can compare to my LM18 and Ubuntu 16.04 computers and see if there are any differences.

This is a really strange bug if you only saw it on your second install as I have 4 laptops running LM or Ubuntu and haven't encountered it once although it is possible that the Update Manager places the Network Manager packages as level 4 or 5

Re: Network-manager Service issue on Linux Mint 18 XFCE

Posted: Fri Sep 30, 2016 5:43 am
by Cassoulet
Okay here are the results from the terminal.

Code: Select all

 ~ $ dpkg -l | grep network-manager
ii  network-manager                              1.2.2-0ubuntu0.16.04.1                     amd64        network management framework (daemon and userspace tools)
ii  network-manager-gnome                        1.2.0-0ubuntu0.16.04.4                     amd64        network management framework (GNOME frontend)
ii  network-manager-openvpn                      1.1.93-1ubuntu1                            amd64        network management framework (OpenVPN plugin core)
ii  network-manager-openvpn-gnome                1.1.93-1ubuntu1                            amd64        network management framework (OpenVPN plugin GNOME GUI)
ii  network-manager-pptp                         1.1.93-1ubuntu1                            amd64        network management framework (PPTP plugin core)
ii  network-manager-pptp-gnome                   1.1.93-1ubuntu1                            amd64        network management framework (PPTP plugin GNOME GUI)
Yesterday in college, I used my laptop to connect to the Public wifi network and surprisingly, everything worked flawlessly, I could switch on/off without any problem. Back home, I thought the problem solved... and for 2 or 3 sessions indeed I had no problems but after a while when opening a new session the problem reappeared.

It seems that the network manager has some troubles activating my wireless card or something like that: if I switch off then wait a long time, there are chances that it works perfectly (shows all the networks available and connects to my domestic network), it I wait a little bit less it just connects to my wifi but doesn't show the networks in the surroundings and the icon is an empty bar wifi icon, if I wait even less time it still connects to my wifi but now shows the wired (ethernet) icon. Eventually if I switch on/off several times quickly, it just shows me "device not ready" and doesn't connect to anything (previously, if it didn't show anything I could connect to my network as a hidden network but no way to connect while in "device no ready").

Something really strange is that sometimes my wireless network in "Edit connections" menu shows like " *ssid name* 1 " as if there were 2 connections in with the same name so the manager added a "1" after the network's name. Maybe because I switched on/off too fast I don't really know.

As I previously said, I binded to a hotkey :

Code: Select all

service network-manager restart
Using it right after booting without switching on/off makes my network-manager working flawless. Using it after encountering any issue also corrects the problem.

Lastly, I installed all the updated, whether on my first or my current install (even the level 4 and 5 ones) and still had no issue on my first install.

Anyways, thanks for your support and eager to help :D

Re: Network-manager Service issue on Linux Mint 18 XFCE

Posted: Sat Oct 01, 2016 5:56 am
by Cassoulet
Hi there. I found a solution to my problem ! I just downloaded "WICD", an alternate network manager that works just fine no problem at all. I proceeded as explained on this website : https://help.ubuntu.com/community/WICD .

Thank you four your support :D

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Sun Oct 02, 2016 12:54 am
by bush5150
I tried this to resolve my issues... It stripped out Cinnamon completely!!!
Be very very careful.

I got THIS ISSUE by following the WICD instructions. When I rebooted my computer, it would boot to the login screen. I could enter my password and hit enter, the screen would go black and take me back to the login screen. A never-ending loop of login screens. :evil: :evil: :evil:

What happens for Cinnamon users is that running:

Code: Select all

sudo apt-get remove --purge network-manager network-manager-gnome
produces:

Code: Select all

The following packages are going to be removed: cinnamon* mint-meta-cinnamon* network-manager* network-manager-gnome*

:evil: :evil: :evil: :evil: :evil:

The only fix is to reboot in restore mode as root and follow the instructions in the above link using command line. Note: this will reinstall network-manager, too. :x

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Fri Feb 03, 2017 2:52 pm
by jackri
I've got exactly the same problem as bush5150 : I can't switch from network-manager to wicd.
When I try to remove network-manager (sudo apt remove network-manager), as soon as I want to close / re-enter in my session, Mint bugs (black screen) and finally re-direct me to login (a never-ending loop)...
And to solve the problem I have to do a sudo apt install cinnammon and it reinstalls only some packages (like cinammon-network or something) and then everything works again but network-manager is reinstalled.

I tried quite a lot of things : systemctl disable NetworkManager.service (doesnt change anything) OR sudo apt remove network-manager-gnome (same problem as sudo apt remove network-manager).

Another thing I noticed is after installing wicd (while I still had network-manager), both were working (network-manager and wicd). If I turn off wifi via the network-manager then wicd got disconnected. Then if I try to connect to wifi via wicd I can do it and it got connected (but not in the network-manager) and it was impossible to access internet (via firefox or ping command) like if wicd doesnt "spread it to the system". After this step, if I tried to connect with network-manager it screens a weird error message : "Client 802.1x is not ready" or something.
Once I purged wicd and restarted network-manager, it was possible to turn on wifi and get connected.

I really need to solve this problem (replace network-manager by wicd) because I've got an annoying wifi problem. As weird as it can seem, network-manager is maybe causing problems to my wifi (randomly turned off and unresponsive) (rtl8821ae driver is causing many problems : https://github.com/lwfinger/rtlwifi_new/issues).

Well, if you can help me, if you have any idea or place where I can find the appropriate helps, I'd appreciate !

PS : Im not used with forum, maybe it's better to create an other topic ?

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Tue Mar 14, 2017 4:24 pm
by mlacons
I don't know why this is marked [SOLVED] as it seems that isn't the case.
I am having the very same problems using a Lenovo G50-45 laptop. The internet gets slower to the point where I restart network-manager and it fine again for a while.
I'm guessing there's a memory but in network-manager but what do I know.
BTW, to the original poster, your English was so good I find myself being careful not to screw up, being an native speaker and all.

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Tue Mar 14, 2017 4:45 pm
by JeremyB
I would try

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Reboot and see if disabling power management for wifi fixes it

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Wed Mar 15, 2017 4:43 pm
by mlacons
Thanks Jeremy for the response but it made no difference

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Wed Mar 15, 2017 9:17 pm
by hunkerdunker
Have the same problem with Lenovo 110S

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Thu Mar 23, 2017 5:22 am
by zentoo
Same problem here but since it was for a reinstall for someone else that need to leave far away quickly I've got to find a temporary proper solution.
I hope future updates will fix this really annoying bug.

So my solution:

Code: Select all

sudo echo 'ALL ALL = NOPASSWD: /usr/bin/service network-manager restart' > /etc/sudoers.d/fix
sudo chmod 440 /etc/sudoers.d/fix
mkdir ~/.scripts
echo -e '#!/bin/bash\nsleep 10 && sudo /usr/sbin/service network-manager restart' > ~/.scripts/fix.sh
chmod +x ~/.scripts/fix.sh
Then you have to launch the script "~/.scripts/fix.sh" when the session start.
On mate version, I've added this script in Menu/Preferences/Start Up Applications.
Reboot and enjoy.

I'm sure there is a way to do it better directly by creating a .desktop file in /etc/xdg/autostart/ but I haven't time to try it since the computer is already away now.

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Sat Mar 25, 2017 3:07 am
by massasauga
Here is what worked for me:

1. Run the following command from a terminal window.

Code: Select all

/etc/init.d/network-manager force-reload
A password dialog box will appear.
2. Type your password.
3. Launch your browser, your email client, your FTP client, or any program that you use that requires internet access.

If the above worked, you can also set this up as a simple script that resides in your home directory:

Code: Select all

!#/bin/bash
# This forces your ethernet connection to reconnect to the internet.
/etc/init.d/network-manager force-reload
Don't forget to make this an executable script after you create it.

You can create a desktop launcher for the script with an icon to click on for convenience. It will display a password dialog when it runs.
You will need to run the script every time you boot, but I think it will work. It has been working for me.

Gregg

P.S.
I have been trying to figure out how to get this to run automatically when you boot. I think one of the updates changed how the network scripts install at boot time and caused this to break.

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Fri May 05, 2017 2:24 am
by Bebs
Hi!
I had the same problem.
The trick was to uninstall and reinstall network-manager with this command:

Code: Select all

sudo apt-get install -d --reinstall network-manager network-manager-gnome 

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Thu Jun 01, 2017 9:29 am
by xavierx
Any solution for this?
I have the same problem....
In the past i have mint with plasma and in plasma if i uninstall the network manager there is not problem.. but in cinnamon if i uninstall the network manager i receive the same error as described below...

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Sun Nov 19, 2017 8:01 pm
by careman71
I've been pounding my head against this problem since I started using Mint back in May-2017. I'm running 18.1 on a Clevo laptop with discrete NVIDIA graphics and a Realtek wifi adapter. I've consistently experienced network slowdown and dropouts, while showing that I was still connected to the router with a strong signal. Restarting network-manager would sometimes help, but sometimes nothing less than a hard reboot (after removing the battery and power plug) would restore connectivity. When connectivity dropped out, I could reach nothing on the network, including the router IP itself. It's not the router, other devices work perfectly when this issue arises.

My solution comes from here: http://seyferseed.ru/en/life-en/ubuntu- ... d-fix.html. I found this by googling around using my wifi driver (same as his).

It boils down to this:

Code: Select all

sudo modprobe -rv rtl8723ae
sudo modprobe -v rtl8723ae swenc=1 ips=0 fwlps=0
He also includes instructions to add the configuration to modprobe.d so that it will persist after reboot.

It's been about 48 hours since I applied these modified params to my wifi driver. I have experienced no dropouts or reduction in bandwidth. Hopefully this will help someone out. I'll update here if I have any further problems.

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Thu Jan 04, 2018 2:38 pm
by ivanski-msk
Cheers to all!
I've wasted soooo much time trying to figure this out. This NetworkManager Wireless probelem is indeed a b****.

I got a Lenovo Ideapad 110 Laptop with Realtec 8821ae Wifi adapter onboard. OS - linux Mint Cinnamon 18.3. Network Manager has a hard time working with my adapter - connection dies rather often for no apparent reason. And when I tried installing WICD and remove NM - Cinnamon crashed. Only after that I found out that NM deinstallation triggers deisnstallation of some core components of Cinnamon.

So what I did - I installed WICD and just disabled the NM like so:

Code: Select all

$ sudo systemctl stop NetworkManager.service
$ sudo systemctl disable NetworkManager.service
(source where I found this: http://xmodulo.com/disable-network-manager-linux.html)

after enablining the WICD (wicd-gtk) and rebooting - all seems to work fine. WICD seems to have helped. However, I'll see how it goes further...
Anyway I hope this post can help some of the other inexperienced Mint users like myself.

Best wishes from Russia!

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Wed Jan 17, 2018 11:26 pm
by sheller
ivanski-msk fix just above my reply worked out great for me. Its been 48 hours and not issues with my wireless disabling randomly. Thank you.

Re: [SOLVED] Network-manager/Wireless issue on Linux Mint 18

Posted: Wed Mar 07, 2018 5:20 pm
by Ernesto R518
I know this is marked as "Solved', but my 2 cents:
System:
Lenovo IdeaCentre 720-18ASU Desktop
Realtek RTL8821AE 02.11ac PCIe Wireless Network Adapter
Linux Mint 18.3 Cinnamon Edition 64-bit.

I was having the same issue as you; Wifi would connect, then less than a couple minutes later, quit. Restarting Network Manager did not work.I tried some of the other recommendations here (installing WICD, removing Network Manager), which killed Cinnamon. It was a fresh install, so I reinstalled (I had some other changes to make, anyway) and once back up, did a little more digging. On another forum, I found this, [re : network manager issue in 18.1], and it worked perfectly.

"...edit /etc/NetworkManager/NetworkManager.conf and change dns=dnsmasq to #dns=dnsmasq."

sudo <your text editor> /etc/NetworkManager/NetworkManager.conf

There's not much there:

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

---

changed, saved, and rebooted. I've been on for a couple of hours already, no problems.