Page 1 of 1

Bluetooth does not work

Posted: Fri Feb 10, 2017 7:28 am
by RO-mix
BT stopped to work after firmware update.
-------
ls /lib/firmware/ar3k
1020201coex AthrBT_0x11020100.dfu ramps_0x01020200_26.dfu ramps_0x11020100_40.dfu
AthrBT_0x01020001.dfu AthrBT_0x31010000.dfu ramps_0x01020200_40.dfu ramps_0x31010000_40.dfu
AthrBT_0x01020200.dfu AthrBT_0x31010100.dfu ramps_0x01020201_26.dfu ramps_0x31010100_40.dfu
AthrBT_0x01020201.dfu AthrBT_0x41020000.dfu ramps_0x01020201_40.dfu ramps_0x41020000_40.dfu
AthrBT_0x11020000.dfu ramps_0x01020001_26.dfu ramps_0x11020000_40.dfu
------------
$ lsusb
Bus 002 Device 002: ID 8087:8000 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8008 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 2109:8110 VIA Labs, Inc. Hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 007: ID 04f2:b414 Chicony Electronics Co., Ltd
Bus 003 Device 012: ID 13d3:3472 IMC Networks
Bus 003 Device 011: ID 046d:c24b Logitech, Inc.
Bus 003 Device 010: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 008: ID 1058:107c Western Digital Technologies, Inc. Elements Desktop (WDBWLG)
Bus 003 Device 006: ID 05e3:0610 Genesys Logic, Inc. 4-port hub
Bus 003 Device 004: ID 2109:2811 VIA Labs, Inc. Hub
Bus 003 Device 003: ID 0424:3fb9 Standard Microsystems Corp.
Bus 003 Device 009: ID 0b05:17fd ASUSTek Computer, Inc.
Bus 003 Device 002: ID 046d:c07d Logitech, Inc.
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

---------------
$ dmesg | egrep -i 'blue|firm'
[ 1.632179] psmouse serio4: elantech: assuming hardware version 4 (with firmware version 0x360f06)
[ 30.810760] Bluetooth: Core ver 2.21
[ 30.810775] Bluetooth: HCI device and connection manager initialized
[ 30.810778] Bluetooth: HCI socket layer initialized
[ 30.810780] Bluetooth: L2CAP socket layer initialized
[ 30.810785] Bluetooth: SCO socket layer initialized
[ 36.485218] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 36.485220] Bluetooth: BNEP filters: protocol multicast
[ 36.485223] Bluetooth: BNEP socket layer initialized
[ 55.523065] Bluetooth: RFCOMM TTY layer initialized
[ 55.523071] Bluetooth: RFCOMM socket layer initialized
[ 55.523075] Bluetooth: RFCOMM ver 1.11

------------------

$ systemctl status bluetooth
● bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2017-02-10 14:27:44 MSK; 8s ago
Docs: man:bluetoothd(8)
Main PID: 7675 (bluetoothd)
Status: "Running"
CGroup: /system.slice/bluetooth.service
└─7675 /usr/lib/bluetooth/bluetoothd

Feb 10 14:27:44 ram-console systemd[1]: Starting Bluetooth service...
Feb 10 14:27:44 ram-console bluetoothd[7675]: Bluetooth daemon 5.37
Feb 10 14:27:44 ram-console systemd[1]: Started Bluetooth service.
Feb 10 14:27:44 ram-console bluetoothd[7675]: Starting SDP server
Feb 10 14:27:44 ram-console bluetoothd[7675]: Bluetooth management interface 1.10 initialized

Feb 10 16:32:52 ram-console bluetoothd[1895]: gatt-time-server: Input/output error (5)
Feb 10 16:32:52 ram-console bluetoothd[1895]: Not enough free handles to register service
Feb 10 16:32:52 ram-console bluetoothd[1895]: Not enough free handles to register service
Feb 10 16:32:52 ram-console bluetoothd[1895]: Sap driver initialization failed.
Feb 10 16:32:52 ram-console bluetoothd[1895]: sap-server: Operation not permitted (1)
Feb 10 13:33:24 ram-console bluetoothd[1895]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/
Feb 10 13:33:24 ram-console bluetoothd[1895]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/
Feb 10 13:39:58 ram-console bluetoothd[1895]: Endpoint unregistered: sender=:1.42 path=/MediaEndpoin
Feb 10 13:39:58 ram-console bluetoothd[1895]: Endpoint unregistered: sender=:1.42 path=/MediaEndpoin
Feb 10 13:57:55 ram-console systemd[1]: Started Bluetooth service.
---------------

ON BOOT:

bluetoothd[1895]: Failed to obtain handles for "Service Changed" characteristic

Cannot get it working ....