[SOLVED] Stumped! Wifi stopped working - device not ready

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

[SOLVED] Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Hi all, restarted and enabled/disabled the wifi on my laptop running Mint 18.1 MATE several times using the Function key combo, as well as running the 'sudo service network- manager restart' command many times, but wifi doesn't work now and always says device not ready...?

Any ideas what is going on? Laptop is an HP Envy Touchsmart 14.

Thanks for any help!

EDIT - iwconfig reports:

Code: Select all

lo        no wireless extensions.

wlo1      IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          
eno1      no wireless extensions.
I've also tried disabling Power Management on the WiFi to no effect...

inxi -Nn output:

Code: Select all

Network:   Card-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe driver: rt2800pci
           IF: wlo1 state: down mac: 80:56:f2:34:08:99
           Card-2: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: eno1 state: up speed: 100 Mbps duplex: full
           mac: a0:48:1c:27:0c:31
Output of JeremyB's Wireless Info script:

Code: Select all

########## wireless info START ##########

Report from: 17 Jun 2017 12:44 ADT -0300

Booted last: 17 Jun 2017 00:00 ADT -0300

Script from: 25 Mar 2017 07:04 UTC +0000

##### release ###########################

Distributor ID:	LinuxMint
Description:	Linux Mint 18.1 Serena
Release:	18.1
Codename:	serena

##### kernel ############################

Linux 4.4.0-79-generic #100-Ubuntu SMP Wed May 17 19:58:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

MATE

##### lspci #############################

01:00.0 Network controller [0280]: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe [1814:3290]
	DeviceName: Ralink RT3290LE 802.11bgn Wi-Fi Adapter
	Subsystem: Hewlett-Packard Company Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter [103c:18ec]

05:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
	DeviceName: Realtek PCIe FE Family Controller
	Subsystem: Hewlett-Packard Company RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [103c:216d]

##### lsusb #############################

Bus 002 Device 002: ID 04f2:b3a6 Chicony Electronics Co., Ltd 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 002: ID 0eef:a107 D-WAV Scientific Co., Ltd 
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

##### lsmod #############################

rt2800pci              16384  0
rt2800mmio             20480  1 rt2800pci
rt2800lib              94208  2 rt2800pci,rt2800mmio
rt2x00pci              16384  1 rt2800pci
rt2x00mmio             16384  2 rt2800pci,rt2800mmio
rt2x00lib              57344  5 rt2x00pci,rt2800lib,rt2800pci,rt2800mmio,rt2x00mmio
mac80211              737280  3 rt2x00lib,rt2x00pci,rt2800lib
hp_wmi                 16384  0
cfg80211              565248  2 mac80211,rt2x00lib
sparse_keymap          16384  1 hp_wmi
eeprom_93cx6           16384  1 rt2800pci
crc_ccitt              16384  1 rt2800lib
wmi                    20480  1 hp_wmi

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

eno1      Link encap:Ethernet  HWaddr <MAC 'eno1' [IF1]>  
          inet addr:192.168.1.113  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::f7f9:27ac:7703:636f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6685 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4481612 (4.4 MB)  TX bytes:1507272 (1.5 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:557 errors:0 dropped:0 overruns:0 frame:0
          TX packets:557 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:55306 (55.3 KB)  TX bytes:55306 (55.3 KB)

wlo1      Link encap:Ethernet  HWaddr <MAC 'wlo1' [IF2]>  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

##### iwconfig ##########################

lo        no wireless extensions.

eno1      no wireless extensions.

wlo1      IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 eno1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eno1
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 eno1

##### resolv.conf #######################

nameserver 127.0.1.1

##### network managers ##################

Installed:

	NetworkManager

Running:

root      1842     1  0 12:42 ?        00:00:00 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         eno1
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               rtl8106e-1_0.0.1 06/29/12
GENERAL.HWADDR:                         <MAC 'eno1' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:02.3/0000:05:00.0/net/eno1
GENERAL.IP-IFACE:                       eno1
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     Wired connection 1
GENERAL.CON-UUID:                       af87fc2e-69b8-35aa-8412-57938c4b9373
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/0
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     100 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
WIRED-PROPERTIES.CARRIER:               on
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{13}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   af87fc2e-69b8-35aa-8412-57938c4b9373 | Wired connection 1
IP4.ADDRESS[1]:                         192.168.1.113/24
IP4.GATEWAY:                            192.168.1.1
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             192.168.1.1
DHCP4.OPTION[1]:                        requested_ms_classless_static_routes = 1
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_time_offset = 1
DHCP4.OPTION[4]:                        requested_domain_name = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_broadcast_address = 1
DHCP4.OPTION[7]:                        host_name = Lap_Darkstrike
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        requested_netbios_scope = 1
DHCP4.OPTION[10]:                       next_server = 192.168.1.1
DHCP4.OPTION[11]:                       expiry = 1497800558
DHCP4.OPTION[12]:                       requested_interface_mtu = 1
DHCP4.OPTION[13]:                       requested_subnet_mask = 1
DHCP4.OPTION[14]:                       routers = 192.168.1.1
DHCP4.OPTION[15]:                       dhcp_message_type = 5
DHCP4.OPTION[16]:                       ip_address = 192.168.1.113
DHCP4.OPTION[17]:                       broadcast_address = 192.168.1.255
DHCP4.OPTION[18]:                       requested_static_routes = 1
DHCP4.OPTION[19]:                       dhcp_renewal_time = 43200
DHCP4.OPTION[20]:                       requested_domain_name_servers = 1
DHCP4.OPTION[21]:                       requested_routers = 1
DHCP4.OPTION[22]:                       domain_name_servers = 192.168.1.1
DHCP4.OPTION[23]:                       requested_ntp_servers = 1
DHCP4.OPTION[24]:                       dhcp_lease_time = 86400
DHCP4.OPTION[25]:                       dhcp_rebinding_time = 75600
DHCP4.OPTION[26]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[27]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[28]:                       network_number = 192.168.1.0
DHCP4.OPTION[29]:                       requested_host_name = 1
DHCP4.OPTION[30]:                       dhcp_server_identifier = 192.168.1.1
IP6.ADDRESS[1]:                         fe80::f7f9:27ac:7703:636f/64
IP6.GATEWAY:                            

GENERAL.DEVICE:                         wlo1
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Ralink corp.
GENERAL.PRODUCT:                        RT3290 Wireless 802.11n 1T/1R PCIe (Ralink RT3290LE 802.11bgn 1x1 Wi-Fi and Bluetooth 4.0 Combo Adapter)
GENERAL.DRIVER:                         rt2800pci
GENERAL.DRIVER-VERSION:                 4.4.0-79-generic
GENERAL.FIRMWARE-VERSION:               0.37
GENERAL.HWADDR:                         <MAC 'wlo1' [IF2]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          20 (unavailable)
GENERAL.REASON:                         2 (Device is now managed)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:02.2/0000:01:00.0/net/wlo1
GENERAL.IP-IFACE:                       
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   no
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: 

SSID  BSSID  MODE  CHAN  FREQ  RATE  SIGNAL  BARS  SECURITY  ACTIVE  * 

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/SSRSB_Wireless]] (600 root)
[connection] id=SSRSB_Wireless | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=SSRSB_Wireless
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/The_Watchtower]] (600 root)
[connection] id=The_Watchtower | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=The_Watchtower
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/SSRSB_Wireless 1]] (600 root)
[connection] id=SSRSB_Wireless 1 | type=wifi | autoconnect=false | permissions=
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=SSRSB_Wireless
[ipv4] method=shared
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Cisco13923]] (600 root)
[connection] id=Cisco13923 | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=Cisco13923
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/The_Watchtower 1]] (600 root)
[connection] id=The_Watchtower 1 | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC 'wlo1' [IF2]> | mac-address-blacklist= | ssid=The_Watchtower
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Samsung Galaxy Core 5765]] (600 root)
[connection] id=Samsung Galaxy Core 5765 | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=Samsung Galaxy Core 5765
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/SSRSB_Visitor]] (600 root)
[connection] id=SSRSB_Visitor | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=SSRSB_Visitor
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Samsung Galaxy Core 5765 1]] (600 root)
[connection] id=Samsung Galaxy Core 5765 1 | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC 'wlo1' [IF2]> | mac-address-blacklist= | ssid=Samsung Galaxy Core 5765
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/OpenWrt]] (600 root)
[connection] id=OpenWrt | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=OpenWrt
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/The_Watchtower_1]] (600 root)
[connection] id=The_Watchtower_1 | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=The_Watchtower_1
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/HydePatonNetwork]] (600 root)
[connection] id=HydePatonNetwork | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=HydePatonNetwork
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/SSRSB_Visitor 1]] (600 root)
[connection] id=SSRSB_Visitor 1 | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC 'wlo1' [IF2]> | mac-address-blacklist= | ssid=SSRSB_Visitor
[ipv4] method=auto
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/SSRSB-ATV]] (600 root)
[connection] id=SSRSB-ATV | type=wifi | permissions=user:darkstrike:;
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=SSRSB-ATV
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

Region: America/Halifax (based on set time zone)

country 00: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
	(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
	(5170 - 5250 @ 80), (N/A, 20), (N/A), NO-IR
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, NO-IR
	(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
	(5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
	(57240 - 63720 @ 2160), (N/A, 0), (N/A)

##### iwlist channels ###################

lo        no frequency information.

eno1      no frequency information.

wlo1      14 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 14 : 2.484 GHz

##### iwlist scan #######################

lo        Interface doesn't support scanning.

wlo1      Interface doesn't support scanning : Network is down

eno1      Interface doesn't support scanning.

##### module infos ######################

[rt2800pci]
filename:       /lib/modules/4.4.0-79-generic/kernel/drivers/net/wireless/rt2x00/rt2800pci.ko
license:        GPL
firmware:       rt2860.bin
description:    Ralink RT2800 PCI & PCMCIA Wireless LAN driver.
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
srcversion:     26CCED9E0CE5EFBFA9B8882
depends:        rt2x00lib,rt2800lib,rt2800mmio,rt2x00mmio,rt2x00pci,eeprom_93cx6
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 
parm:           nohwcrypt:Disable hardware encryption. (bool)

[rt2800mmio]
filename:       /lib/modules/4.4.0-79-generic/kernel/drivers/net/wireless/rt2x00/rt2800mmio.ko
license:        GPL
description:    rt2800 MMIO library
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
srcversion:     01C1A7641505065E52E0388
depends:        rt2800lib,rt2x00lib,rt2x00mmio
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 

[rt2800lib]
filename:       /lib/modules/4.4.0-79-generic/kernel/drivers/net/wireless/rt2x00/rt2800lib.ko
license:        GPL
description:    Ralink RT2800 library
version:        2.3.0
author:         http://rt2x00.serialmonkey.com, Bartlomiej Zolnierkiewicz
srcversion:     BB9F48B63A82C3FD3E73BAF
depends:        rt2x00lib,mac80211,crc-ccitt
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 

[rt2x00pci]
filename:       /lib/modules/4.4.0-79-generic/kernel/drivers/net/wireless/rt2x00/rt2x00pci.ko
license:        GPL
description:    rt2x00 pci library
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
srcversion:     543B84557258F153AC267F0
depends:        rt2x00lib,mac80211
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 

[rt2x00mmio]
filename:       /lib/modules/4.4.0-79-generic/kernel/drivers/net/wireless/rt2x00/rt2x00mmio.ko
license:        GPL
description:    rt2x00 mmio library
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
srcversion:     ADBE279820CFD0A1081C682
depends:        rt2x00lib
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 

[rt2x00lib]
filename:       /lib/modules/4.4.0-79-generic/kernel/drivers/net/wireless/rt2x00/rt2x00lib.ko
license:        GPL
description:    rt2x00 library
version:        2.3.0
author:         http://rt2x00.serialmonkey.com
srcversion:     72E39180D883A5541F66494
depends:        mac80211,cfg80211
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 

[mac80211]
filename:       /lib/modules/4.4.0-79-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     5EFE430950E66A71D6E20F9
depends:        cfg80211
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/4.4.0-79-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     48C96882CCDC964173BE1D1
depends:        
intree:         Y
vermagic:       4.4.0-79-generic SMP mod_unload modversions 
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[rt2800pci]
nohwcrypt: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

lp

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[   32.164555] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[   32.164709] ieee80211 phy0: rt2x00lib_request_firmware: Info - Loading firmware file 'rt3290.bin'
[   32.523332] ieee80211 phy0: rt2x00lib_request_firmware: Info - Firmware detected - version: 0.37
[   34.139382] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   35.739456] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   35.752507] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[   36.164754] r8169 0000:05:00.0 eno1: link down
[   36.164882] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[   44.224203] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   45.824355] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   47.452448] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   49.056622] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   61.097596] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   62.697740] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   64.313853] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   65.914012] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   78.110859] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   79.723039] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   81.347181] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   82.947261] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   95.088382] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   96.700392] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[   98.344495] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[   99.944740] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  112.101778] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  113.701928] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  115.318012] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  116.918192] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  120.908400] IPv6: ADDRCONF(NETDEV_UP): wlo1: link is not ready
[  122.522639] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  124.122786] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  124.138216] IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
[  125.854908] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  127.454963] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  129.071176] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  130.671320] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  142.096241] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  143.696391] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  145.312505] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  146.916654] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  148.366280] r8169 0000:05:00.0 eno1: link up
[  148.366318] IPv6: ADDRCONF(NETDEV_CHANGE): eno1: link becomes ready
[  159.103347] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  160.714682] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  162.333899] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  163.933239] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  176.092099] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  177.695427] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  179.310657] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  180.918016] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  193.080832] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  194.680204] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  196.295464] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  197.898820] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  210.081650] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  211.688997] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)
[  213.312286] ieee80211 phy0: rt2800_wait_wpdma_ready: Error - WPDMA TX/RX busy [0x00000068] (repeated 2 times)
[  214.915608] ieee80211 phy0: rt2800pci_set_device_state: Error - Device failed to enter state 4 (-5)

########## wireless info END ############
Last edited by darkstrike on Sat Jun 24, 2017 3:30 pm, edited 2 times in total.
JeremyB
Level 20
Level 20
Posts: 11952
Joined: Fri Feb 21, 2014 8:17 am

Re: Stumped! Wifi stopped working - device not ready

Post by JeremyB »

Post results for

Code: Select all

rfkill unblock wifi && rfkill list all
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Was I supposed to run the command sudo? WITHOUT sudo, I get:

Code: Select all

rfkill unblock wifi && rfkill list all
Can't open RFKILL control device: Permission denied

Running that command WITH sudo gives me:

Code: Select all

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
JeremyB
Level 20
Level 20
Posts: 11952
Joined: Fri Feb 21, 2014 8:17 am

Re: Stumped! Wifi stopped working - device not ready

Post by JeremyB »

I suspect power management is at fault even though ifconfig results show it off

Code: Select all

sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
Reboot
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Hi Jeremy,

I had already found and tried the command to disable power saving on the card. It is disabled as we speak. That being said, my WiFi is now randomly working out of the blue, though I have had issues on and off with the connection dropping and requiring a restart or 'sudo service network-manager restart' command to get it going again...?
babyblues409
Level 1
Level 1
Posts: 26
Joined: Sun Jun 05, 2016 10:14 pm
Location: The Lone Star State of Texas

Re: Stumped! Wifi stopped working - device not ready

Post by babyblues409 »

Mine started going bonkers like that the other day too. I was using the B43 driver, not the legacy. I went into the Driver manager and changed it to the "recommended" Linux/Ubuntu driver and solved the problem.
Good Luck!....I think some recent update clobbered the wifi setup.
JeremyB
Level 20
Level 20
Posts: 11952
Joined: Fri Feb 21, 2014 8:17 am

Re: Stumped! Wifi stopped working - device not ready

Post by JeremyB »

You might want to install the 4.10 kernel that is available in the Linux Mint Update Manager, click View then Linux kernels.
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Jeremy, do you mean I should install that Kernel, or babyblues, or both of us?
JeremyB
Level 20
Level 20
Posts: 11952
Joined: Fri Feb 21, 2014 8:17 am

Re: Stumped! Wifi stopped working - device not ready

Post by JeremyB »

darkstrike wrote:Jeremy, do you mean I should install that Kernel, or babyblues, or both of us?
Just you
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Sadly, makes no difference...wifi not working again despite trying the commands I tried earlier and trying the 4.10.0-22 and 4.4.0-78 kernels (was already using 4.4.0-79 as default)...

Sometimes on boot, instead of saying device not ready, it does do the connecting animation and after a minute or two, WILL connect, but it does eventually die again...(this just was on 4.10.0-22 surprisingly)
User avatar
Spearmint2
Level 16
Level 16
Posts: 6919
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Stumped! Wifi stopped working - device not ready

Post by Spearmint2 »

consider the internal wifi may just be failing mechanically. There are Linux wifi USB devices available cheaply at Amazon and EBay. Panda is one, just check the reviews to be sure you get one that is Linux compatible.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

I don't think it's failing as it was working fine a few days ago. I did do a big list of updates the other day through the Update Manager...probably like 20, though not sure what they included. I've already gone back to previous kernels and those made no difference, so could an update have done it? Also doing a quick search shows people with this Ralink RT3290 apparently have a lot of issues with Linux...
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Well...as I don't have any others to test with, ordered a new (used) Intel PCIE half-size WiFi card to replace this one to see if a new one gives the same issues. I've heard Intel and Atheros cards are the best choices for Linux, so I will try that. The new one is also a combo card with bluetooth so it would be nice if I could get both working. Anybody have any other ideas I can try before that one gets here late in the week?
JeremyB
Level 20
Level 20
Posts: 11952
Joined: Fri Feb 21, 2014 8:17 am

Re: Stumped! Wifi stopped working - device not ready

Post by JeremyB »

I think you may have a wireless card that doesn't work well with wireless-N mode enabled on the router for some reason or another
I found a thread on ubuntuforums a while back where it was fixed by using Wireless-G mode on the router
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Might try that...I often do backups over the network from my laptop to a Win10 desktop (and vice versa) so I would miss the faster Wireless N speeds if I had to lose them...will try the new Intel card when it arrives later this week and we'll see! I've actually been on the laptop all morning (typing from it now) and weirdly it's been flawless so far? :S
babyblues409
Level 1
Level 1
Posts: 26
Joined: Sun Jun 05, 2016 10:14 pm
Location: The Lone Star State of Texas

Re: Stumped! Wifi stopped working - device not ready

Post by babyblues409 »

Mine was acting exactly like you describe and after changing the wifi driver as I posted earlier, problem solved. I always keep my system up to date and had done some updates too, as you described.
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

@babyblues: Nothing network related shows up in the Driver Manager for me?
User avatar
trytip
Level 13
Level 13
Posts: 4979
Joined: Tue Jul 05, 2016 1:20 pm

Re: Stumped! Wifi stopped working - device not ready

Post by trytip »

I don't think it's failing as it was working fine a few days ago. this is the understatement of the year, i said the same thing when my marriage broke :mrgreen:
Anybody have any other ideas I can try before that one gets here late in the week?
have you tried to boot with a live usb to see if it is failing also?
Image
User avatar
darkstrike
Level 5
Level 5
Posts: 607
Joined: Fri Jun 03, 2011 5:56 am
Location: Mahone Bay, Nova Scotia, Canada

Re: Stumped! Wifi stopped working - device not ready

Post by darkstrike »

Haha, well, to that end Trytip, it's been working flawlessly since I booted it this morning, weirdly enough - hasn't kicked me off or failed to connect once, and I've also put it to sleep and woke it twice and it worked fine both times there as well....?

No, I hadn't tried it in LiveUSB mode. Right now I am letting it go for a day or two to see if it acts up again, but right now it seems to be working OK...
JeremyB
Level 20
Level 20
Posts: 11952
Joined: Fri Feb 21, 2014 8:17 am

Re: Stumped! Wifi stopped working - device not ready

Post by JeremyB »

A Live USB of LM18.1 may have the same issue but LM18 might work perfectly as there was a change in the network manager to enable wifi power management by default
Post Reply

Return to “Wireless”