<Solved> Ralink RT2790 not working on Mint 18.1

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
gvanhavre
Level 1
Level 1
Posts: 13
Joined: Tue Jul 23, 2013 3:52 pm

<Solved> Ralink RT2790 not working on Mint 18.1

Post by gvanhavre » Fri Jun 23, 2017 5:44 am

Hello, I just installed Mint 18.1 Serena on a LG R410, and the wifi is not working properly. It was working previously on Mint 17, without a single problem. Ethernet works fine, and the wifi is recognizing my home network, it does even ask for the password, but can't seem to connect. I've been reading a lot of solutions on the forums, none of which seem to be effective in my case.

Here is the output of a inxi -Fxz:

Code: Select all

System:    Host: greg-R410-G-BP21P1 Kernel: 4.4.0-81-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: MATE 1.16.1 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.1 Serena
Machine:   System: LG product: R410-G.BP21P1 v: TBD
           Mobo: Quanta model: QL6 v: TBD
           Bios: INSYDE v: QL6L3C52 date: 12/11/2008
CPU:       Dual core Intel Core2 Duo T6400 (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3) bmips: 7981
           clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1600 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.00hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express
           GLX Version: 2.1 Mesa 12.0.6 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-81-generic
Network:   Card-1: Ralink RT2790 Wireless 802.11n 1T/2R PCIe
           driver: rt2800pci v: 2.3.0 bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 04:00.0
           IF: enp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 250.1GB (6.4% used)
           ID-1: /dev/sda model: Hitachi_HTS54322 size: 250.1GB
Partition: ID-1: / size: 227G used: 13G (6%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 3.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 48.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 158 Uptime: 8 min Memory: 348.1/2939.6MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
And a dmesg | grep wlp1s0:

Code: Select all

[   16.954436] rt2800pci 0000:01:00.0 wlp1s0: renamed from wlan0
[   32.071126] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[   32.316650] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[   34.349680] IPv6: ADDRCONF(NETDEV_UP): wlp1s0: link is not ready
[   76.194809] wlp1s0: authenticate with 00:13:10:da:b0:7c
[   76.208540] wlp1s0: send auth to 00:13:10:da:b0:7c (try 1/3)
[   76.210168] wlp1s0: authenticated
[   76.211292] rt2800pci 0000:01:00.0 wlp1s0: disabling HT as WMM/QoS is not supported by the AP
[   76.211297] rt2800pci 0000:01:00.0 wlp1s0: disabling VHT as WMM/QoS is not supported by the AP
[   76.212639] wlp1s0: associate with 00:13:10:da:b0:7c (try 1/3)
[   76.214827] wlp1s0: RX AssocResp from 00:13:10:da:b0:7c (capab=0x431 status=0 aid=3)
[   76.214897] wlp1s0: associated
[   76.214912] IPv6: ADDRCONF(NETDEV_CHANGE): wlp1s0: link becomes ready
[  122.042255] wlp1s0: deauthenticating from 00:13:10:da:b0:7c by local choice (Reason: 3=DEAUTH_LEAVING)
So it looks like it's deauthenticating itself at some point, but I don't really understand... Does anyone have an idea? Thanks in advance.
Last edited by gvanhavre on Tue Jun 27, 2017 5:43 pm, edited 1 time in total.

shneor
Level 1
Level 1
Posts: 5
Joined: Fri Jun 16, 2017 6:10 pm

Re: Ralink RT2790 not working on Mint 18.1

Post by shneor » Sat Jun 24, 2017 2:15 pm

I have exactly the same problem.

shneor
Level 1
Level 1
Posts: 5
Joined: Fri Jun 16, 2017 6:10 pm

Re: Ralink RT2790 not working on Mint 18.1

Post by shneor » Sat Jun 24, 2017 2:22 pm

Sorry, the same problem with the same adapter.

gvanhavre
Level 1
Level 1
Posts: 13
Joined: Tue Jul 23, 2013 3:52 pm

Re: Ralink RT2790 not working on Mint 18.1

Post by gvanhavre » Mon Jun 26, 2017 8:35 am

Some forums suggest it could be related to DHCP... In my /var/log/syslog, i think there is point where DHCP really bugs:

Code: Select all

dhclient[2748]: DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 3 (xid=0xb677d38)
ntpd[1047]: bind(23) AF_INET6 fe80::xxxx:xxxx:xxxx:xxxx%3#123 flags 0x11 failed: Cannot assign requested address
ntpd[1047]: unable to create socket on wlp1s0 (13) for fe80::xxxx:xxxx:xxxx:xxxx%3#123
ntpd[1047]: failed to init interface for address fe80::xxxx:xxxx:xxxx:xxxx%3
avahi-daemon[829]: Joining mDNS multicast group on interface wlp1s0.IPv6 with address fe80::xxxx:xxxx:xxxx:xxxx.
avahi-daemon[829]: New relevant interface wlp1s0.IPv6 for mDNS.
avahi-daemon[829]: Registering new address record for fe80::xxxx:xxxx:xxxx:xxxx on wlp1s0.*.
ntpd[1047]: Listen normally on 14 wlp1s0 [fe80::xxxx:xxxx:xxxx:xxxx%3]:123
ntpd[1047]: new interface(s) found: waking up resolver
dhclient[2748]: DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 8 (xid=0xb677d38)
dhclient[2748]: DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 15 (xid=0xb677d38)
dhclient[2748]: DHCPDISCOVER on wlp1s0 to 255.255.255.255 port 67 interval 20 (xid=0xb677d38)
ntpd[1047]: error resolving pool 2.ubuntu.pool.ntp.org: Temporary failure in name resolution (-3)
ntpd[1047]: error resolving pool 0.ubuntu.pool.ntp.org: Temporary failure in name resolution (-3)
NetworkManager[827]: <warn>  [1455209281.1146] dhcp4 (wlp1s0): request timed out
NetworkManager[827]: <info>  [1455209281.1147] dhcp4 (wlp1s0): state changed unknown -> timeout
NetworkManager[827]: <info>  [1455209281.1474] dhcp4 (wlp1s0): canceled DHCP transaction, DHCP client pid 2748
NetworkManager[827]: <info>  [1455209281.1475] dhcp4 (wlp1s0): state changed timeout -> done
NetworkManager[827]: <info>  [1455209281.1480] device (wlp1s0): state change: ip-config -> failed (reason 'ip-config-unavailable') [70 120 5]
NetworkManager[827]: <info>  [1455209281.1483] manager: NetworkManager state is now DISCONNECTED

User avatar
phd21
Level 19
Level 19
Posts: 9308
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Ralink RT2790 not working on Mint 18.1

Post by phd21 » Mon Jun 26, 2017 4:30 pm

Hi "gvanhavre", & Anyone Else Interested in This,

This is what I could find:

I think if you simply updated / upgraded the Linux Kernel above 4.4, and rebooted, that might solve your issue. Maybe also install "Linux-firmware" stuff from the "Synaptic Package Manager (SPM)" too. You can update / upgrade the Linux Kernel through your Mint Update Manager or installing "ukuu" and using that. I would stay away from unstable "RC" Linux Kernels. Maybe installing Linux Kernel 4.10.16 or 4.10.17, or even a newer Kernel in the 4.11 series, but I would not go to the newest (personally). Keep in mind that if you reboot with any problems, you can just reboot again and go into your advanced options and choose a different previous Linux Kernel.


I do not know how to install the drivers for this adapter. If you need to install drivers for this, Forum member "JeremyB" seems to be an expert with Wifi adapters, so you can contact him...

CONFIG_RT2800PCI: Ralink rt28xx/rt30xx/rt35xx (PCI/PCIe/PCMCIA) support
* found in Linux kernels: 4.5–4.11, 4.12-rc+HEAD
https://cateee.net/lkddb/web-lkddb/RT2800PCI.html

RT2790 Broadband Wi-Fi Legacy Product
Download Drivers - click Linux Penguin icon and download the
"STA_RT2860D-1.2.2.0UI-3.0.0.0_2010_05_18.zip" file
https://www.mediatek.com/products/broad ... -downloads

Device firmware rt2860.bin
https://wireless.wiki.kernel.org/en/use ... /rt2800pci

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

JeremyB
Level 20
Level 20
Posts: 10934
Joined: Fri Feb 21, 2014 8:17 am

Re: Ralink RT2790 not working on Mint 18.1

Post by JeremyB » Mon Jun 26, 2017 4:47 pm

These issues may be fixed by following instructions from chili555 https://ubuntuforums.org/showthread.php ... st13614520

gvanhavre
Level 1
Level 1
Posts: 13
Joined: Tue Jul 23, 2013 3:52 pm

Re: Ralink RT2790 not working on Mint 18.1

Post by gvanhavre » Tue Jun 27, 2017 5:42 pm

I was able to get another solution:

- I just put the IPv4 Settings on Manual
- Added my wi-fi local address, netmask and a gateway.
- Added Google's DNS server, just in case.

Well, it works, but i don't understand why/how.

User avatar
phd21
Level 19
Level 19
Posts: 9308
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: Ralink RT2790 not working on Mint 18.1

Post by phd21 » Tue Jun 27, 2017 6:55 pm

Hi "gvanhavre",

Did you update or upgrade your Linux Kernel? Since Updating or upgrading the kernel is safe to do because you can just boot to advanced options and select a previous Kernel if a new one does not work, I upgraded to the newest one 4.11.7 just to try it and it works great...

Changing your DNS server IP addresses from your local ISP default ones are always a good idea. I would recommend using some that are more secure than Google's though, perhaps from "dns.watch", or "opennic", openDNS, or freenom world, etc...

Hope this helps ...
Phd21: Mint KDE 18.3 & 19, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Fellere
Level 1
Level 1
Posts: 11
Joined: Wed Jan 06, 2016 2:48 pm

Re: <Solved> Ralink RT2790 not working on Mint 18.1

Post by Fellere » Wed Jun 28, 2017 12:29 pm

Have the same problem on two of my machines, they are running Mint 18.1Ralink RT2790.

My mwmory is a bit dusty on Windows stuff right now, but this DNS problem has occurred two times that i know of.
On Win XP sp2 and on Win Vista.

gvanhavre
Level 1
Level 1
Posts: 13
Joined: Tue Jul 23, 2013 3:52 pm

Re: <Solved> Ralink RT2790 not working on Mint 18.1

Post by gvanhavre » Thu Jun 29, 2017 9:14 am

I'm still on an old kernel... 4.4 I think. I don't know if my solution is useful for other users with the same problem, as it seems too simple to be real.

Post Reply

Return to “Wireless”