Page 1 of 1

losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 5:07 pm
by joedog3
I finally managed to get wireless working on my DELL INSPIRON 1521 (laptop) via Linux Mint 18.2 'Sonya' "Xfc3 32-bit". However, if I reboot the machine, not only does the wireless internet not connect automatically, but the laptop doesn't even identify my home network or any other area network

Via internet search, I learned that if I go to the linux terminal and type:
sudo apt-get install firmware-b43-installer && sudo modprobe -r b43 && sleep 15 && sudo modprobe b43

and hit enter, my network will be identified and connection will be established. (The very first time I did this, the machine was doing some manner of 'updates' or something, but after that first time, when I now run the above command, it takes a few moments and gives a line that indicates that everything is updated and running. THEN up comes the internet connection along with identified area networks.

What do I need to do so that connection happens automatically when first boot up the machine.

Thanks,
Joedog3

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 5:12 pm
by JeremyB
Is Linux Mint installed to a hard drive or are using the Live USB/DVD?

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 5:17 pm
by sarge816
Same happens to me but 18.2 Xfce 64bit. My wireless is a cheapo Rosewill N150UBE USB job with the Realtek RTL8188SU chipset. Worked great in LM17.3 Cinnamon, but now it has to be unplugged and inserted into a different USB slot every boot for it to be seen by the PC. I've tried kernel's from 4.4 - 4.10 and they are all the same, no idea why it's doing this now. Ofcourse, it's a bit more problematic for you on a laptop since I can just unplug/plug.

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 5:47 pm
by joedog3
the operating system is installed on the hard drive. thanks.

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 6:00 pm
by JeremyB
Please post results for

Code: Select all

grep ssb /etc/modprobe.d/*

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 6:09 pm
by joedog3
/etc/modprobe.d/blacklist-bcm43.conf:blacklist ssb
/etc/modprobe.d/blacklist-bcm43.conf:install wl modprobe -r b43 b44 b43legacy ssb; modprobe --ignore-install wl ; modprobe --ignore-install b44
/etc/modprobe.d/blacklist.comf:# replaced by b43 and ssb.

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 7:20 pm
by JeremyB

Code: Select all

sudo rm /etc/modprobe.d/blacklist-bcm43.conf

Code: Select all

echo " blacklist wl" | sudo tee -a /etc/modprobe.d/blacklist.conf

Code: Select all

sudo depmod -a


Reboot

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 7:26 pm
by joedog3
AND IT WORKS!

Thank you very much. Well done.

So, what was the deal?

Thanks again,
Joedog3

Re: losing wireless after reboot; requires terminal commands

Posted: Sun Jul 16, 2017 7:53 pm
by JeremyB
I think you may have installed the proprietary driver and it blacklisted the kernel modules needed for the wireless to work. I suspect

Code: Select all

dpkg -l | grep bcmwl

shows bcmwl-kernel-source in the results