Cannot connect to Internet thru Wi-Fi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
aqk
Level 1
Level 1
Posts: 4
Joined: Fri Dec 09, 2011 6:19 pm

Cannot connect to Internet thru Wi-Fi

Post by aqk » Sun Aug 20, 2017 11:08 pm

I just installed Mint 18.2 on a small Lenovo laptop (4 GB, 110 GB SSD) for a friend, and all seems well, except-
How do I connect to the Internet thru Wi-fi? Where is the Icon (or context menu item) for doing this?
In the bottom right corner, there is an icon to bring up items such as "Enable Networking" and "Edit connections" -
which I have done.
Normally there would be a "enable Wi-Fi" menu item, but it is missing.
So now it just sits there mute. Where do I connect?

Please don't ask me elementary questions- I've got the system working great with Grub (and UEFI - BIOS is finally in the trashcan) and
Windows insider Preview connects great to the internet through Wi-Fi.
Mint? Not so well.
I have successively tried using the wi-fi IPV4 settings in mint with DHCP-auto, DHCP-addresses-only and static (Mint seems to call this "manual")
I haven't tried IPV6 yet, But will do so if asked.
None of these work- and yes I have used Google's 8.8... DNS servers too.
So now, How and where do I ENABLE Wi-FI?

User avatar
MintBean
Level 9
Level 9
Posts: 2967
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: Cannot connect to Internet thru Wi-Fi

Post by MintBean » Sun Aug 20, 2017 11:20 pm

Network manager to the right of the bottom panel. Left click on it and there's a slider for wifi.
You should be able to enable WIFI regardless of the proximity of wifi networks, choice of DNS, DHCP configuration etc.

aqk
Level 1
Level 1
Posts: 4
Joined: Fri Dec 09, 2011 6:19 pm

Re: Cannot connect to Internet thru Wi-Fi

Post by aqk » Mon Aug 21, 2017 8:16 pm

re-

Code: Select all

Network manager to the right of the bottom panel. Left click on it and there's a slider for wifi.
NO. There is not.

Code: Select all

You should be able to enable WIFI regardless of the proximity of wifi networks, choice of DNS, DHCP configuration etc.
My apologies if I did not make myself sufficiently clear.
As I said earlier:
In the bottom right corner, there is an icon to bring up items such as "Enable Networking" and "Edit connections" -
which I have done.
Normally there would be a "enable Wi-Fi" menu item, but it is missing.


Currently when I either LEFT-click or RIGHT-click the only items that are "live" in the context menu are-
...
VPN Connections >
...
Enable Networking
....
Edit connections


The Enable Networking item is ticked.
The menu sub-item for Wi-Fi does not show at all. And when I attempt to edit Wi-Fi connections, my router's SSID does not show up.
HA! As I type this, I am beginning to understand the problem:
Perhaps the Wi-fi adaptor is not recognized by Mint?
How do I check for it or enable it? (it works fine in Windows, and in the Mint USB boot install.)

User avatar
mintage
Level 2
Level 2
Posts: 52
Joined: Fri Dec 30, 2016 3:26 pm

configure Wi-Fi connection to find Enable Wi-Fi button

Post by mintage » Mon Aug 21, 2017 10:25 pm

Use teh Edit Connections options and a box shows up with an Add button.
Select Add and select Wi-Fi from the drop-down menu. Select Create.
Name your connection (if you want) in the Connection name box
In the Wi-Fi tab, enter SSID in the appropriate box. I did not change anything else on the Wi-Fi tab.
In the General tab, you have some automatic options that were not important to me.
In the Wi-Fi Security tab, I have a regular setup, nothing industrial or complex, so WPA & WPA2 Personal is a fine security setting for me.
I hope this produces your desired Enable Wi-Fi selector.
* * * * * * * * * * * * * * * * * * * * * * * * *
I made lasagna after this post.
* * * * * * * * * * * * * * * * * * * * * * * * *

Post Reply

Return to “Wireless”