Wifi wpa2 enterprise

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 95
Joined: Thu Sep 24, 2015 3:32 pm

Wifi wpa2 enterprise

Post by tcpip » Fri Aug 25, 2017 8:37 am

Hi all,

I have a mint 18 and need to connect to a wpa2 enterprise network. but I cant login in.

Any ideas?


Code: Select all

System:    Host: host Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.2.6 (Gtk 3.18.9-1ubuntu3.1) Distro: Linux Mint 18.1 Serena
Machine:   System: Positivo BGH (portable) product: i500pro v: TBD
           Mobo: Quanta model: JW2 v: TBD Bios: Insyde v: PR121 date: 05/14/2013
CPU:       Dual core Intel Core i5-3320M (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10375
           clock speeds: max: 3300 MHz 1: 1682 MHz 2: 2030 MHz 3: 2026 MHz 4: 1227 MHz
Graphics:  Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.10hz
           GLX Renderer: Mesa DRI Intel Ivybridge Mobile GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel 7 Series/C210 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card-1: Intel 82579LM Gigabit Network Connection driver: e1000e v: 3.2.6-k port: 3080 bus-ID: 00:19.0
           IF: enp0s25 state: down mac: <filter>
           Card-2: Intel Centrino Advanced-N 6235 driver: iwlwifi bus-ID: 07:00.0
           IF: wlp7s0 state: up mac: <filter>
Drives:    HDD Total Size: 250.1GB (50.7% used) ID-1: /dev/sda model: WDC_WD2500BEKT size: 250.1GB temp: 35C
           Optical: /dev/sr0 model: PIOR DVD-RW DVRTD11RS rev: 1.01 dev-links: cdrom,cdrw,dvd,dvdrw
           Features: speed: 24x multisession: yes
           audio: yes dvd: yes rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
Partition: ID-1: / size: 228G used: 117G (54%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 224 Uptime: 33 min Memory: 1866.7/7849.8MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35
Last edited by JeremyB on Fri Aug 25, 2017 10:19 am, edited 1 time in total.
Reason: code tags added

User avatar
Level 17
Level 17
Posts: 7770
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Wifi wpa2 enterprise

Post by catweazel » Sat Aug 26, 2017 6:55 pm

Your post essentially says "it doesn't work. Any ideas?"

What exactly doesn't work? In what way doesn't it work? How should it work? Are there any error messages? If so, what are they? If this is a corporate network, have you spoken to your organisation's technical people?
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

Level 2
Level 2
Posts: 95
Joined: Thu Sep 24, 2015 3:32 pm

Re: Wifi wpa2 enterprise

Post by tcpip » Tue Aug 29, 2017 8:13 am


Yes is not working, i can't connect I tried all the options I found.


Level 1
Level 1
Posts: 1
Joined: Tue Nov 28, 2017 2:30 am

Re: Wifi wpa2 enterprise

Post by tbote » Tue Nov 28, 2017 2:41 am

On the "Network" window, try the option of "connect to hidden network". In the popup window that follows select ."Wifi security" as "WPA2 enterprise", then in the popup window that follows change the authentication to "PROTECTED EAP" or "PEAP". Type in your username and password and then hit connect. This is just a work around that worked for me. Hope it helps.

Post Reply

Return to “Wireless”