Mint 18.2 laptop won't connect to Wi-Fi

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Post Reply
whois1230
Level 3
Level 3
Posts: 172
Joined: Mon Aug 28, 2017 5:35 am

Mint 18.2 laptop won't connect to Wi-Fi

Post by whois1230 » Mon Aug 28, 2017 5:54 am

Hello dear forum users, I have connection issues on my Dell Latitude E6410 laptop. It won't connect, or when it does, it disconnects itself after a couple of minutes, and then I can't reconnect. I'm connecting to a hidden Wi-Fi network. I turned the Wireless power management off(from "wifi.powersave = 3" to "wifi.powersave = 2") and that didn't help. I'm running Linux Mint 18.2 Cinnamon 64-bit.

Here is the output for

sudo lshw -C network

*-network
description: Ethernet interface
product: 82577LM Gigabit Network Connection
vendor: Intel Corporation
physical id: 19
bus info: pci@0000:00:19.0
logical name: eno1
version: 05
serial: 5c:26:0a:4f:31:1b
size: 1Gbit/s
capacity: 1Gbit/s
width: 32 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k duplex=full firmware=0.12-1 ip=192.168.2.104 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:24 memory:f6900000-f691ffff memory:f6980000-f6980fff ioport:7040(size=32)
*-network
description: Wireless interface
product: Centrino Advanced-N 6200
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlp2s0
version: 35
serial: 18:3d:a2:46:8e:38
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=4.10.0-32-generic firmware=9.221.4.1 build 25532 latency=0 link=no multicast=yes wireless=IEEE 802.11
resources: irq:27 memory:f4100000-f4101fff

User avatar
Pjotr
Level 21
Level 21
Posts: 13861
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by Pjotr » Mon Aug 28, 2017 6:10 am

a. Please generate an overview of your system like this:
- Launch a terminal window (this is how to launch a terminal window);
- make the terminal window full screen, to avoid chopped lines;
- Copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

Press Enter.

Copy/paste the output in your next message.

b. Do the same with the following three commands:

Code: Select all

rfkill list all
and:

Code: Select all

iwconfig
and:

Code: Select all

inxi -Nn
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

whois1230
Level 3
Level 3
Posts: 172
Joined: Mon Aug 28, 2017 5:35 am

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by whois1230 » Mon Aug 28, 2017 12:45 pm

Pjotr wrote:a. Please generate an overview of your system like this:
- Launch a terminal window (this is how to launch a terminal window);
- make the terminal window full screen, to avoid chopped lines;
- Copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

Press Enter.

Copy/paste the output in your next message.

b. Do the same with the following three commands:

Code: Select all

rfkill list all
and:

Code: Select all

iwconfig
and:

Code: Select all

inxi -Nn
inxi -Fxz

Output:

System: Host: user Kernel: 4.10.0-32-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.2 Sonya
Machine: System: Dell product: Latitude E6410 v: 0001
Mobo: Dell model: 0667CC v: A03 Bios: Dell v: A09 date: 05/26/2011
CPU: Dual core Intel Core i3 M 380 (-HT-MCP-) cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10107
clock speeds: max: 2533 MHz 1: 933 MHz 2: 933 MHz 3: 1999 MHz 4: 933 MHz
Graphics: Card: Intel Core Processor Integrated Graphics Controller bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1280x800@60.14hz
GLX Renderer: Mesa DRI Intel Ironlake Mobile GLX Version: 2.1 Mesa 17.0.7 Direct Rendering: Yes
Audio: Card Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.10.0-32-generic
Network: Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e v: 3.2.6-k port: 7040 bus-ID: 00:19.0
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi bus-ID: 02:00.0
IF: wlp2s0 state: down mac: <filter>
Drives: HDD Total Size: 160.0GB (7.6% used) ID-1: /dev/sda model: ST9160414ASG size: 160.0GB temp: 33C
Partition: ID-1: / size: 143G used: 7.7G (6%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 4.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 50.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 229 Uptime: 4 min Memory: 1001.9/3811.5MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

rfkill list all

Output:

0: dell-wifi: Wireless LAN
Soft blocked: no
Hard blocked: no
1: dell-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

iwconfig

Output:

eno1 no wireless extensions.

wlp2s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=15 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off

lo no wireless extensions.

inxi -Nn

Output:

Network: Card-1: Intel 82577LM Gigabit Network Connection driver: e1000e
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 5c:26:0a:4f:31:1b
Card-2: Intel Centrino Advanced-N 6200 driver: iwlwifi
IF: wlp2s0 state: down mac: 18:3d:a2:46:8e:38

User avatar
Pjotr
Level 21
Level 21
Posts: 13861
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by Pjotr » Mon Aug 28, 2017 1:11 pm

Try this:

1. Your kernel needs updating: install the latest kernel of the 4.10 series (-33). Then reboot.

2. Set your router to a fixed wifi channel instead of a dynamic channel.

3. Select the best (least crowded) wifi channel in your router:
https://sites.google.com/site/easylinux ... st-channel
(item 1, left column)

4. Disable IPv6:
https://sites.google.com/site/easylinux ... able-IPv61
(item 2.2, right column)

5. Set the BSSID field to the MAC address of the router:
https://sites.google.com/site/easylinux ... the-router
(item 2.6, right column)
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

MariaWoodson
Level 1
Level 1
Posts: 1
Joined: Tue Aug 29, 2017 2:30 am
Location: Washington, USA

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by MariaWoodson » Tue Aug 29, 2017 2:34 am

I have the same problem. Thanks for all the answers, my dear friends! When my laptop is not connected to Wi-Fi, it is so frustrating!

whois1230
Level 3
Level 3
Posts: 172
Joined: Mon Aug 28, 2017 5:35 am

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by whois1230 » Tue Aug 29, 2017 4:27 pm

Pjotr wrote:Try this:

1. Your kernel needs updating: install the latest kernel of the 4.10 series (-33). Then reboot.

2. Set your router to a fixed wifi channel instead of a dynamic channel.

3. Select the best (least crowded) wifi channel in your router:
https://sites.google.com/site/easylinux ... st-channel
(item 1, left column)

4. Disable IPv6:
https://sites.google.com/site/easylinux ... able-IPv61
(item 2.2, right column)

5. Set the BSSID field to the MAC address of the router:
https://sites.google.com/site/easylinux ... the-router
(item 2.6, right column)
Thank you. I applied 1. and 5. and it worked. My router was already set to channel 11. When I disabled IPv6, I couldn't connect to the network, so I had set it to auto.

whois1230
Level 3
Level 3
Posts: 172
Joined: Mon Aug 28, 2017 5:35 am

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by whois1230 » Thu Aug 31, 2017 5:53 pm

Pjotr wrote:Try this:

1. Your kernel needs updating: install the latest kernel of the 4.10 series (-33). Then reboot.

2. Set your router to a fixed wifi channel instead of a dynamic channel.

3. Select the best (least crowded) wifi channel in your router:
https://sites.google.com/site/easylinux ... st-channel
(item 1, left column)

4. Disable IPv6:
https://sites.google.com/site/easylinux ... able-IPv61
(item 2.2, right column)

5. Set the BSSID field to the MAC address of the router:
https://sites.google.com/site/easylinux ... the-router
(item 2.6, right column)
Hello, I applied the steps from your post and I can connect to my Wi-Fi network now, but sometimes when I shut my laptop down I can't reconnect, and I have to re-enter the SSID and password. The last time I turned my laptop on, I got a black screen prompt with white letters and I could choose from 4 options: start linux, memtest and I can't remember the other 2. I had 30 seconds to choose, or it would choose automatically for me.

TheLion
Level 1
Level 1
Posts: 1
Joined: Sat Apr 28, 2018 3:10 am

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by TheLion » Sat Apr 28, 2018 3:14 am

Pjotr wrote:
Mon Aug 28, 2017 1:11 pm
Try this:

1. Your kernel needs updating: install the latest kernel of the 4.10 series (-33). Then reboot.

2. Set your router to a fixed wifi channel instead of a dynamic channel.

3. Select the best (least crowded) wifi channel in your router:
https://sites.google.com/site/easylinux ... st-channel
(item 1, left column)

4. Disable IPv6:
https://sites.google.com/site/easylinux ... able-IPv61
(item 2.2, right column)

5. Set the BSSID field to the MAC address of the router:
https://sites.google.com/site/easylinux ... the-router
(item 2.6, right column)
Well this worked for me. I updated to the latest kernel of the 4.10 series (-42). Worked like a charm and I am now able to connect to all wireless networks. Thanks

User avatar
Pjotr
Level 21
Level 21
Posts: 13861
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Mint 18.2 laptop won't connect to Wi-Fi

Post by Pjotr » Sat Apr 28, 2018 4:31 am

Good to hear, but my advice was from nearly a year ago.... Now I advise to try the latest kernel of the 4.13 series. The 4.10 series is no longer supported and contains dangerous vulnerabilities (Meltdown/Spectre).
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Post Reply

Return to “Wireless”