no wifi on a clean install

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
dexl
Level 3
Level 3
Posts: 118
Joined: Sat Sep 11, 2010 10:16 am

no wifi on a clean install

Postby dexl » Mon Oct 09, 2017 6:57 am

After a clean install of LM 18.2 Mate on my laptop, I cannot get the wifi to work AT ALL. In the live USB I can go to drivers setting and select the wireless driver and wifi starts working immediately. After installing the system, I did exactly the same thing, but it just doesn't install the driver. The progress bar indicator just sits there forever not finishing the task. I tried it with the USB plugged in, and it just won't install.

Then I searched online for the wireless driver for my card: "firmware-b43-installer_019-3_all.deb", but it had an unmet dependency of "b43-fwcutter_019-3.deb", so I downloaded and installed it as well. To my dismay, even though the installation goes fine in the debi manager, I still cannot connect to my wireless driver. In the drivers settings, the wireless driver still shows up as not selected, nothing happens when I select it and wait (forever!) for it to get installed. It just doesn't.

What am I doing wrong? New users installing LM18.2 will probably not want to use Mint at all, where can I find a solution to this problem? What else can I try? I do have the right drivers, but they don't want to get installed. :(

User avatar
Pjotr
Level 18
Level 18
Posts: 8846
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: no wifi on a clean install

Postby Pjotr » Mon Oct 09, 2017 6:59 am

Hook up to a wired internet connection, launch Driver Manager and install another driver it offers you. Then unplug the wire, reboot and report what happens.
Tip: 10 things to do after installing Linux Mint 18.2 Sonya
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

dexl
Level 3
Level 3
Posts: 118
Joined: Sat Sep 11, 2010 10:16 am

Re: no wifi on a clean install

Postby dexl » Mon Oct 09, 2017 7:39 am

Here's the thing, I don't have an option to connect it to a wired internet. I need a solution where I could download things on a different computer and transfer the files to the laptop that doesn't have wired connection.

User avatar
Moem
Level 11
Level 11
Posts: 3700
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: no wifi on a clean install

Postby Moem » Mon Oct 09, 2017 8:00 am

Or you could get a USB wifi adapter that works under Mint and use that to troubleshoot your existing wifi adapter.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

dexl
Level 3
Level 3
Posts: 118
Joined: Sat Sep 11, 2010 10:16 am

Re: no wifi on a clean install

Postby dexl » Tue Oct 10, 2017 1:49 pm

Moem wrote:Or you could get a USB wifi adapter that works under Mint and use that to troubleshoot your existing wifi adapter.


Hey, I haven't thought of that! That's a great suggestion, thank you!

BTW, I really hope next versions of Mint will have this issue fixed. Clean install no wifi is unacceptable...

JeremyB
Level 17
Level 17
Posts: 7434
Joined: Fri Feb 21, 2014 8:17 am

Re: no wifi on a clean install

Postby JeremyB » Tue Oct 10, 2017 5:29 pm

See https://ubuntuforums.org/showthread.php?t=2316978 if it is just the firmware you need
This is not likely to get fixed as Broadcom will not allow Linux Mint or anyone to distribute their firmware with the Distro

User avatar
catweazel
Level 10
Level 10
Posts: 3331
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: no wifi on a clean install

Postby catweazel » Wed Oct 11, 2017 1:39 am

dexl wrote:Clean install no wifi is unacceptable...

You're shooting the messenger. It's a Broadcom problem.
If your problem is fixed, please mark your thread as [SOLVED] by editing the title of the first message in the thread.

dexl
Level 3
Level 3
Posts: 118
Joined: Sat Sep 11, 2010 10:16 am

Re: no wifi on a clean install

Postby dexl » Thu Oct 19, 2017 6:15 am

JeremyB wrote:See https://ubuntuforums.org/showthread.php?t=2316978 if it is just the firmware you need
This is not likely to get fixed as Broadcom will not allow Linux Mint or anyone to distribute their firmware with the Distro


Does that mean, I won't be able to get LM working on my laptop? Here's the situation: The solution posted above to use a modem to connect to the Internet works but ONLY initially. It worked for one or two boots and now I don't know why, each time I boot the laptop, I get the same thing. Wifi is unavailable, I need to insert a USB modem to connect to the Internet. When I go to drivers, I don't see the Broadcom driver available anymore and everything else is greyed out. What?? Here's a screenie:

JeremyB
Level 17
Level 17
Posts: 7434
Joined: Fri Feb 21, 2014 8:17 am

Re: no wifi on a clean install

Postby JeremyB » Thu Oct 19, 2017 6:29 am

When it doesn't work post results from terminal for

Code: Select all

dmesg | grep b43; rfkill list


Return to “Wireless”