Wifi Works in LM 17 but not under 18.2

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
Zilaba
Level 1
Level 1
Posts: 4
Joined: Mon Oct 16, 2017 3:04 pm

Wifi Works in LM 17 but not under 18.2

Postby Zilaba » Mon Oct 16, 2017 3:51 pm

It is with a heavy heart that I ask for help on such a seemingly basic issue, but after trying and reading some other posts, here I am...

Considering upgrade to Linux Mint 18.2, I made a USB and can boot 'live' on it but the Wifi does not work.
Clicking panel symbol, no networks are listed (there are several in area). It seems that in version 17 I just clicked one.
Not seeing that, I right click, chose "configure network connections" and made a new item of type wifi, entered the SSID from the router. Nothing happened. I edited it and then looked at security, thought to set it to WPA and enter appropriate password.
Now, something is happening - message appears above panel "Failed to get secrets from New 802-11"
I tried a few other things, such as entering a MAC address that I copied by looking at settings in the old version.
Seemed mostly automatic under 17 - no fields to fill except password.

In other posts I got the idea to type into terminal : inxi -N
Which shows this: Network: Card-1: Broadcom BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller driver: b43-pci-bridge Card-2: Intel 82567LM-3 Gigabit Network Connection driver: e1000e
If that's a clue at all.
Any ideas?

comp is a lenovo ThinkCentre.

JeremyB
Level 17
Level 17
Posts: 7440
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi Works in LM 17 but not under 18.2

Postby JeremyB » Mon Oct 16, 2017 4:58 pm

A good chance you had to install package firmware-b43-installer in LM17 to get wireless to work and you will need to do the same in LM18. You could copy the contents of /lib/firmware/b43 to a CD or thumb drive. Then after installing LM 18 create the /lib/firmware/b43 directory and copy the files to it and reboot

Zilaba
Level 1
Level 1
Posts: 4
Joined: Mon Oct 16, 2017 3:04 pm

Re: Wifi Works in LM 17 but not under 18.2

Postby Zilaba » Tue Oct 17, 2017 5:25 pm

I've got materials ready, 1 USB with /lib/firmware/b43 and another USB with LM 18.2.
But, I'm reluctant to try because if I don't succeed I'll really be without i-net.
My other thought is, if this package needed to be downloaded from internet for internet to work, how could I have done it?
Wondering if there's anything else I can do using the _live_ version before I commit to the upgrade.

JeremyB
Level 17
Level 17
Posts: 7440
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi Works in LM 17 but not under 18.2

Postby JeremyB » Tue Oct 17, 2017 5:55 pm

It is possible that the Broadcom proprietary module works. Check the LM 17 install with

Code: Select all

lsmod | egrep 'wl|b43'; lspci -nnk | grep -iA2 net

Post the result

Zilaba
Level 1
Level 1
Posts: 4
Joined: Mon Oct 16, 2017 3:04 pm

Re: Wifi Works in LM 17 but not under 18.2

Postby Zilaba » Tue Oct 17, 2017 6:46 pm

Code: Select all

b43                   387371  0
bcma                   52096  1 b43
mac80211              630653  1 b43
cfg80211              484040  2 b43,mac80211
ssb                    62379  1 b43
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM-3 Gigabit Network Connection [8086:10de] (rev 02)
   Subsystem: Lenovo Device [17aa:3048]
   Kernel driver in use: e1000e
--
11:00.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
   Subsystem: ASUSTeK Computer Inc. WL-138G v2 / WL-138gE / WL-100gE [1043:100f]
   Kernel driver in use: b43-pci-bridge

JeremyB
Level 17
Level 17
Posts: 7440
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi Works in LM 17 but not under 18.2

Postby JeremyB » Tue Oct 17, 2017 7:11 pm

My idea should work when or if you update to LM 18 as you are using the b43 module in LM17 and it needs firmware provided by package firmware-b43-installer


Return to “Wireless”