Linux Mint keeps losing internet connection

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
africanlion
Level 3
Level 3
Posts: 150
Joined: Sun Jul 08, 2012 7:33 pm

Linux Mint keeps losing internet connection

Postby africanlion » Wed Nov 01, 2017 12:05 pm

This happens a lot and especially when i open a new app/program and the internet connection just disappears and i have to reboot

Please help

User avatar
kc1di
Level 10
Level 10
Posts: 3305
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Linux Mint keeps losing internet connection

Postby kc1di » Thu Nov 02, 2017 7:32 am

Give us a little more info to work with.
type the following command in a terminal and post the output (in code tags please).

Code: Select all

inxi -Fxz
John 3:16
Morse code an Early Digital Mode
Registered Linux User #462608
Wireless Script: http://ubuntuforums.org/showthread.php?t=2082305&p=12350385#post12350385
Good terminal command tutorial: https://ryanstutorials.net/linuxtutorial/

africanlion
Level 3
Level 3
Posts: 150
Joined: Sun Jul 08, 2012 7:33 pm

Re: Linux Mint keeps losing internet connection

Postby africanlion » Thu Nov 09, 2017 6:43 pm

Code: Select all

System:    Host: darkchild101-RC522AA-ABU-SR1937UK-GB630 Kernel: 3.13.0-37-generic i686 (32 bit, gcc: 4.8.2)
           Desktop: Cinnamon 2.6.13  Distro: Linux Mint 17.2 Rafaela
Machine:   System: Compaq Presario 061 product: RC522AA-ABU SR1937UK GB630 version: 0nx0411RE101ASTE200
           Mobo: Hewleet-Packard model: Asterope2 version: 1.0 Bios: American Megatrends version: 3.14 date: 05/22/2006
CPU:       Dual core Intel Pentium D CPU (-MCP-) cache: 2048 KB flags: (lm nx pae sse sse2 sse3 vmx) bmips: 12796.9
           Clock Speeds: 1: 2400.00 MHz 2: 2400.00 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RC410 [Radeon Xpress 200/1100] bus-ID: 01:05.0
           X.Org: 1.15.1 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1280x1024@60.0hz
           GLX Renderer: Gallium 0.4 on ATI RC410 GLX Version: 2.1 Mesa 10.1.3 Direct Rendering: Yes
Audio:     Card: Advanced Micro Devices [AMD/ATI] IXP SB4x0 High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-37-generic
Network:   Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too ver: 0.9.28 port: e800 bus-ID: 02:05.0
           IF: eth0 state: down mac: <filter>
           Card-2: Ralink RT5370 Wireless Adapter driver: rt2800usb ver: 2.3.0 usb-ID: 001-004
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 250.1GB (23.9% used) 1: id: /dev/sda model: ST3250823A size: 250.1GB
Partition: ID: / size: 229G used: 56G (26%) fs: ext4 ID: swap-1 size: 1.01GB used: 0.00GB (0%) fs: swap
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 158 Uptime: 3 min Memory: 451.4/938.3MB Runlevel: 2 Gcc sys: 4.8.4
           Client: Shell (bash 4.3.11) inxi: 1.9.17

JeremyB
Level 17
Level 17
Posts: 7423
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint keeps losing internet connection

Postby JeremyB » Thu Nov 09, 2017 6:44 pm

Also post results for

Code: Select all

iwconfig

zb21
Level 1
Level 1
Posts: 10
Joined: Mon Jun 09, 2014 11:56 pm

Re: Linux Mint keeps losing internet connection

Postby zb21 » Fri Nov 10, 2017 7:09 pm

I am having a similar problem of losing the connection using the same driver, rt5370. A difference seems to be that it happens intermittently without any user interaction.

Code: Select all

iwconfig
lo        no wireless extensions.

wlx7cdd90e0ba66  IEEE 802.11bgn  ESSID:"xxxxxx" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: 18:1B:EB:F8:1B:53   
          Bit Rate=65 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=49/70  Signal level=-61 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:734  Invalid misc:357   Missed beacon:0

enp0s7    no wireless extensions.


My general question is what can an end user do when an update seems to cause a rock solid usb wifi device to intermittently lose connectivity other than reinstall 18.1 or perhaps 18.2?

JeremyB
Level 17
Level 17
Posts: 7423
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint keeps losing internet connection

Postby JeremyB » Sat Nov 11, 2017 8:20 am

Wifi power management causing issues

Code: Select all

sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Code: Select all

sudo systemctl restart network-manager.service

zb21
Level 1
Level 1
Posts: 10
Joined: Mon Jun 09, 2014 11:56 pm

Re: Linux Mint keeps losing internet connection

Postby zb21 » Sat Nov 11, 2017 1:32 pm

JeremyB wrote:Wifi power management causing issues

Code: Select all

sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf

Code: Select all

sudo systemctl restart network-manager.service


Thank you, JeremyB!


Return to “Wireless”

Who is online

Users browsing this forum: No registered users and 2 guests