[Solved] Wifi not working after installation

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help
daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

[Solved] Wifi not working after installation

Postby daveoid92 » Mon Nov 06, 2017 11:59 am

I just installed Mint Sonya and my wifi is not working.
I'm a newbie in Linux so i search something on Forums, without success.

rfkill list all says :
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

The driver is Broadcom Corporation: BCM4313 802.11bgn wireless network adapter

Can someone know the problem? Thank you in advance
Last edited by daveoid92 on Sun Nov 19, 2017 11:15 am, edited 1 time in total.

User avatar
JoeFootball
Level 6
Level 6
Posts: 1081
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Wifi not working after installation

Postby JoeFootball » Mon Nov 06, 2017 12:35 pm

daveoid92 wrote:Broadcom Corporation: BCM4313 802.11bgn wireless network adapter

Do you have the proper Broadcom driver installed? For more information, see the "Broadcom chipset: install the driver" section of the "How to solve internet connection problems" article from the Easy Linux Tips Project.

Joe

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Mon Nov 06, 2017 2:50 pm

Thanks for the link
the command lsusb says:

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Bus 001 Device 003: ID 093a:2521 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 5986:0295 Acer, Inc
Bus 003 Device 002: ID 13fe:4100 Kingston Technology Company Inc. Flash drive
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

is the Realtek the card???

oh and iwconfig
wlp4s0b1 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off
but no one of the methods listed here can help me :(

lmintnewb2

Re: Wifi not working after installation

Postby lmintnewb2 » Mon Nov 06, 2017 3:22 pm

Recently enjoyed my first broadcom adventure on gnu/Linux. Had seen many people say it can be a real PITA and yep, for me it was. Believe tried playing with a recent live session of Mint, wasn't the latest but newish and nope my wireless wouldn't work either.

First off would make sure it's enabled and not disabled in the systems bios/uefi-firmware and by hitting any key combo which would ordinarily do that. ie: On my system I can disable/enable wireless by hitting the Fn = function key + F2. Doesn't work ...
Try ( and I'd have had it sorted out in 10mins if I'd had this available.) plugging in your hard wired internet connection cable. That should get you connected even if wireless isn't working. Then check the Mint updater thingy (or software center thingy) for the Install Additional Software/drivers thing. Can't remember exactly how it's laid out and have nothing Minty onboard atm. Might find the proprietary broadcom drivers to get your wireless working offered in it.

Way I had to go about it, due to only having wireless as the only means of connectivity. I used a distro which detected/supported my broadcom wireless out-of-box. Bunsenlabs Linux the Hydrogen release did so no problem. Chrooted the problem install from live-session with it. See that by way of a good resource on the topic. Then I had to install dkms, broadcom-sta-dkms and the linux-headers for the version of the kernel I was using. To get it to build and correctly install the missing proprietary drivers I needed to get wireless working.

So if your hardwired connection is working, install those packages and see if wireless is now going strong doing this with the system cabled into the internet. So you won't have to bother with chroot from live-session etc. What broadcom packages are installed on your OS ? Output of "dpkg -l |grep broadcom" being one step to investigate that. Also see if dkms is already installed, very well could be.

This is a Debian Stretch netinstall, which added a bit of pains to getting it done. Also installed and briefly played with ubuntu 16.04 and after luckily deciding to hit the Fn + F2 key to check if wireless was even enabled on the system, wireless worked out-of-box in it. Though I don't like ubuntu, so quickly found the solution necessary to get it working in what I do like and overwrote buntu v 16.04.

Overall broadcom wireless turned out to be a bit of a pita but not too bad after looking into the topic and finding a fix.

JeremyB
Level 17
Level 17
Posts: 7455
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not working after installation

Postby JeremyB » Mon Nov 06, 2017 5:46 pm

Post results for

Code: Select all

lspci -nnk | grep -iA3 net; rfkill list

I put a BCM4313 in my Toshiba laptop I have Linux Mint on and it worked right away but I know there are issues with some of them

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Tue Nov 07, 2017 1:34 pm

JeremyB wrote:Post results for

Code: Select all

lspci -nnk | grep -iA3 net; rfkill list

I put a BCM4313 in my Toshiba laptop I have Linux Mint on and it worked right away but I know there are issues with some of them

lspci -nnk | grep -iA3 net; rfkill list
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 05)
Subsystem: Lenovo RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [17aa:3975]
Kernel driver in use: r8169
Kernel modules: r8169
04:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
Subsystem: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:0587]
Kernel driver in use: bcma-pci-bridge
Kernel modules: bcma
0: ideapad_wlan: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: ideapad_bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Tue Nov 07, 2017 1:40 pm

daveoid92 wrote:2: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes

why now it is blocked ?! i think i missed something

JeremyB
Level 17
Level 17
Posts: 7455
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not working after installation

Postby JeremyB » Wed Nov 08, 2017 8:36 am

Code: Select all

sudo apt-get remove bcmwl-kernel-source

Code: Select all

echo "blacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist.conf

Code: Select all

echo "blacklist b43" | sudo tee -a /etc/modprobe.d/blacklist.conf

Reboot and wifi should work

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Wed Nov 08, 2017 3:48 pm

JeremyB wrote:

Code: Select all

sudo apt-get remove bcmwl-kernel-source

Code: Select all

echo "blacklist ssb" | sudo tee -a /etc/modprobe.d/blacklist.conf

Code: Select all

echo "blacklist b43" | sudo tee -a /etc/modprobe.d/blacklist.conf

Reboot and wifi should work


All done: checked that the blacklist.conf has the 2 rows added, and the wifi still be here without find nothing!
now i'll try to reinstall the bcmwl driver now with that blacklist, and if it change nothing i'll remove it once more time!
If u have others ways to try, Thank you so much!!!

edit: ok nothing, i'll remove it once more! the blacklist.conf it's unchanged! ty but it still not finding the networks :(

maybe it's of some use the iwconfig ?

lo no wireless extensions.

enp3s0 no wireless extensions.

wlp4s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:off

JeremyB
Level 17
Level 17
Posts: 7455
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not working after installation

Postby JeremyB » Wed Nov 08, 2017 6:07 pm

Uninstall/purge bcmwl-kernel-source, then see the wireless script link in my signature and post results. What model computer is this?

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Thu Nov 09, 2017 4:07 am

JeremyB wrote:Uninstall/purge bcmwl-kernel-source, then see the wireless script link in my signature and post results. What model computer is this?


You mean the link "Wireless script" right?
btw my laptop is a Lenovo Ideapad Z580
i can't put the .txt here, it says invalid format

JeremyB
Level 17
Level 17
Posts: 7455
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not working after installation

Postby JeremyB » Thu Nov 09, 2017 6:08 am

Copy the contents of the wireless-info.txt and paste between code tags
You might want to check your router settings and make sure it is on channel 1-11 as Broadcom cards don't work on 12-14 in Linux

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Thu Nov 09, 2017 12:14 pm

Code: Select all


########## wireless info START ##########

Report from: 09 Nov 2017 09:04 CET +0100

Booted last: 09 Nov 2017 00:00 CET +0100

Script from: 25 Mar 2017 07:04 UTC +0000

##### release ###########################

Distributor ID:   LinuxMint
Description:   Linux Mint 18.2 Sonya
Release:   18.2
Codename:   sonya

##### kernel ############################

Linux 4.10.0-38-generic #42~16.04.1-Ubuntu SMP Tue Oct 10 16:32:20 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Cinnamon

##### lspci #############################

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 05)
   Subsystem: Lenovo RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [17aa:3975]
   Kernel driver in use: r8169

04:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
   Subsystem: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:0587]
   Kernel driver in use: bcma-pci-bridge

##### lsusb #############################

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Bus 001 Device 003: ID 093a:2521 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 003: ID 5986:0295 Acer, Inc
Bus 003 Device 002: ID 13fe:4100 Kingston Technology Company Inc. Flash drive
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: ideapad_wlan: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: ideapad_bluetooth: Bluetooth
   Soft blocked: yes
   Hard blocked: no
2: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

##### lsmod #############################

brcmsmac              573440  0
cordic                 16384  1 brcmsmac
brcmutil               16384  1 brcmsmac
mac80211              782336  1 brcmsmac
cfg80211              602112  2 brcmsmac,mac80211
bcma                   57344  2 brcmsmac
ideapad_laptop         28672  0
sparse_keymap          16384  1 ideapad_laptop
wmi                    16384  1 ideapad_laptop
video                  40960  2 i915,ideapad_laptop

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

enp3s0    Link encap:Ethernet  HWaddr <MAC 'enp3s0' [IF1]> 
          inet addr:192.168.1.137  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::f37e:ca80:c0fc:66a3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1671 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1656 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:755498 (755.4 KB)  TX bytes:288422 (288.4 KB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:172 errors:0 dropped:0 overruns:0 frame:0
          TX packets:172 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:25245 (25.2 KB)  TX bytes:25245 (25.2 KB)

wlp4s0b1  Link encap:Ethernet  HWaddr <MAC 'wlp4s0b1' [IF2]> 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

##### iwconfig ##########################

enp3s0    no wireless extensions.

lo        no wireless extensions.

wlp4s0b1  IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=30 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.254   0.0.0.0         UG    100    0        0 enp3s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp3s0
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 enp3s0

##### resolv.conf #######################

nameserver 127.0.1.1

##### network managers ##################

Installed:

   NetworkManager

Running:

root       944     1  0 08:56 ?        00:00:00 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         enp3s0
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         <MAC 'enp3s0' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0/net/enp3s0
GENERAL.IP-IFACE:                       enp3s0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     Connessione via cavo 1
GENERAL.CON-UUID:                       2437865d-746e-3d66-b1d0-421cd7df1b76
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/0
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     100 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
WIRED-PROPERTIES.CARRIER:               on
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{0}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   2437865d-746e-3d66-b1d0-421cd7df1b76 | Connessione via cavo 1
IP4.ADDRESS[1]:                         192.168.1.137/24
IP4.GATEWAY:                            192.168.1.254
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             213.144.64.1
IP4.DNS[2]:                             213.144.66.1
DHCP4.OPTION[1]:                        requested_ms_classless_static_routes = 1
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_time_offset = 1
DHCP4.OPTION[4]:                        requested_domain_name = 1
DHCP4.OPTION[5]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[6]:                        requested_broadcast_address = 1
DHCP4.OPTION[7]:                        host_name = davide-Lenovo-Z580
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        requested_netbios_scope = 1
DHCP4.OPTION[10]:                       next_server = 192.168.1.254
DHCP4.OPTION[11]:                       expiry = 1510217776
DHCP4.OPTION[12]:                       requested_interface_mtu = 1
DHCP4.OPTION[13]:                       requested_subnet_mask = 1
DHCP4.OPTION[14]:                       routers = 192.168.1.254
DHCP4.OPTION[15]:                       dhcp_message_type = 5
DHCP4.OPTION[16]:                       ip_address = 192.168.1.137
DHCP4.OPTION[17]:                       broadcast_address = 192.168.1.255
DHCP4.OPTION[18]:                       requested_static_routes = 1
DHCP4.OPTION[19]:                       dhcp_renewal_time = 1800
DHCP4.OPTION[20]:                       requested_domain_name_servers = 1
DHCP4.OPTION[21]:                       requested_routers = 1
DHCP4.OPTION[22]:                       domain_name_servers = 213.144.64.1 213.144.66.1
DHCP4.OPTION[23]:                       requested_ntp_servers = 1
DHCP4.OPTION[24]:                       dhcp_lease_time = 3600
DHCP4.OPTION[25]:                       dhcp_rebinding_time = 3150
DHCP4.OPTION[26]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[27]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[28]:                       network_number = 192.168.1.0
DHCP4.OPTION[29]:                       requested_host_name = 1
DHCP4.OPTION[30]:                       dhcp_server_identifier = 192.168.1.254
IP6.ADDRESS[1]:                         fe80::f37e:ca80:c0fc:66a3/64
IP6.GATEWAY:                           

GENERAL.DEVICE:                         wlp4s0b1
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Broadcom Corporation
GENERAL.PRODUCT:                        BCM4313 802.11bgn Wireless Network Adapter
GENERAL.DRIVER:                         brcmsmac
GENERAL.DRIVER-VERSION:                 4.10.0-38-generic
GENERAL.FIRMWARE-VERSION:               N/A
GENERAL.HWADDR:                         <MAC 'wlp4s0b1' [IF2]>
GENERAL.MTU:                            0
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         42 (The supplicant is now available)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.2/0000:04:00.0/bcma0:1/net/wlp4s0b1
GENERAL.IP-IFACE:                       
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   no
CONNECTIONS.AVAILABLE-CONNECTION-PATHS:

SSID  BSSID  MODE  CHAN  FREQ  RATE  SIGNAL  BARS  SECURITY  ACTIVE  *

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

##### iw reg get ########################

Region: Europe/Rome (based on set time zone)

country US: DFS-FCC
   (2402 - 2472 @ 40), (N/A, 30), (N/A)
   (5170 - 5250 @ 80), (N/A, 17), (N/A)
   (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS
   (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
   (5735 - 5835 @ 80), (N/A, 30), (N/A)
   (57240 - 63720 @ 2160), (N/A, 40), (N/A)

##### iwlist channels ###################

enp3s0    no frequency information.

lo        no frequency information.

wlp4s0b1  11 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz

##### iwlist scan #######################

enp3s0    Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlp4s0b1  No scan results

##### module infos ######################

[brcmsmac]
filename:       /lib/modules/4.10.0-38-generic/kernel/drivers/net/wireless/broadcom/brcm80211/brcmsmac/brcmsmac.ko
firmware:       brcm/bcm43xx_hdr-0.fw
firmware:       brcm/bcm43xx-0.fw
license:        Dual BSD/GPL
description:    Broadcom 802.11n wireless LAN driver.
author:         Broadcom Corporation
srcversion:     8C74C05120839730351F55C
depends:        mac80211,bcma,brcmutil,cfg80211,cordic
intree:         Y
vermagic:       4.10.0-38-generic SMP mod_unload

[brcmutil]
filename:       /lib/modules/4.10.0-38-generic/kernel/drivers/net/wireless/broadcom/brcm80211/brcmutil/brcmutil.ko
license:        Dual BSD/GPL
description:    Broadcom 802.11n wireless LAN driver utilities.
author:         Broadcom Corporation
srcversion:     389318E018771B5453D0B02
depends:       
intree:         Y
vermagic:       4.10.0-38-generic SMP mod_unload

[mac80211]
filename:       /lib/modules/4.10.0-38-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     309C9ACED540FCAA1DE7422
depends:        cfg80211
intree:         Y
vermagic:       4.10.0-38-generic SMP mod_unload
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/4.10.0-38-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     D77C8F93375950F3BA95B16
depends:       
intree:         Y
vermagic:       4.10.0-38-generic SMP mod_unload
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

[bcma]
filename:       /lib/modules/4.10.0-38-generic/kernel/drivers/bcma/bcma.ko
license:        GPL
description:    Broadcom's specific AMBA driver
srcversion:     C645ADA4C8790A787B7C8E9
depends:       
intree:         Y
vermagic:       4.10.0-38-generic SMP mod_unload

##### module parameters #################

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac
blacklist ssb
blacklist b43

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[   19.077678] bcma: bus0: Found chip with id 0x4313, rev 0x01 and package 0x08
[   19.077708] bcma: bus0: Core 0 found: ChipCommon (manuf 0x4BF, id 0x800, rev 0x24, class 0x0)
[   19.077734] bcma: bus0: Core 1 found: IEEE 802.11 (manuf 0x4BF, id 0x812, rev 0x18, class 0x0)
[   19.077787] bcma: bus0: Core 2 found: PCIe (manuf 0x4BF, id 0x820, rev 0x11, class 0x0)
[   19.090416] bcma: bus0: Bus registered
[   19.462622] brcmsmac bcma0:1: mfg 4bf core 812 rev 24 class 0 irq 18
[   19.630039] ieee80211 phy0: registered radio enabled led device: brcmsmac-phy0:radio gpio: 499
[   19.630834] brcmsmac bcma0:1 wlp4s0b1: renamed from wlan0
[   25.191607] IPv6: ADDRCONF(NETDEV_UP): wlp4s0b1: link is not ready
[   25.536506] brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
[   25.536553] brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
[   25.537225] IPv6: ADDRCONF(NETDEV_UP): wlp4s0b1: link is not ready
[   25.541338] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[   25.880975] r8169 0000:03:00.0 enp3s0: link down (repeated 2 times)
[   25.881023] IPv6: ADDRCONF(NETDEV_UP): enp3s0: link is not ready
[   26.137880] IPv6: ADDRCONF(NETDEV_UP): wlp4s0b1: link is not ready
[   27.414597] r8169 0000:03:00.0 enp3s0: link up
[   27.414614] IPv6: ADDRCONF(NETDEV_CHANGE): enp3s0: link becomes ready

########## wireless info END ############



ps. i see from another win PC that the channel is 12.... so?

JeremyB
Level 17
Level 17
Posts: 7455
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not working after installation

Postby JeremyB » Thu Nov 09, 2017 2:39 pm

I would definitely change it as the wifi card is working, it just can't find any networks

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Thu Nov 09, 2017 2:53 pm

ok thank you so much! but... how?

JeremyB
Level 17
Level 17
Posts: 7455
Joined: Fri Feb 21, 2014 8:17 am

Re: Wifi not working after installation

Postby JeremyB » Thu Nov 09, 2017 6:06 pm

That really depends on the wifi router on how to change the channel, most have a web interface

daveoid92
Level 1
Level 1
Posts: 9
Joined: Mon Nov 06, 2017 11:43 am

Re: Wifi not working after installation

Postby daveoid92 » Fri Nov 10, 2017 10:40 am

JeremyB wrote:That really depends on the wifi router on how to change the channel, most have a web interface


ok i'll found it myself!!! THANK YOU SO MUCH for having found the problem! :D you're awesome!!!
is there a way to reward you with some positive feedbacks? i dont find anything


Return to “Wireless”